Keyboard/Punctuation AutoCorrect IssueSupport


Last Updated:

  1. BoogieNYC

    BoogieNYC Well-Known Member This Topic's Starter

    Joined:
    Apr 22, 2010
    Messages:
    152
    Likes Received:
    24
    On occasion, I'll be typing (either vertical or horizontal orientation) and I'll hit the punctuation button (not a long-press on the period) to type a dash and the damn keyboard removes the space I typed after the word. So if I wanted to write the following sentence I'd have to hit delete "I never type dashes -- only semicolons."

    Why does the keyboard repeatedly remove the space between the s in dashes and the dash itself? Is there a setting to stop that? Nothing more irritating than speeding along and having to back up because I typed it properly and the device decided to intervene for my benefit. WTF!?!?!?!?!?!

    Aside from switching keyboard applications -- which I don't want to do -- any way to get around this other than hitting delete and retyping it properly
     

    Advertisement
  2. Ed5275

    Ed5275 Well-Known Member

    Joined:
    Jul 10, 2010
    Messages:
    157
    Likes Received:
    99
    Bump. Mine does this, too.

    For example, if I type:

    I'd call that "sucky."

    It comes out like this:

    I'd call that" sucky."

    Any opinions or advice?
     
  3. john0821

    john0821 Well-Known Member

    Joined:
    Jul 25, 2010
    Messages:
    256
    Likes Received:
    11
    I noticed this as well. If I were to type out "red + yellow = green" ... it will auto-correct to "red+ yellow= green" ... annoying to say the least.
     
  4. ezflip

    ezflip Well-Known Member

    Joined:
    Jul 19, 2010
    Messages:
    57
    Likes Received:
    13
    Bump, this is annoying me as well. Even with auto correct turned off, it still does it. I have to type emails with dollar amounts all the time and it always deletes the space between the word and the $. This will cost you $700, always comes out as This will cost you$ 700. Very annoying. Anybody have a fix for it yet?

    BTW, I just upgraded to froyo and it still does it. Please help!
     
  5. Jayme

    Jayme Well-Known Member

    Joined:
    Jul 7, 2010
    Messages:
    362
    Likes Received:
    13
    I just tried this and you guys are correct it does auto correct. I got this work correctly by deleting the quote.

    Example

    If I type That is <space> "honest" It will correct to This is" honest".
    When it auto corrects I backspace delete the quote, then I can type
    This is "honest" without it correcting again.
    Kind of a pain to do but at least it works. :)
     
  6. Brian_83

    Brian_83 Well-Known Member

    Joined:
    Mar 29, 2010
    Messages:
    211
    Likes Received:
    30
    I like it because it works great for punctuation, at least with the 2.2 update. If I'm typing a question and need a question mark I just hit space at the end of my sentence, then the punctuation options come up above the keyboard and I can chose the ? and it puts it right where it goes at the end of my sentence. I think that's why it behaves like this. It also works well for email addresses. When typing the address you type the first part and then space and then get the options for ? @ or whatever. Once I click it it puts it where it goes without any spaces. If it put spaces there it wouldn't be right. I guess we all can't be happy?
     

Share This Page

Loading...