Kies and Galaxy S2General


  1. Trekk

    Trekk Well-Known Member

    Hi,

    I am having difficulties with Kies recognizing my phone, all drivers were installed when I open Kies it just writes connecting with a phone logo and never finds the phone. Tried different cables uninstalled reinstalled Kies still does not work. Can anyone help me with this please

    Feedback would be appreciated
    Thank you

    Advertisement
  2. ironass

    ironass Well-Known Member

    These threads may help you... it seems that Kies can be "flakey" to say the least.

    Hope this helps. :D

    http://androidforums.com/samsung-galaxy-s2/366658-new-kies-update-today-wont-connect.html

    http://androidforums.com/samsung-galaxy-s2/361247-connecting-pc-usb-nothing-happends.html
  3. Trekk

    Trekk Well-Known Member

    Went through both threads still does not work Kies really getting on my nerves was the reason I let go of the Captivate and went to the Nexus now I have difficulties with it again.
  4. ironass

    ironass Well-Known Member

    May I ask what you want to use Kies for?
  5. Trekk

    Trekk Well-Known Member


    I read there is a firmware update
  6. ironass

    ironass Well-Known Member

  7. Trekk

    Trekk Well-Known Member

  8. forkless

    forkless New Member

    I had similar issues with KIES detecting my I9100, issue resolved itself when I put the USB cable into a different USB slot on my laptop.

    So we could be looking at;

    - Faulty USB drivers that are not picked up on the application hub
    - Faulty USB port
    - Particular USB ports not supplying enough power for the device

    So you may want to try to plug it into another USB slot or try a powered USB hub.

    Hope that helps.
  9. Trekk

    Trekk Well-Known Member


    Thank for the help what I did was install old version of kies and seems to have worked
  10. mpsya

    mpsya Member

    I'm having the same problem.

    Could you provide a link to the old version please? Thanks.
  11. Trekk

    Trekk Well-Known Member

    Samsung Kies 2.0.0.11044_11 - Free Samsung Kies Download at Downloadplex.com

    Install this version, also what I did before I boot up Kies I put cellphone in USB debugging mode all drivers were installed in win7. After that I launched Kies plugged the phone back. Took maybe a minute or so for it to recognise the phone. Make sure you don't update Kies when it asks you to. Any questions don't be shy to ask

    Best of luck
  12. Mark Higgins

    Mark Higgins New Member

    I have a solution;
    I'm having exact same problem as many of you, and still have; so what I do now on my galaxy s2 itself is go into 'application' click on 'kies air' it then gives you a URL address to enter on your computer webrowser page (you must be on-line of course) then 'hey presto' you can use Samsung Kies on-line without connecting your USB, it's great!!!!

Share This Page