1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Kies DLL function crashed during installation


  1. mrayvt

    mrayvt New Member

    Tried to install Kies Version 2.3.3 from Samsung and 2.5.0 from Softpedia and both failed during InstallShield Wizard on Windows XP Pro SP3 Laptop with WIFI. See error below. Deleted temp files and kies msi files, etc. Cleaned Samsung and Kies out my registry file. Scan for virus done. Updated Windows. Disabled anti-virus, id vault protection, firewall, sonar protection, etc. Used different drive. Two drives enough space. Nothing changed. Test Installshield ok. The problem points to Samsung Kies DLL file KiesProgressDialog.dll. See KiesInstall.Log below. The error is not clear or doesn't have a solution. Please help me to fix this damn installation.

    Message: Unhandled Exception
    Error Number: 0x80040707
    Description: DLL function call crashed: KiesProgressDialog.KiesLicenseAndPathDialog
    Setup will now terminate.

    [Samsung Kies] OnBegin()
    [Samsung Kies] GetExistFolderPath ==>
    [Samsung Kies] GetKies2InstallFileName(+)
    [Samsung Kies] LaunchAppAndWaitEX() - C:\DOCUME~1\Michael\LOCALS~1\Temp\{D8047BA5-52BF-411E-9AB2-06C2BAF9929C}\WriteDescExecuteFileName.exe Software\Samsung\KIESSETUP Samsung Kies Installer 2.0
    [Samsung Kies] 1
    [Samsung Kies] C:\DOCUME~1\Michael\LOCALS~1\Temp\{D8047BA5-52BF-411E-9AB2-06C2BAF9929C}\WriteDescExecuteFileName.exe Software\Samsung\KIESSETUP Samsung Kies Installer 2.0 - result: 1
    [Samsung Kies] GetKies2InstallFileName(-)
    [Samsung Kies] Kies2Path:D:\Downloads\Kies_2.5.0.12094_27_11.exe
    [Samsung Kies] GetParentPath(+) - szPath: D:\Downloads\Kies_2.5.0.12094_27_11.exe
    [Samsung Kies] GetParentPath(-) - szParent: D:\Downloads\
    [Samsung Kies] OnFirstUIBefore()
    [Samsung Kies] DestroyProcess(+)- DeviceDataService.exe
    [Samsung Kies] DestroyProcess(-)- DeviceDataService.exe
    [Samsung Kies] DestroyProcess(+)- ConnectionManager.exe
    [Samsung Kies] DestroyProcess(-)- ConnectionManager.exe
    [Samsung Kies] DestroyProcess(+)- DeviceManager.exe
    [Samsung Kies] DestroyProcess(-)- DeviceManager.exe
    [Samsung Kies] DestroyProcess(+)- Kies.exe
    [Samsung Kies] DestroyProcess(-)- Kies.exe
    [Samsung Kies] DestroyProcess(+)- KiesPDLR.exe
    [Samsung Kies] DestroyProcess(-)- KiesPDLR.exe
    [Samsung Kies] DestroyProcess(+)- KiesHelper.exe
    [Samsung Kies] DestroyProcess(-)- KiesHelper.exe
    [Samsung Kies] DestroyProcess(+)- KiesTrayAgent.exe
    [Samsung Kies] DestroyProcess(-)- KiesTrayAgent.exe
    [Samsung Kies] DestroyProcess(+)- KiesAirMessage.exe
    [Samsung Kies] DestroyProcess(-)- KiesAirMessage.exe
    [Samsung Kies] szUpgradePath :
    [Samsung Kies] SdKiesCheckConnectedPhone(+)
    [Samsung Kies] Ret: 0
    [Samsung Kies] SdKiesCheckConnectedPhone(-)
    [Samsung Kies] SdKiesSelectLanguage(+)
    [Samsung Kies] Ret: 1 SelectLanguage: 1033
    [Samsung Kies] RemoveKies1_5Process(+)
    [Samsung Kies] RemoveKies1_5Process(-)
    [Samsung Kies] SdKiesLicenseAndPath(+)
    [Samsung Kies] OnAbort()
    [Samsung Kies] OnUnInstallEnd(+)
    [Samsung Kies] DeleteShortcut(+)
    [Samsung Kies] DeleteShortcut(-)
    [Samsung Kies] RemoveKiesRegistry(+)
    [Samsung Kies] RemoveKiesRegistry(-)
    [Samsung Kies] DeleteFolders(+)
    [Samsung Kies] DeleteFolders(-)
    [Samsung Kies] RemoveKies2ProgramRegistry(+)
    [Samsung Kies] LaunchAppAndWaitEX() - C:\DOCUME~1\Michael\LOCALS~1\Temp\{D8047BA5-52BF-411E-9AB2-06C2BAF9929C}\Kies2RemoveAll.exe
    [Samsung Kies] 0
    [Samsung Kies] RemoveKies2ProgramRegistry(-)
    [Samsung Kies] OnUnInstallEnd(-)

    Advertisement
    :
  2. Atma

    Atma Well-Known Member

    Hi mrayvt :wavey: Welcome to the forums.

    I'm afraid I don't have much help for you. I see that XP needs service pack 3 installed for Kies to work. I assume you have that? *edit* Nevermind. I see you have SP3.

    Have you tried Kies from Samsung's site? Version 2.5.0.12094? Tried cleaning out your temp folder? Deleted the Samsung folder Kies creates?
  3. mrayvt

    mrayvt New Member

    Thank you. Hope forums are very useful and helpful.

    After reading your suggestion, I downloaded the latest version from Samsung and got the same error. I deleted all the files under Temp. I used old Fix-It Utilities and just downloaded CCleaner to clean registry and disk. Same error again. I think a better way is to buy an usb wireless adapter to plug my desktop which has Kies installed already.
  4. Pjcruiser

    Pjcruiser New Member

    I am getting nearly the same error. I had a previous version of Kies 1.4.5. I uninstalled it in 2010. Now I am trying to install the latest version with no success. The error I am getting is 0x80040707. MSSetupaddinDll.Deletefolder.

    Any thoughts out there?
    Thanks in advance.
Loading...

Share This Page