Kies/MTP Application crashingSupport


  1. iMouseOne

    iMouseOne Active Member

    Hey all. The first time I connected the phone to my computer with usb set to Samsung Kies, it worked fine. Day 2, now everytime I try and connect the MTP Application screen pops up, then crashes, then pops up again, then crashes, and continues to do so until I unplug. Has anyone else experienced this and fixed it?

    Changing the USB setting to anything else, such as Mass Storage, works fine.

    I've tried on Windows 7 and WinXP with the same result. Drivers are already on the computer from the first time.

    Advertisement
  2. iMouseOne

    iMouseOne Active Member

    TPWarriorDad likes this.
  3. iMouseOne

    iMouseOne Active Member

    Ok, I found a fix for the problem in the Galaxy S forum, use this fix at your own risk, you will lose your media if you do not back up:

    The fix involves formatting the internal sd card. This will wipe out any media you added to the card, so back up your media using the Mass Storage USB setting before doing so.

    Menu > Settings > SD card & phone storage > then under 'Internal SD Card' - Unmount SD card > Format SD Card > Mount SD card."

    Enjoy.
    darsh50, dgnew and TPWarriorDad like this.
  4. TPWarriorDad

    TPWarriorDad New Member

    I had to register just so that I could say THANKS for your helpful post. I spent many hours yesterday and today (including over 2 hours on the phone with "3rd level" support at Samsung and we couldn't figure out the solution to this very problem.

    I Googled/researched the heck out of this until I ran across your post (and the French DailyMotion video you linked to- my phone was acting exactly the same way!), I was stumped.

    But after reading your comments, I simply reformatted BOTH SD cards and now I'm using the Kies software without any problems. Thanks so much. By the way folks, even though I'm in the USA, and Kies software isn't being offered or supported here because Google hasn't licensed Samsung to use it, you can simply go to SamsungApps.com, register your country as "Canada" or other, and then download it from there.

    Works like a charm. Thanks again. Have a great weekend.
  5. iMouseOne

    iMouseOne Active Member

    You're very welcome! Figured I've gotten so much help from forums, I give back when I can.
  6. nalinbhatt

    nalinbhatt New Member

    Thank you very much. I had trouble upgrading to JH2 but after formating SD, it(some how) solved that issue as well.
  7. Jack45

    Jack45 Well-Known Member

    Not to throw cold water on this celebration, but I tried reformatting the internal SD card several times to deal with Kies and the MTP application crashing. No luck. That's why I've become a convert to this linked method to satisfy my focused need to transfer contacts from Outlook to my phone (that's all I wanted Kies for). Easy, painless, and works all the time:

    http://androidforums.com/samsung-captivate/149837-captivate-outlook-contacts-solution.html
  8. naoumis1

    naoumis1 New Member

    I formated both sd crads and still no dice...any help?
  9. Fade

    Fade New Member

    Connect to your galaxy s as a mass storage device. Look for any files with extensions of 16 or more characters. (ie: file.12345678901234567)

    Kies has problems with files with more than 16 character extensions (count after the dot). A lot of programs cache filenames this way. Clear these and kies will connect without having to reformat your SD card.
    gustavohvantol likes this.
  10. bind00

    bind00 Well-Known Member

    Thanks. This is a much better option. I can't believe so many people a perfectly happy to format their drives. Not me. If they have 16-char extensions on their backed up media then presumably the problem would persist after restoring them (?).

    I found a post somewhere that pointed out long extensions in the Seesmic avatar folder. Deleting this slowed the rate at which the MTP application screen crashed from about twice a second to about once every 3-5 seconds.

    I shall try to find other offending files by mounting the drive over USB, opening in Windows Explorer and searching *.?????????????????*.

    ...unless anyone has any better ideas.
  11. gustavohvantol

    gustavohvantol New Member



    Hi,

    i have the same problem with i9000b (brazilian version)
    i fix it deleting some cache files including some files with a long extension.
    i don't remember exactly, but i think that the cause is an file in DCIM folder.

    Thanks all
  12. MarkkuJ

    MarkkuJ New Member

    I found out that in my case simply unmounting the card and then connecting the USB worked like a charm, so no need to format, just don't have it mounted when USBing.
  13. bernell

    bernell New Member

    Need to restore contacts information in my text messaging app in the phone.

    Thanks
  14. Genkido

    Genkido New Member

    Thanks a lot dude!! You saved my life!
  15. dgnew

    dgnew New Member

    ;)

    Thanks, this problem made me crazy.
  16. jackflash14

    jackflash14 New Member

    When i connect my fone via usb cable with kies open it says "kies does not support this file"! I have used kies once to transfer music now everytime I connect it says this! Can anyone help?
  17. rawfa

    rawfa Well-Known Member

    I've tried all options above and this cursed application is still crashing!!!!
    The Galaxy S series is one of the best phones out there but Samsung sucks at supporting it.
  18. jamina1

    jamina1 Member


    My solution to this problem was to remove the external sd card. Once I did that, kies stopped crashing.
  19. extream_13

    extream_13 New Member

    I find that this happen if u have long extension on uour SD card.You just have to find this /(these) file(s) with long extension on your SD card and rename it...
  20. Gelicos

    Gelicos New Member

    Samsung Kies keeps crashing when trying to sync Schedule, contacts and memo, that kept happening since they did the last update. :mad:
    Obviously they don't really test their updates before pushing the updates!!
    I wonder how long Samsung will take to sort this problem out. :rolleyes:
Loading...

Share This Page