1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support Kies says "Your device does not support software upgrading via Kies" when phone is connected


  1. raaamencup

    raaamencup New Member

    Hi all,

    I am new to this forum and I'm encountering some problem when i tried to upgrade my s2 from 2.3.5 to ICS. The phone is unrooted and it was connected to kies via wifi because i wasn't able to connect it to my mac using USB.

    it says that "Your device does not support software upgrading via Kies"
    My phone was unlocked i think and i didnt buy it from any carrier. It was originally KOR but i changed it to TGY because im living in hong kong and i heard that it was what its supposed to be..

    i really want to upgrade to ICS asap but i dont want to root or use other unofficial way as im prone to making my electronics broken :eek::eek:

    this screenshot showed up and i really dont know what it means because im not familiar with these kinds of specs and stuff :confused::confused:

    please help and thanks a lot!

    Attached Files:


    Advertisement
  2. Kie

    Kie Well-Known Member

    Well there's your problem! If you change the firmware/kernel from stock to something else, Kies won't recognise it. The only way to update officially with Kies is to have the official firmware meant for your phone at stock. If you want ICS, you have to wait until KOR updates, or manually flash an official firmware that has ICS.

    Welcome to the forums btw :D

    Edit: I just checked and it seems that KOR have updated to ICS. So you need to go back to KOR first, then Kies can update to ICS.
  3. raaamencup

    raaamencup New Member

    I originally tried upgrading before changing from KOR to TGY but it didnt work either :( I thought KOR means korea so wasnt it the first country to receive the update? Just to be sure what do you mean by kernel and stock? Im sorry i really am new to android ;(
  4. 123test

    123test New Member

    My phone is also KOR. I am not able to upgrade to ICS from 2.3.5 though.
  5. knight6230

    knight6230 New Member

    hey guys
    am new s2 user
    i upgraded to ics and my phone started crashing
    i dont know that much on firmware and these stuff
    i just want to upgrade to an official firmware version

    PDA: I9100XXLPQ
    CSCI9100XXLPD

    AND I CAN'T DO IT VIA KIES
    it says ur phone is not supported for firmware upgrade
    i thing cause i upgraded to unofficial vertion

    please help!!
  6. ironass

    ironass Well-Known Member

  7. grazy37

    grazy37 New Member

    I have problem.
    Once back then, I upgraded accidently from GB to ICS via kies. Then i realized that GB version was a lot better and i wanted to get it back. So i searched info how to get it back, then i found something and i got GB back but its not the original that i had.
    I cannot update this to ICS via Kies etc.

    How do I get back the original version of android that can be upgraded via Kies

    PLEASE, HELP
  8. Anjimf

    Anjimf New Member

    Hi, I just tried upgraing my phone via kies now that i got it back from being 'fixed' as when i got it came with firmware problems.
    I really have no understanding of this stuff but hope someone can help me: Im in Australia.
    its version is:
    PDA: I9100XXKL1
    phone: I9100XXKL1
    CSC: I9100OXAKL1
    This is how they sent it back to me & now kies says it doesnt support upgrade?
    I would really apreciate help thank you.
  9. Slug

    Slug Check six! Moderator

    That may simply be due to the fact that there's no OXA update available yet. Once the 4.0.x update rolls out you should be able to receive it via Kies.
  10. Anjimf

    Anjimf New Member

    Ok thank you. Hopefully thats it, as before it used to connect and just say. No upgrades available, firmware is most current.
  11. pavangattu

    pavangattu New Member

    All,

    I'm also facing same kind of issue “Your device does not support software upgrading via Kies”

    Let me explain what happened exactly:

    1. After 100% charged we get an notification on top stating that 100% Charged , when I unplug the charger after that battery percentage will go down to 95% or 96% immediately as on when unplug the charger
    2. And my S2 was little bit hanging while operating
    3. While charging mobile is getting heat
    Because of all the above reasons I have approached Samsung Servicing Center (authorized) and I was to told that there is problem with Mother Board and needs to be replaced and need to update the OS also,
    After 3 days I got my mobile back with replaced new mother board and software updated, after that also above mentioned (Point 1) issue not resolved and moreover I could see and new issue that, when I tried to connect my mobile to KIES it says that “Your device does not support software upgrading via Kies” and it’s showing only current firmware version and not showing that this is the latest firmware version,
    Not sure what to do, today again I have approached Samsung Servicing Center to take look into that,
    Could someone had same kind of issue, please advice me on this.
  12. Anjimf

    Anjimf New Member

    yeah no luck today by facebook: It is stock but the difference comes because your firmware is the one which s not released for your region. Eg, european firmware on American handsets.

    can anyone help here & if i wanted to flash to local firmware, like for Australia, how do i do it?
    thank you
  13. triforceguy1

    triforceguy1 Member

    Okay, I have an un-modded S2 phone so I haven't done anything internally and it says It does not support Software Upgrading.

    I've tried resetting to factory settings and everything but it didn't work
    I have a feeling that it's because I am still on 2.3.3 but when I go to OTA Updating it says no updates can be found, please could I get some help here?

    PDA - I9100XWKF3
    PHONE - I9100XXE7
    CSC - I9100O2UKG2
  14. ajmount88

    ajmount88 Well-Known Member

    O2 updates are not available OTA. Your CSC code shows that you have an O2 UK branded handset (the same as me). If you connect your phone to your computer and open KIes it should let you update your phone to android 4.0.3 ICS.
  15. triforceguy1

    triforceguy1 Member

    That's where I'm getting the message
  16. triforceguy1

    triforceguy1 Member

    Can anyone help me with this?
  17. LunaticLtd

    LunaticLtd New Member

    I have not done any rooting or whatever to my phone (intentionally...dunno if something I added app-wise did something) but I get the same notification on Kies..."Your device does not support software upgrading via Kies". I did just manually upgrade Kies by downloading the latest version from the Samsung website (Kies won't update internally...downloads it but nothing happens).

    The only apps that I do have on it that *might* be a problem is Advanced SD Card Manager and Android File Manager.

    I didn't think those would root the phone or cause problems. Maybe they don't.

    Any ideas on why Kies is giving me this error?

    I'm on a US AT&T phone (SGH-i777).

    Thanks!
  18. supertausif

    supertausif New Member

    Friends...
    I am from Pakistan and bought my 1st android SGS2 here from Pakistan. I wanted to upgrade my phone to ICS but kies says that your phone is not supported. Here are my phone's details:

    Model number: GTI9100
    Android version: 2.3.3
    Baseband version: I9100XXKDH
    Kernel version: 2.6.35.7-I9100XWKDD-CL161513 root@DELL103 #2
    Build number: GINGERBREAD.XWKDD

    I am totally new about this all. Please help me what is the problem... Please help me friends... Thanks...
  19. beFree

    beFree New Member

    I also cannot upgrade the software via Kies. I bought my Galaxy S2 in Hong Kong, but did not root the phone. It is unlocked. I have never altered or changed the software. I am using a sim card in the mainland China. Any ideas?
  20. mysky911

    mysky911 New Member

    same problem here in Malaysia. I bought it from samsung store. After service center changed my mainboard, my KIES showing :your device does not support firmware!!!!

    I have tried it using others laptop but still same issues.... All those laptops i tried is OK when connected with Galaxy NOTE....

    HELP!!!
  21. ironass

    ironass Well-Known Member

    The chances are that after your repair the Service Point flashed a different, generic, firmware to your phone... this is happening in a lot of cases. It means that your phone is now unable to update via Kies.

    You can either take it to a Service Point and ask them to flash the update or flash the firmware yourself, via Odin. See post #1, here.
  22. nzgooner

    nzgooner New Member

    Hi,

    I am trying to check if my phone can update to ICS, Galaxy Sii

    PDA I9100XXK13
    Phone I9100XXK13
    CSC I9100OXAK13
    Build Sep 15 KST 2011

    I am in New Zealand, have not rooted or anything like that. I cannot update via kies or via the phone itself?

    Thanks
  23. ironass

    ironass Well-Known Member

    OXA firmware is the, "Open Europe", firmware and has been released for ICS.

    See posts #1 and #2, here.

    There are various reasons why you may not be able to update your phone and these are discussed in the above link.

    My advice would be to take it to a Samsung Service Point and ask them to update it for you.
    nzgooner likes this.
  24. danatoakhill

    danatoakhill Member

    Hi all,

    I know this sounds like a stupid and simple question...maybe it is, but I'm trying to find the right stock firmware / kernal for my GT-i9100.

    I flashed to ICS before it was released, now want to update to official version via kies...so I flashed to this with odin (downloaded from samfirmware.com)

    PDA: i9100BOKK1
    PHONE: i9100BOKJ1
    CSC: i9100TMUKK1

    But when I connect to kies it still says the 'device software does not support updating via kies'.

    I've tried flashing lots of other gingerbread firmwares from samfirmwares.com (need gingerbread so kies detects it needs updating).

    Really stuck here. Is there something else that can cause kies to give that error, or is it definitely that I've got the wrong stock firmware?

    If so, is there a sure fire way to get the right one? I've tried the xda branded firmware list, that's where I got the link for this firmware above.

    Please help!
  25. darengive

    darengive New Member

    1. changed the CSC from KOR to XEU which is UK/Ireland using an app in the Play Store, search for CSC....
    -this will factory reset the phone
    2. Downloaded the official ICS firmware for XEU check here SamMobile Firmware Page
    3. Flash using Odin using instructions from The Realm of Facts!!
    4. ICS ready...

Share This Page