Killed my screen on android 2.3 superpad 3Support


  1. kenc0

    kenc0 New Member

    i have the android 2.3 superpad 3 and like upbeatpaul killed my screen. tried holding the menu and back panel buttons but didn't work. don't know if i just press both and release or hold until screen lights up. do i press power button first then the other two or all three at the same time? also tried the mini hdmi and that did't work. also tried just holding menu button and then powering up. still nothing. Need to reset to factory. any ideas?

    Advertisement
  2. dart16

    dart16 Well-Known Member

    The procedure for Disco models is holding menu (on the top of the tablet) and back (which is on the front of the tablet), and then, while you have these two pressed, press the on button until the screen lights up, once you see 'update' or 'reset' or something like that you can let the back and menu buttons go.

    I thought the buttons for the 2.3 models was 'back' and 'home', then press on??? try that!
    kenc0 likes this.
  3. kenc0

    kenc0 New Member

    When working correctly the screen shows in sequence the following: robot/small penguin in upper corner/small word android/large word android then opens with widget screen.
    Tried power/home/back: screen just flashes robot w/buzz until I release, then shows above sequence but with blank screen instead of widget screen. No reset.
    Tried power/menu/back: screen freezes robot until I release, then shows above sequence. No reset.
    Tried power/vol +/back: screen shows robo, then shows above sequence. No reset.
    Tried power/vol -/back: screen shows same as vol+.
  4. dart16

    dart16 Well-Known Member

    Pressing buttons with the power on is not going to fix it. You are trying to get the tablet into a mode where it will look for update files held on the tf card, to do that there is a key sequence that involves holding two buttons down and then pressing the power button to turn the tablet on, not pressing the power button first. Perhaps you would be better off reading
    This thread which is more to do with your version...
  5. kenc0

    kenc0 New Member


    Thanks for the thread.

    Sorry if i was unclear. I meant i tried holding down the second 2 buttons then the power button (release power when starts) at the same time. Was writing fast and trying to save space instead of giving clear information. will do better in the future.

Share This Page