Kindle Fire HD 7" working playstore


  1. PRallday168

    PRallday168 Well-Known Member

    Working Playstore for the Kindle Fire HD 7"
    [​IMG] I am in no way responsible for what you do to your phone. Use at your own risk!

    Now ive read a bunch of different posts on how to make this work and this seems to work the best for me.

    1.Make sure you have ES file explorer downloaded from the amazon appstore



    2.Download this package https://dl.dropbox.com/u/88552195/Playstore%20files.zip







    3.Extract the zip to a folder in your downloads so you wont get confused.


    4.Open ES file explorer and go to setting>Root settings, and check root explorer and allow super user,up to root, mount file system.



    5. now go back to the folder where you extracted the files and touch and install GoogleServicesFramework.apk and once it finishes installing, power off kindle and power back on kindle.



    6.now go back to the folder and cut the vending.apk and move it to system/app folder and paste it there.



    7.long press on the vending.apk and select properties>change permissions and make sure that User: read, write are checked....Group: read.... Other: read.




    8.now tap on the vending.apk and press ok to replace and install.



    9.now go to home>apps>market and sign in to google(must do this first because it will not work without signing in)



    10.now go back into the folder where we first extracted the files and press and install the gplay.apk and BOOM your done! restart the kindle once more just to make sure everthing went right.



    post your questions here if you need help on how to install.

    Advertisement
    DeadWeird, raynoldsk, Alanya and 3 others like this.
  2. marthal222

    marthal222 Member

    I have a Fire HD, v. 7.2.3 - I have ES file explorer, from the Store. You state "Open ES file explorer and go to setting>Root settings, and check root explorer and allow super user,up to root, mount file system." I open the explorer and it takes me directly to the 3 files that I just extracted. How to I get to "setting>Root settings"? And once there, it will be obvious how to "check" "root explorer", and Superuser to root, and "mount file"? I see these in ES, under "Settings">"Other Settings">"Root settings" - first one is "Root Explorer", and when I check" it, it initiates the process, but the result is "sorry, test failed . . ." The next one is "Up to Root", and when I tap on it, the green "check" appears in the box. The next one is "Mount File System", and when I tap on it, nothing happens. This is my experience thus far.
  3. marthal222

    marthal222 Member

    Not knowing how to do step 4, I went ahead to step 5 and installed GSF apk. I didn't get any error messages.
    Then going to step 6 - how do you cut "Vending.apk", and then paste it into the "app" folder in "System"? - how do you "cut" and "paste" ?!! :)
    Step 7 - I understand what "long press" means, but is that done after "Vending" is pasted into "app" in "System"?
    Step 9 - "home" means the bldg in the lower right corner? and "apps" means the "Apps" tab on the home screen? and "market" means . . ? and once there, because I have not yet been there (I don't think), it will be obvious how to sign in to google?
    I hope my request for more refined detail is not obnoxious. I am computer literate (PC), but totally new to tablets and maneuvering inside.
    Willing to learn -
    Thanx
  4. ChudleyOne

    ChudleyOne Well-Known Member

    To get the Root Settings working correctly, it appears you need to have rooted your device before attempting to install the Playstore. Try following one of the other threads about rooting & try this tutorial again. That should get the other steps working.
    marthal222 likes this.
  5. PRallday168

    PRallday168 Well-Known Member

    Are you rooted? because in order to go ahead and complete this tutorial you must have root access to the device. let me know.
  6. PRallday168

    PRallday168 Well-Known Member

    correct. i will also update my thread on rooting as it seems now the 7.2.2 and 7.2.3 update has a different method of rooting.
    marthal222 likes this.
  7. marthal222

    marthal222 Member

    Appreciate the insights, folks. Because ownership is new, with not a whole lot to lose, I am going to re-set the HD, and start from square one again. In this process, besides using the "re-set" button, are there any other steps I ought to follow in order to properly and completely reset?
    Given that I do have v. 7.2.3, I would greatly appreciate a step by step, starting with rooting, then moving on to Playstore, and the other xlnt resources. With the HD rooted, and Playstore installed, are there apps that I should avoid - which might conflict with it? Is there a repository of apps that don't play nice on a rooted HD? Is there a repository of xlnt apps for a rooted HD? I'd additionally like to know how to do the referenced "cut" and "past" routine on an HD. Again, I'm computer literate, but these tablets do have a mind of their own.
    Thanx again - i appreciate the cooperation and kind attention
  8. PRallday168

    PRallday168 Well-Known Member

    not a problem at all. a fresh start would be nice, just to make sure we get you up to par :D . my device right now is bricked at the moment, as i was testing some apps that obviously didnt play well with. lol! currently waiting for my factory cable to be sent to me. on another note. pm me so we can root and install gapps succesfully on your KFHD. ill be glad to help.
    marthal222 likes this.
  9. marthal222

    marthal222 Member

  10. PRallday168

    PRallday168 Well-Known Member

    im working on a step by step guide with links and personal downloads so everyone can see how i did it. If you cant wait until about 8 pm eastern time thatll be great! im still at work and wont be home untill then to post it. i dont want you to brick your device, that will be a pain in the hind.!
  11. tearshade

    tearshade New Member

    Any idea why when I try to open it, it closes and says "Google Play Store has stopped." and in the background I can see accept and decline buttons, but can't click them because they go away once I click okay?
  12. PRallday168

    PRallday168 Well-Known Member

    when you first installed market did you sign in to your google account and then installed gplay ?
  13. dchester11

    dchester11 New Member

    Should I be able to load Google Maps after this? When I browse for it in the app store it says 'Your device isn't compatible with this version'.
  14. Inksaver

    Inksaver Well-Known Member

    I have just tried to install Google Maps on Bluestacks (An Android emulator running on PC) with the intention of sideloading it to the Kindle.
    The app runs, but no maps are displayed. I am wondering whether this app only runs on a device with gps, which obviously my desktop PC (and Kindle?) do not have.

    I will not take the next step to test here as it looks to be doomed from the start.

    As a sidenote, anybody wanting to check out an app before committing it to their Kindle I would recommend installing and using Bluestacks on your PC. After all if it goes wrong and Bluestacks no longer runs: Control panel>-Programs and Features>-Uninstall fixes it immediately!

    http://bluestacks.com/

    WARNING: Do not install Bluestacks if you are considering rooting your Kindle, as rooting will not work.
  15. svenEsven

    svenEsven New Member

    for whatever reason i cant get SU to allow file explorer root access, ive even set SU to automatically accept all requests temporarily. any info on why this would be happening?
  16. PRallday168

    PRallday168 Well-Known Member

    you can side load it but itll be of little to no use as the 7" kindle fire hd doesnt have gps. on another note the 8.9" 4g lte kindle fire hd comes with gps incase anyone here has one.
  17. PRallday168

    PRallday168 Well-Known Member

    try wiping cache and data from ES File manager then uninstall then reinstall and try again to get root access. this happened to me and that seemed to fix it. let me know if that helps.
  18. professor egghead

    professor egghead New Member

    Thanks so much for the helpful instructions. I followed them. Then it still wouldn't open. So I deleted the vending.apk file from system/app and moved the gplay3.8.17 file there. It's worked perfectly since. Not sure exactly what made it work right but anyway the issue is fixed. Thought maybe this could help someone else. Thanks again!
    Professor egghead
    PRallday168 likes this.
  19. PRallday168

    PRallday168 Well-Known Member

    Glad it worked !. I guess you can put Gplay in system/app. never tried it but if it worked for you than thats awesome!
  20. Petyofi

    Petyofi New Member

    Hello and first of all thank you for creating this guide!

    I have encountered a problem following the steps, though.

    At step #4:
    "Open ES file explorer and go to setting>Root settings, and check root explorer and allow super user,up to root, mount file system."

    I have ES File Explorer v3.0.1 and there is no such sub-branch "Root Settings" and therefore no "Allow Super User", "Up to Root" and "Mount File System" options.

    From the app menu I selected Tools > Root Explorer and after a click managed to allow super user. I can also successfully browse the Root directory and any of its subfolders.

    Step #6:
    "now go back to the folder and cut the vending.apk and move it to system/app folder and paste it there"

    What remains unachieved is "Mount File System", which I guess is the reason why any of my attempts to copy or cut the "Vending.apk" file into the "system/app" directory always fail.
    The file and the involved folders are all "read/write" enabled and yet I can't complete the action.
    The message which appears when trying to paste is "com.estrongs.fs.FileSystemException: Permission denied"

    I have also tried moving the "Gplay3.8.17.apk" file in the "system/app" folder but without success.
    Several times I have restarted the tablet, reinstalled the ES File Explorer, cleared its cache, but all that has changed nothing.

    Any help with my issue is greatly appreciated!
    Thank you in advance!
  21. PRallday168

    PRallday168 Well-Known Member

    Sorry to hear that ! Uninstall your current ES explorer and download this one. https://dl.dropboxusercontent.com/u/88552195/New folder/es_file_explorer_v1.6.2.5.apk. this is the one i used. it has the root menu! hope this helps!
  22. TomXP411

    TomXP411 Well-Known Member

    Hi, all.

    Has anyone had problems signing in to their Google account? I can do everything up until this point... and I get an error: "Can't establish a reliable data connection to the server."


    *edit*
    Turns out that I needed to toggle WiFi: just turn wireless off, then turn it back on. Sycned right up. Now I'm waiting for the Market screen to load... (white screen with loading prompt)
  23. PRallday168

    PRallday168 Well-Known Member

    yeap usually thatll do the trick. if anything, uninstall google play and reinstall it. (wipe cache and data first from playstore)
  24. Petyofi

    Petyofi New Member

    PRallday168 likes this.
  25. PRallday168

    PRallday168 Well-Known Member

    no problem! The new ES file explorer does have root menu but its kind of hidden with all the new features theve added. to get there, just look for Tools>root explorer and toggle it on and mount system R/W . this will do the trick in the future. Root explorer is a good app also! :D. Glad it worked for ya !

Share This Page