kINGSTON 16gb SDC4 card error?


Last Updated: 2013-02-02 18:08:46
  1. Azizov

    Azizov New Member

    Hello everyone,

    i own motorola motoluxe, it has been a pretty good phone so far. The only problem was 2gb memory card that eventually want enough. Today i got a new sd card(kINGSTON 16gb SDC4 card). I tries to install a few apps thinking that i will never run out of memory again. But unfortunately all the apps i download show me 1 of the 2 error messages: The file was not signed correctly or The application crashes. I restarted the phone a dozen times, but its the same. I put back the old sd card which is sandisk 2gb. Thats works like a charm...

    Has anyone had a similar problem? Do you think my problem will be solved if i get another brand like sandisk?

    Advertisement
  2. The_Chief

    The_Chief Accept no imitations! Moderator

    Hi Azizov and welcome to Android Forums!

    Wow, SD card issues. I can't stand that... I had a card go out on me once - just died! Thankfully I had everything backed up to the PC and lost very little. Replaced it with a 32GB card that quickly filled up! :eek: Still, back to your problem...

    This could be a format issue or a bad card. You can try formatting the card and trying it again. And you could try another card to isolate the problem. A Class 4 card should not be acting up.

    Hope this helps. If you would like, I can move this to the Android Lounge where more eyes will be on the issue... just let me know.

    It's great to have you aboard! :)
    Azizov likes this.
  3. Azizov

    Azizov New Member

    Thank you The_Chief. It's very annoying to have such a stupid problem :(. And, i ve already tried formatting the card, from my phone and also from my computer. But still get the same thing. Did you get yours to work after formatting? If so, how did you format it?

    And that would be awesome if more people saw this!

    I will change the card in 1 or 2 days if it keeps acting like that
  4. The_Chief

    The_Chief Accept no imitations! Moderator

    Okay Azizov, you are now in the Android Lounge :)

    And no, the 16 GB card never worked again. Maybe I just hit the end of its maximum read/write cycles or something (I DID root and ROM my Droid quite a bit). But the 32 GB Sandisk has done me well... of course now my Nexus doesn't use an SD card at all, so the card's in standby.

    Good luck and let us know how it turns out :)

Share This Page