kktkat update made my s4 unusableSupport


Last Updated: 2014-04-25 17:18:40
  1. gsfrider

    gsfrider Member

    Hi
    Since I updated my s4 to kitkat the only thing I can do without problems is make calls, main problems are
    Phone won't recognise my sim except to make calls
    Bluetooth switches itself on & off constantly
    Every app stops as soon as it's opened
    Phone constantly freezes
    When I write anything my phone alters what I've written to ineligible words
    I have tried several things ie clearing the cache & even a factory reset did more harm than good as since then my battery drains very quickly,
    Even Samsung themselves don't seem to know how to solve my problems so any help would be very much appreciated, thanks

    Advertisement
  2. ironass

    ironass Well-Known Member

    Thank you for your post.

    There are currently 23 different models of the Samsung Galaxy S4 and over 1,000 different stock Samsung firmware versions, worldwide, covering 3 different Android platforms. Not all issues will affect all models or firmware releases and your answers to the following question/s will help in the forum's answers to your specific query.

    #1 Could you post your Model number and Android version...

    To locate these, go to...

    Settings > More > About device > Model number and Android version

    This will give you the model of Samsung Galaxy S4 that you have and which Android version you are on.


    #2. Your current Firmware, (not just Baseband), version .

    To locate your current firmware version, go to the stock, Samsung, dial pad and type in...

    *#1234#

    This will give you your, "Version", details in full, usually 3 lines of information, AP: CP: CSC:, which may all be relevant.

    *** If code *#1234# has been disabled on your firmware, you can download and install, free from the Play Store, Phone Info and it will give you, under Firmware Info... PDA, Baseband, CSC, versions.


    #3. Also helpful would be your carrier, (service provider), location, (UK, India, Russia, USA, etc: ), and if your phone is rooted or not and running a custom ROM, (give details).


    Thanks. The above helps us to help you and hopefully someone will be able to reply to you shortly. :)


    For more information, see, http://androidforums.com/samsung-galaxy-s4/760098-23-galaxy-s4-models-know-yours.html#post6099681

    (Tip: You can go to the green bar at the top of this forum and click on, "User CP", which will take you to your User Control Panel and then select, "Edit your details", under the heading, "Your profile", on the left hand side. Here you can fill in your model and firmware under, "Current devices", in, "Additional Information". This ensures that your device details are shown under your user name on the left, in every post you make. You can update this as often as you like and will help other users immediately identify your current phone and firmware details.)
  3. dynomot

    dynomot Well-Known Member

    gsfrider has appealed to my better nature as a bored (fed up with the lack of proper action in the Note 3 Forums) former SGS4 owner to see if I can help him out by PM. As a student of the "Three Wise Men" (no names, no pack drill ;) ), of even numbered Samsung Galaxy phones I feel confident I can sort him and his errant device out........

    However, watch this space.

    Sees Ironass running to pub, Hawker rolling a large boulder across the entrance to Wales, and Syd, well, just being Syd.
  4. ironass

    ironass Well-Known Member

    Just a thought dynomot old fruit... but helping people out by Private Messaging does not really help any other forum users who may have similar problems and could benefit from your answers, does it? ;)
  5. dynomot

    dynomot Well-Known Member

    Does if I copy and paste and edit :)

    Seriously, We're hopefully (if he gets back in touch) going to sort the phone out via a Skype chat, in Real time. I have an evening free from not installing fun things on my Note 3 Hobbit tablet, where I have once again been forsaken by my other half in her persuit of the mortgage payment (work - she is on nights). The kids are safely tucked up in bed and I have a day off tomorrow.

    Now usually that would be the perfect opportunity to do a Nandroid and have a play, bork my phone and spend until two in the morning sorting it out, but the lack of decent looking ROMs and kernels (Xposed already installed with the tweaks I want) for the Note 3 means I can't have half as much fun as you lot are having with the SGS4.

    I'm seriously looking in to buying an SGS4 and flogging my Note 3, just because of the lack of mods and tweaks.

    Great device my Note 3, stunning even and I love doodling work the S-pen, using split screens and watching TV and films on it. I'd go back (sideways? ) to an SGS4 in a heart beat simply because of the dev support there is for it. I'm just waiting until they drop in value with the advent of the SGS5 and hopefully I can pick a mint second hand one up for around
  6. gsfrider

    gsfrider Member

    My model no is gt-19505
    Android version is 4.4.2
    Firmware is
    Ap 19505xxufnb8
    Cp 19505xxufnb8
    Csc 19505btufnb3

    My carrier is EE in the UK

    Thanks
  7. dynomot

    dynomot Well-Known Member

    Excellent, let us begin (dons surgeons gloves with a snap). I intend to show you how to wipe your phone entirely and start again. Hopefully ending up with your phone as if it is fresh out of the box running KitKat with no issues whatsoever.

    First start with a fully charged phone. It can be charging while my Dropbox folder gives you the EE firmware and the Odin PC application you need to flash it.

    Here is the link for the .tar.md5 file, which is the latest EE 4.4.2 (KitKat) firmware for a Samsung Galaxy S4 (GT-i9505) It comes in a .zip folder and will need unzipping/extracting download it to your desktop and unzip/extract it to there by double clicking it:

    LINKS REMOVED SEE IRONASS' POST.

    Here is Odin V3.09 a PC application you will need to flash the firmware to your phone dowload and save both files in this link to a desktop folder called "ODIN V3.09" you create yourself:

    https://www.dropbox.com/sh/q29x3tv7l5j6epj/7CaOVqd6xB/Odin_v3.09

    Please do not share these links, even though they are on a public forum. Dropbox get rather uppity and will suspend my public folder (again). I will take them down after a while and if you do not have them by then PM me with an email addy and I'll send them to you.

    OK. Once you've done all of the above and your phone is fully charged copy all the media off of your phone you want to keep to your PC so you can get it back after you have successfully flashed, this includes your removable memory card if you have one as well. Now turn off your phone and wait until it shuts down (remove it from PC if still attached first). Remove the SD card if you have one.Now go into "Recovery mode" by pressing and holding in this order all at the same time starting with Volume up, then home and finally the power button. Keep them all pressed until you get a buzz and the Samsung GT-i9505 screen and release all three. Now using volume up and down navigate to clear cache and use home key to select, then do a factory reset (warning this will wipe your phone). Now from recovery go to reboot and once rebooted shut it down again.

    Now on the PC make sure Kies is not running (you need it installed for the drivers to connect your phone to Odin.), if it is not installed install it from Samsung here :

    Kies | Samsung UK

    and then run it once.

    Make sure it is fully closed including any of it's processes via windows task manager.

    Now from the Odin V3.09 folder you made right click the Odin .EXE file and run it as administrator. On opening it will look like this :

    [​IMG]


    Turn your phone on and wait until it boots. Now from a home screen go Menu>settings>general>about device(bottom option) and the bottom piece of information is build number tap on this repeatedly (seven times if memory serves) until you get a toast message saying "your a developer". Now go back and a new option called "developer options" is there, select it and check the "USB debugging" option. Go back to a home screen and shut down.

    Now go into download mode on your phone. From phone completely off press and hold volume down + home key + power. Press them in that order and keep them all pressed until you get the warning screen about a custom OS, press volume up to continue to download mode. which looks like this :

    [​IMG]

    Now connect your phone and Odin will connect and look like this :


    [​IMG]

    Now check the AP tick box in Odin and click the AP button, browse to the .md5 firmware file saved on your desktop. select it and now Odin, once it has done the md5 checksum checking will look like this (ignore the file name on this screenshot shown to the right of the AP box, that is for a Note 3. I used my phone to do this screen shot as I haven't got an SGS4 any longer. Be sure the processes explained in this post are identical apart from this one detail) :

    [​IMG]

    Now making sure these check boxes are ticked ONLY THESE, NO OTHERS(VERY IMPORTANT) press start.

    [​IMG]

    The phone will then be reflashed with EE firmware version 4.4.2 (KitKat). Odin will do a running commentary in the left hand box and will end with the word "Reset". Your phone will then reboot (it can take a while on it's very first boot, don't worry) you can then unplug the phone and close Odin.

    Your phone is now as it would be when first ever turned on and all your problems should be sorted. Reformat your memory card in the phone, and connect the USB to copy back your media. At this point I would suggest only re downloading your apps one at a time and testing them one by one. It could be the source of your problems is a rogue app that is not yet updated to run correctly in KitKat, but it can be uninstalled if this is the case.

    Good Luck, this is a little drastic, sounds difficult (but isn't once you've done it once) and will teach you much about your device just doing it. If you still have issues (which I seriously doubt you will) it may be your device itself is at fault. I recommend a warranty claim (Your warranty will still be valid doing all of the above), as the phone itself could be faulty.
  8. ironass

    ironass Well-Known Member

    Can I just stop you there for one moment dynomot old sprout! :hmmmm:

    Although gsfrider's carrier is indeed EE, his phone is in actual fact a sim free, UK, unbranded model with the CSC and Product code BTU. Therefore, if he flashes the carrier branded firmware you suggest for EE, on CSC code EVR, this will not be his, "fresh out of the box", firmware and he will void his warranty terms and be unable to receive any future updates for his phone via Samsung Kies or OTA, (Over The Air). See the warning in #1.5 of 23 Galaxy S4 models - know yours? Not to mention the fact that he will end up with any, "bloatware", that EE include on their firmware.

    Maybe a better choice would be to reflash the existing KitKat firmware for his CSC and Product code...

    Model: GT-I9505
    Model name: GALAXY S4 LTE
    Country: United Kingdom
    Version: Android 4.4.2
    Changelist: 481100
    Build date: Thu, 13 Feb 2014 11:47:45 +0000
    Product Code: BTU
    PDA: I9505XXUFNB8
    CSC: I9505BTUFNB3
    MODEM: I9505XXUFNB8


    Both the UK unbranded firmware and the EE firmware have the same changelist, 481100, so I do not see any advantage in flashing EVR. Also, there are no inherent problems reported for the BTU firmware that would account for the OP's problems. What do you think?

    TIP: With the cumulative problems that gsfrider is experiencing it might be a good idea to back everything up on his phone and do a, "vanilla", install from fresh, (Factory Data Reset, format internal and SD card memory), as this would ensure that there is no corrupt data or files left on the phone, internal memory or SD card to cause any further problems. See #2.2 of Update Problems - Dummies Guide. This is what they would do at a Samsung Service Repair Point anyway.

    I'll shut up now and get me coat! :vroam:


    ironass motto..."Flash in haste...repent at leisure!" ;)
    dynomot likes this.
  9. dynomot

    dynomot Well-Known Member

    Ironass is correct, my link to EE firmware from my dropbox removed. Use the vanilla BTU firmware linked to by Ironass instead.
  10. gsfrider

    gsfrider Member

    Hi
    I did the flashing & phone is no different apart from I can't connect to kies to download my stored items, thanks
    Pete
  11. gsfrider

    gsfrider Member

    I've also had my phone flashed by Samsung & it's still the same (buggered)
  12. ironass

    ironass Well-Known Member

    Sorry to hear that. There is obviously a major problem with the handset and as you are still under warranty you should demand a replacement if they cannot fix it.
  13. gsfrider

    gsfrider Member

    Thanks everyone for trying to help, even Samsung it seems can't sovel my problems.
    R.I.P S4
  14. gsfrider

    gsfrider Member

    Hi
    As my phone worked 100% perfect before the update I don't think it is the handset, the Samsung service centre that last flashed it also found no problems at all with the handset, I think the only solution is to reinstall jellybean & see what happens,thanks
    Pete
  15. ironass

    ironass Well-Known Member

    The fact of the matter is that Samsung did not fix it. Therefore it is their responsibility to do so. Irrespective of whether it is a software or hardware fault. They may be able to downgrade you from KitKat to Jelly Bean but you should not try it as the bootloaders are different.
  16. gsfrider

    gsfrider Member

    I am trying to get Samsung to sort the problem but they don't seem to know what to do about it & they are very reluctant to give me a new phone but I will keep trying, thanks very much to you all who tried to help me it's very much appreciated
    Pete

Share This Page