Koumajutsu's SD-Card Partition Tool for Prevail


Last Updated:

  1. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    Koumajutsu here once again, with a gift

    SDparter.apk version 1.1

    My tool for partitioning SD-cards.

    This is roughly based on 51dusty's sdparted 0.6 script for CyanogenMod with a few key differences.

    1) This is an Android App and not a script.
    2) This does not need to be run through a terminal while in Recovery
    3) It carries what tools it needs with it (parted, tune2fs, e2fsck binaries)
    4) This only supports FAT32, EXT4 and SWAP partitions (EXT2 and EXT3 have been omitted for sake of simplicity)

    This has been tested with the Samsung Galaxy Prevail, but may work with other devices.

    SCREENSHOTS! (coming soon)

    Requirements: Root, EXT4 support, Swap Support
    File system supports are only required to create those partition types. You should be able to use this to create partitions that your system supports so long as you don't try to make partitions you don't support (I.E. if you only have EXT4 support, do not expect swap partitions to work and not cause FCs)

    Unlike a lot of other people's apps out there, I'm going to suggest that Developers include this app as a system app in their ROMs if it works on their device. All I ask is you drop my name somewhere :D

    Changelog:
    1.0: Initial Release
    1.1: Fixed Force Close when parsing non-whole numbers into integers. Fixed potential Force Close if app is run without an SD-card installed. Added checks for each binary individually

    [​IMG]
     

    Advertisement
  2. kristopher5823

    kristopher5823 Well-Known Member

    Joined:
    Jan 2, 2012
    Messages:
    418
    Likes Received:
    179
    Making everything so easy thanks :)
     
  3. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Joined:
    May 2, 2012
    Messages:
    4,383
    Likes Received:
    2,866
    Great idea!
     
  4. cwhatever

    cwhatever Life Goes On Guide

    Joined:
    Mar 4, 2012
    Messages:
    3,038
    Likes Received:
    842
    pretty slick when open up app it will tell you how you are partioned now.
     
  5. kevincott

    kevincott Well-Known Member Contributor

    Joined:
    Jul 12, 2011
    Messages:
    1,267
    Likes Received:
    296
    Getting FC on CTMod3.68.

    Redownloaded and reinstalled same thing.


    It gets past asking for Superuser then dies.



    edit: had kouma settings on SSM, changed to data rebooted and same issue. Phone acting up. Going to save SD data, wipe everything and reinstall.
     
  6. cwhatever

    cwhatever Life Goes On Guide

    Joined:
    Mar 4, 2012
    Messages:
    3,038
    Likes Received:
    842
    i'm still on 3.6
     
  7. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Joined:
    May 2, 2012
    Messages:
    4,383
    Likes Received:
    2,866
    I'm having FC issues but I'm on 3.6

    EDIT: Just updated to 3.68 and it works. It could be the way I installed it. When I did this on 3.6, I pushed the apk to /system/app using adb. This time I used adb install to do this and it works, no FCs
     
  8. cwhatever

    cwhatever Life Goes On Guide

    Joined:
    Mar 4, 2012
    Messages:
    3,038
    Likes Received:
    842
    i just did the drill and opened up and worked fine, even clicked on stuff to check out and worked fine, don't know? enen just oped up again works fine.
     
  9. kevincott

    kevincott Well-Known Member Contributor

    Joined:
    Jul 12, 2011
    Messages:
    1,267
    Likes Received:
    296
    Fell back to a CWM CTMod3.6 and SDparter works.

    Will try 3.68 again later.
     
  10. cwhatever

    cwhatever Life Goes On Guide

    Joined:
    Mar 4, 2012
    Messages:
    3,038
    Likes Received:
    842
    well thats good but wierd, palmtree5 said he was on 3.6 and wouldn't work for him, wierd?
     
  11. MaNiMaL4187

    MaNiMaL4187 Active Member

    Joined:
    Mar 9, 2012
    Messages:
    25
    Likes Received:
    4
    I'm on half ass 2, with fe16 baseband, kk 2.5. Just installed the sdparter for shits and giggles. Fc's on me. Any help?
     
  12. cwhatever

    cwhatever Life Goes On Guide

    Joined:
    Mar 4, 2012
    Messages:
    3,038
    Likes Received:
    842
    got no clue, maybe way installed? kevi no go on one and worked on another and then someone else on same and no go, mine went first time.
     
  13. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    please provide a logcat capture.
    and as much detail as possible.
    i.e.: the size of your sdcard, and the size of your current partitions and their filesystems

    just saying that it force closes is of no use to anyone
     
  14. cwhatever

    cwhatever Life Goes On Guide

    Joined:
    Mar 4, 2012
    Messages:
    3,038
    Likes Received:
    842
    here is a screenshot.


    2012-06-19 16.15.27.png
     
  15. Bloodawn

    Bloodawn Well-Known Member

    Joined:
    Jul 16, 2011
    Messages:
    2,176
    Likes Received:
    2,619
    nice bro. good work as always.
     
  16. kevincott

    kevincott Well-Known Member Contributor

    Joined:
    Jul 12, 2011
    Messages:
    1,267
    Likes Received:
    296
    I am accepting that it didn't run for me thru a problem on my end. After I repartioned the SD (CWM) and erased all data, worked fine on reinstallation.
     
  17. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    I still wonder what caused you to have FCs
    If it ever happens again, please get a logcat containing the error.
    If I can figure out what happened, I can make the app provide useful feedback rather than just decide that it can't run because it read something it didn't like
     
  18. kevincott

    kevincott Well-Known Member Contributor

    Joined:
    Jul 12, 2011
    Messages:
    1,267
    Likes Received:
    296

    Will do. After fresh install of CTMod 3.68 SDparter works.
     
  19. hyusa

    hyusa Active Member

    Joined:
    Sep 13, 2011
    Messages:
    43
    Likes Received:
    5
    Was going to upgrade to the new CTmod, so I threw this is the systems app folder to have it install along with everything else. Tried to launch it and got an FC. I'm using the stock SD card. Here's the logcat. SDparter logcat - Pastebin.com

    I've never outputted one before, so I wasn't exactly sure what you needed. I hope this helps you help me.
     
  20. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    cool, I'll have a fix shortly.

    The problem was related to my assumption that I would receive partition sizes from the system in whole numbers.
    Code (Text):
    1. E/AndroidRuntime( 3444): Caused by: java.lang.NumberFormatException: unable to parse '64.4' as integer
    is where I found a decimal point and choked :D
     
    hyusa likes this.
  21. hyusa

    hyusa Active Member

    Joined:
    Sep 13, 2011
    Messages:
    43
    Likes Received:
    5
    ^sweet, glad I could be of assistance, haha.
     
  22. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
  23. cwhatever

    cwhatever Life Goes On Guide

    Joined:
    Mar 4, 2012
    Messages:
    3,038
    Likes Received:
    842
    cool but why did it work on mine?
    and should i leave it or get rid of and use new one?
     
  24. kdraw44

    kdraw44 Well-Known Member Contributor

    Joined:
    Mar 25, 2012
    Messages:
    576
    Likes Received:
    221
    Works perfect, thanks:)
     
  25. Koumajutsu

    Koumajutsu Well-Known Member This Topic's Starter

    Joined:
    Aug 26, 2011
    Messages:
    1,444
    Likes Received:
    1,102
    you probably partitioned your's with sdparted like mine.
     

Share This Page

Loading...