Kyocera Milano 2.3.4 Root


Last Updated:

  1. pctech101

    pctech101 New Member This Topic's Starter

    Joined:
    May 14, 2010
    Messages:
    3
    Likes Received:
    0
    I found:
    http://heartheecho.webs.com/apps/fo...aridnours-one-click-style-rooting-tool?page=1

    Saridnours has a 1 click root for the echo. Guess what...
    After trying 6 times, it finally successfully rooted my Kyocera Milano C5120. It had issues with "su signal stopped" errors. Finally it succeeded and su ran properly after trying to do it a few times.

    I do not want to give direct link, not my work.
    Um... hope this helps
     

    Advertisement
  2. scary alien

    scary alien not really so scary Moderator

    Joined:
    Mar 5, 2010
    Messages:
    20,701
    Likes Received:
    20,242
    pctech101, all:

    I just posted a new, standard root guide for your all-things-root sub-forum.

    I wanted to link this thread in here, but I can't really see or figure-out the root method because the link you provided apparently requires member registration.

    You can re-post the root method here and cite your source for the benefit of others and that would allow us to link and include that information in the root guide.

    Thanks and let us know.

    Cheers!
     
  3. chrisyroid

    chrisyroid Member

    Joined:
    Nov 15, 2011
    Messages:
    10
    Likes Received:
    7
    I tried that method but it could only get it to root temporarily. After some research I came across this method: How to Root HTC Amaze 4G on Android 2.3.4 Gingerbread

    It totally worked!

    Here is the code from inside the batch file:

    Code (Text):
    1. :cd %:h
    2. adb wait-for-device
    3. adb push zergRush /data/local/
    4. adb shell chmod 777 /data/local/zergRush
    5. adb shell rm /data/local/tmp/*sh
    6. adb shell /data/local/zergRush
    7. adb wait-for-device
    8. adb shell sleep 1
    9. adb remount
    10. adb shell mount -o rw,remount rootfs /
    11. adb shell mount -o remount,suid /dev/block/mmcblk0p29 /system
    12. adb shell chmod 4755 /system/bin/sh
    13. adb push ./su /system/bin
    14. adb push ./su /system/bin
    15. adb push ./busybox /system/bin
    16. adb shell chmod 4755 /system/bin
    17. adb shell chmod 4755 /system/bin/su
    18. adb shell chmod 4755 /system/bin/su
    19. adb push ./Superuser.apk /system/app
    20. adb install ./androidterm.apk
    21. adb wait-for-device
    22. adb shell sync
    23. pause
     
    scary alien likes this.
  4. scary alien

    scary alien not really so scary Moderator

    Joined:
    Mar 5, 2010
    Messages:
    20,701
    Likes Received:
    20,242
    Thanks, chrisyroid!

    I linked your post in the all-things-root guide.

    Cheers!
     
  5. hawkeyez731

    hawkeyez731 New Member

    Joined:
    Jul 12, 2012
    Messages:
    3
    Likes Received:
    0
    I have tried all 3 ways of rooting my Milano and they have all failed... Any suggestions out there?
     
  6. hawkeyez731

    hawkeyez731 New Member

    Joined:
    Jul 12, 2012
    Messages:
    3
    Likes Received:
    0
    Still hoping for some help on this issue... Plz.
     
  7. Trlinde

    Trlinde New Member

    Joined:
    May 8, 2012
    Messages:
    2
    Likes Received:
    0
    Anyone found a rooting method that works?
    I've got a Kroger i-wireless Milano with a Sprint image and it refuses to root.
     
  8. tingtransform

    tingtransform New Member

    Joined:
    Nov 8, 2012
    Messages:
    2
    Likes Received:
    0
    I have a Milano from Ting (Sprint), and have not found a root solution. I have tried Zergrush, Superoneclick, Unlock Root, and Gingerbreak but none of them work. On Ting's forum they explain that the Milano software was patched against Zergrush and other exploits around March 2012https://help.ting.com/entries/21807722-rooting-the-kyocera-milano

    I have not found posts anywhere online of someone being able to root a Milano after March 2012. Without root this phone is pretty useless to me because it only has 150mb of internal memory and is so full of bloatware that it can only download about 3 apps then is full.

    I am willing to make a donation to someone who can help me get this rooted.
     
  9. manuelrh15

    manuelrh15 New Member

    Joined:
    Mar 28, 2013
    Messages:
    2
    Likes Received:
    0
    how can i root kyocera milano, android 2.3.4
     
  10. dabar

    dabar Member

    Joined:
    May 28, 2012
    Messages:
    5
    Likes Received:
    0
    Is it possible to downgrade to 2.3.3 and root it? I tried someone's 2.3.6 til I read up on more previous posts I found via google, and after March 2012, these methods are all useless as they've patched up the OS
     
  11. jjfulghum

    jjfulghum New Member

    Joined:
    Mar 11, 2011
    Messages:
    1
    Likes Received:
    1
    I downloaded Ministro 2 and superuser from the playstore and Poot.apk from the web. Opened the poot app, waited for the libraries to update, clicked on click to poot, and then updated the superuser binaries and Voila! Root
     
    scary alien likes this.

Share This Page

Loading...