Root Kyros 7042-Windows-root/cmw recovery

Discussion in 'Android Devices' started by PimpinEZ, Jun 6, 2012.

  1. PimpinEZ

    PimpinEZ Well-Known Member
    63

    Apr 12, 2011
    166
    75
    63
    Kyros-7042-Root-CWM.zip

    Download Kyros-7042-Root-CWM.zip from Sendspace.com - send big files the easy way

    I'm trying to make this easier for newbies.
    Credit is do to Vampirefo, Steev, Saurik, Fun.

    This zip contains a root exploit thanks to Steev, and a script for pushing CWM recovery thanks to Vampirefo.
    This is a one click deal! Just extract the folder and choose your .bat file.
    root.bat is used to just gain root and should work on other gen3 Kyros.
    root_recovery.bat is used specific for the Kyros 7042, and will root the device as well as push CMW.
    I've included SuperSU for theme flow reasons.

    It is good practice to make a stock backup (Dump) before doing any modification to your Kyros Tablet.
    Root maybe required. Credit to Steev.
    http://www.*************s.net/forum...-dumps-coby-generation-3-devices-fw_dump2.zip

    Update...
    If you get the following error

    Installing CMW recovery...
    /data/local/tmp/install-recovery.sh[8]: cannot create /dev/block/nandg: Permissi
    on denied
    done
    dd: can't open '/dev/block/nandf': Permission denied
    reboot: Operation not permitted

    try changing these lines in the root_recovery.bat
    adb.exe shell sh /data/local/tmp/install-recovery.sh
    to
    adb.exe shell su -c "sh /data/local/tmp/install-recovery.sh"
     

    Advertisement
  2. thricemin

    thricemin New Member
    5

    Jun 6, 2012
    4
    0
    5
    Is this just to root the device? And if so do you have the links for stable roms and gaps? :D
     
  3. lbeavisc

    lbeavisc New Member
    5

    Oct 16, 2011
    2
    0
    5
    i did back up via adb script dump, how do you do a restore using that?
     
  4. rameshudupi

    rameshudupi New Member
    5

    Jun 12, 2012
    1
    0
    5
    @PimpinEZ
    Hi,
    I used the root_recovery.bat. My tab is not rooted yet. I got the following error.

    waiting for kyros..
    ..
    ..
    ..
    ..
    7 files pushed. 0 files skipped.
    3372 kb/s (10305096 bytes in 2.984s)
    rooting...
    Installing CMW recovery...
    /data/local/tmp/install-recovery.sh[8]: cannot create /dev/block/nandg: Permission denied
    done
    dd: can't open '/dev/block/nandf': permission denied
    reboot: Operation not permitted
    Finished!
    Press any key to continue...

    Could you please help me.

    Thanks
     
  5. PimpinEZ

    PimpinEZ Well-Known Member
    63

    Apr 12, 2011
    166
    75
    63
    This roots but to flash cmw you must enter the last 2 line manually through android term emu on the tablet. for some reason the bat can't get su I'm trying to fix it. Sorry for the late respones guys. So.. run the bat then open it with notepad and manually do the lines on your tablet. Should work! Ima try and fix it asap.
     
    amigobuddy likes this.
  6. sk8rgeek

    sk8rgeek Well-Known Member
    38

    Feb 3, 2011
    188
    20
    38
    Kush
    Garland, Tx
    Alright..new to the tablet/4.0 world here..how do we get into recovery..and whats next??

    Thanks for doing this though..the other site said 64 bit windows wouldnt work..smh :/
     
  7. pkopalek

    pkopalek Well-Known Member
    103

    Dec 19, 2009
    837
    117
    103
    Computer Technician / Systems Implementation Manag
    Buffalo, NY
    Do you really have gapps going? Did you just use the normal Gapps from goo-inside.me ?
     
  8. PimpinEZ

    PimpinEZ Well-Known Member
    63

    Apr 12, 2011
    166
    75
    63
    guys gapps work and you get into recovery by vol+ the silver button and power or you can type su in android emu then reboot-recovery
     
    amigobuddy likes this.
  9. sk8rgeek

    sk8rgeek Well-Known Member
    38

    Feb 3, 2011
    188
    20
    38
    Kush
    Garland, Tx
    Got it all figured out, but thank you.

    Gapps works great, not laggy at all. Love being able to use a mouse, keyboard, or controller :)
     
  10. amigobuddy

    amigobuddy New Member
    5

    Aug 14, 2012
    3
    0
    5
    Hi PimpinEZ -

    I tried this on my Colby MID7042 running from Win7 x64 and I don't think it worked. I do not see the super user app on the device and when i type "su" in the emu, it gives a me an "unknown" response.

    I tried installing BusyBox from 1Mobile and it failed to install stating that it couldn't find necessary files, etc.

    It says all 7 files pushed, 0 files skipped. How can I else verify the root or resolve?

    Thanks
     
  11. amigobuddy

    amigobuddy New Member
    5

    Aug 14, 2012
    3
    0
    5
    I resolved my issue. I had to install adb drivers first. Thanks for all this. This is awesome! I am creating my backup and next I will try to install the gapps. Is there a link to install gapss w/o a custom rom?

    Actually folks, i lose my root every time i reboot. Any ideas how to solve?
     
  12. sk8rgeek

    sk8rgeek Well-Known Member
    38

    Feb 3, 2011
    188
    20
    38
    Kush
    Garland, Tx
    Happened to me also. Just have to figure out how to run the script correctly with LiveSuite. Once you do that, you should get Gapps+Root+Recovery.
     
  13. amigobuddy

    amigobuddy New Member
    5

    Aug 14, 2012
    3
    0
    5
    sk8rgeek, where did you find a stable ROM with all that? I looked at the above attached thread and it looks like some folks feel that the ROM is not stable.

    On a side note, after some fiddling I was able to get the root to stick (kinda). It stays but I have to update the SuperU binaries upon every boot (annoying but manageable when I only need it).

    I could not get CWM to work correctly. It only recognizes my internal sd, not external sd. In addition to that it only recognizes something like 400 MB free on the internal SD though there is close to 1 GB free. This is resulting in a failed backup every time I try due to space constraints, odd! Have you had any issues with CWM?
     
  14. Downslide

    Downslide New Member
    5

    Sep 10, 2012
    1
    0
    5
    Hey guys. Does anyone have the zip file PimpinEZ linked to in the first post? I can't get it from sendspace, Ilnked- or what ever the download manager is - keeps crashing.

    I have a Dropbox account I could pm somebody to have them upload it to that.

    I'd really appreciate it.
     
  15. ninjasinabag

    ninjasinabag Well-Known Member
    103

    Jun 21, 2012
    538
    164
    103
    Male
    you name it
    philadelphia, PA
    Okay, I'm stuck at waiting for device on the root bat. When I connected my device for the first time it said that the drivers were not installed correctly. I need help. Getjar sucks....period
     
  16. _metzeller

    _metzeller New Member
    5

    Oct 16, 2012
    3
    0
    5
    Can anybody please make a step by step tutorial about this?
    Noob here... Tnx.
     
  17. otvac305

    otvac305 New Member
    5

    Feb 22, 2013
    1
    0
    5
    I can root my 7042 via the term emu, but it resets on start-up. Any tips for a noob?
     
  18. ninjasinabag

    ninjasinabag Well-Known Member
    103

    Jun 21, 2012
    538
    164
    103
    Male
    you name it
    philadelphia, PA
    That's normal, you'd have to flash pimpenstien ROM for consistent root privileges sadly.
     
  19. leblinux

    leblinux New Member
    5

    Aug 7, 2013
    2
    0
    5
    Hi,

    I am stuck at waiting for kyros, i did normal boot and nothing happened any ideas?
     
  20. StillHacking

    StillHacking Well-Known Member
    28

    Jul 13, 2010
    85
    12
    28
    Field Engineer
    Pittsburgh
    Hi, I realise this is an old thread but I'd like to say thank you. I had to do the root_recovery.bat modification and try a couple of times but I was able to get CWM installed then the Google Aps as well.

    For some reason it looses root after boot but you can bring it back by updating the SU binary. It does not really matter as the Play store was the goal with no plans of flashing any ROM's for now. Seems more stable now and it even runs an older version of Kodi.

    Thanks again, I almost just made this a clock...
     
    ninjasinabag likes this.

Share This Page

Loading...