Support Language support in Music Player

Discussion in 'Android Devices' started by harrispo, Sep 12, 2009.

  1. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    I have a few Greek songs that I would like to play on the Galaxy, but it really annoys me that the Greek song names don't show properly. Instead I get a bunch of question marks

    The strange thing is that it reads one of the tags, but none of the rest :thinking:
     

    Advertisement
  2. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    Noone has experienced anything like this?
     
  3. damuffinman

    damuffinman Well-Known Member
    38

    I had the same problem with my Chinese songs...

    Basically you've got to convert all your ID3 tags to UTF-16 so the tag displays properly. I made a blog post about it on my blog.
     
  4. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    I did that but it didn't make a difference
     
  5. damuffinman

    damuffinman Well-Known Member
    38

    Strange. What firmware are you running?
     
  6. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    Firmware version: 1.5
    Baseband version: I7500XXIH6
    Kernel version: 2.6.27
    Build number: 76XXCSDCBALUM6375

    Oh and another thing - I can't update the firmware because NPS doesn't recognise my phone. I've tried following all the guides and reading up about the problem on the forum and on other sites but to no avail. I've tried it on both Vista x64 and XP x86 and the result is the same - nothing

    As far as I can tell all the drivers are installed, including the ADB drivers. Any ideas?
     
  7. damuffinman

    damuffinman Well-Known Member
    38

    NPS won't update mine either - the last update it gave me was from FF to G6. I used Odin to get it to H7.

    The ID3 tags were fine in G6, both English and Chinese. In H7 it kind of screwed everything over, I had to change all the tags to UTF-16 (English as well) but some of the Chinese ones didn't render properly either.

    Perhaps it's a firmware thing?
     
  8. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    I'm trying to update the firmware to IH8. Where can I acquire Odin from? I typed "Odin Multi Downloader" in Google but the results didn't help
     
  9. damuffinman

    damuffinman Well-Known Member
    38

    Odin should be in the firmware pack, along with the firmware files.

    At least that's what came bundled with my H7 firmware.
     
  10. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    I just updated to IH8 using the instructions on your site and on here and so far the phone seems faster, which is always nice. Still no support for foreign fonts in the music player though :(
     
  11. damuffinman

    damuffinman Well-Known Member
    38

    Fingers crossed for the I4 firmware then!
     
  12. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    Any idea when it's due?
     
  13. damuffinman

    damuffinman Well-Known Member
    38

    It's out for new i7500s from O2 UK but not available on the PC Studio yet. Check the other thread for progress - I believe a few of the hardcore enthusiasts are trying to 'hack' it from the Samsung servers at the moment.
     
  14. lynda1234

    lynda1234 New Member
    5

    Sep 25, 2009
    1
    0
    5
    Such a very amazing link!
    This is an interesting discussion. thank you for sharing
     
  15. pinhadwhir

    pinhadwhir New Member
    5

    Oct 1, 2009
    1
    0
    5
    Thank you so much for the post. It's really useful.
     
  16. harrispo

    harrispo Active Member
    15

    Sep 12, 2009
    31
    0
    15
    Nothing to do with this topic: damuffinman, what happened to your website? Always found it very informative and it seems to be down now :(
     
  17. damuffinman

    damuffinman Well-Known Member
    38

    Bad news I'm afraid. It got taken down by my web host for 'distribution of software', which they deem is against their user policy.

    I thought about starting it again, but I realised we don't really need more divisions in the community.
     

Share This Page

Loading...