Large PDF Slow to displaySupport


Last Updated:

  1. Tony2Cakes

    Tony2Cakes New Member

    Hi Folks,

    I have the Galaxy TAB2 10.1 When loading a large PDF 44 pages I get white pages and no text. Eventually the text may appear. A single page is OK Tried using Polaris Kingston and a few other readers. Why is thing so slow to display pdf's?

    Thank you all in advance..

    Advertisement
  2. jwither

    jwither Well-Known Member

    Using Polaris and testing with a 70 page 5mb PDF, saved to either the internal or sd card, it's not lightning fast on my tab, but I wouldn't expect it to be. It's about the same as loading it on my iPad 2.

    As I flip from page to page, text loads pretty quickly, but images take 2 - 3 seconds to load.

    If you're opening it from a web browser, your Internet connection speed will have a lot to do with it, just as it would on a PC. The pages have to download, THEN load in the app.
  3. Tony2Cakes

    Tony2Cakes New Member

    I am loading pages from a PDF file on the external SD card. I also tried loading the same pages from the internal memory. The result is the same, either a very slow load or just white blank page. I have pulled the SD card and it displays the PDF fine in my lappy

    Any thoughts?
  4. jwither

    jwither Well-Known Member

    Is the file something that is publicly available, that I can load and test with? My guess is that it likely has something to do with the file, how it was created, etc.
  5. Tony2Cakes

    Tony2Cakes New Member

    Hi,
    Thanks for your offer to help.
    I have attached the file. It is a service manual for a Roland piano.
    Interesting to note, I purchased EZ PDF pro and this opens the file!
    Where as Kingston and Polaris do not.

    I look forward to your findings:)

    Attached Files:

  6. jwither

    jwither Well-Known Member

    Opened in Polaris, took no longer than a couple seconds to load each page, even when I skipped ahead several pages.

    You might have a look at other processes which are running on your Tab that might be causing a slowdown.

    I keep power saving mode turned off. I don't know exactly everything that it does, but if it lowers the CPU speed for the sake of battery usage, that might also be part of your issue.
  7. Tony2Cakes

    Tony2Cakes New Member

    Hmm, I checked Task manager, 0 apps running also cleared ram. Still no load with Polaris or Kingston. Any Idea forward here?

    This is a 2 week old unit with only a handful of apps installed.

Share This Page