Support Launcher Pro suddenly blowing up after 2.2 update

Discussion in 'Android Devices' started by 1977sjr, Sep 22, 2010.

  1. 1977sjr

    1977sjr Well-Known Member
    26

    Apr 19, 2010
    72
    2
    26
    Cincinnati, OH
    Has anyone else been experiencing Launcher Pro force-closes and homescreen freezes after their 2.2 update? Everything was working perfectly for me for a couple of hours and now it's all gone down the drain. I've done restarts and two battery pulls. I would get to the homescreen and then it would just freeze up and I couldn't do anything. Frustrating! Do I need to do a factory reset???
     

    Advertisement

  2. Andro Monster

    Andro Monster New Member
    5

    Sep 22, 2010
    2
    0
    5
    Yeah i have experienced this as well on my X, though I have no idea how to approach it. We may have to wait for an update to LP in order to fix these freezes and glitches
     
  3. 1977sjr

    1977sjr Well-Known Member
    26

    Apr 19, 2010
    72
    2
    26
    Cincinnati, OH
    I'm dead in the water basically...I can't do anything once the phone boots up to the homescreen. It immediately freezes. I can't even get into Settings to do a reset.
     
  4. JustinHEMI

    JustinHEMI Well-Known Member
    93

    Apr 29, 2010
    534
    148
    93
    Male
    Senior nuclear reactor operator
    Pittsburgh, PA
    Mine has been flawless. But, as I do after every update, I did a factory reset and fresh install of everything. So perhaps that might be a solution for you.
     
  5. 1977sjr

    1977sjr Well-Known Member
    26

    Apr 19, 2010
    72
    2
    26
    Cincinnati, OH
    Is there any way I can go about doing a reset when I'm stuck on my homescreen right after every boot-up?
     
  6. JustinHEMI

    JustinHEMI Well-Known Member
    93

    Apr 29, 2010
    534
    148
    93
    Male
    Senior nuclear reactor operator
    Pittsburgh, PA
    There is another way to do a reset, but I don't know it off the top of my head. Google it and you will find it.
     
  7. 1977sjr

    1977sjr Well-Known Member
    26

    Apr 19, 2010
    72
    2
    26
    Cincinnati, OH
    I looked it up and found it, but that's not even working...damn this thing is really screwed up all of a sudden...
     
  8. 1977sjr

    1977sjr Well-Known Member
    26

    Apr 19, 2010
    72
    2
    26
    Cincinnati, OH
    Okay, I finally was able to navigate to the Privacy menu to do a reset. Justin, my question to you is, did you install LP after your reset? And has it been working for you without any freezes or hang-up's?
     
  9. JustinHEMI

    JustinHEMI Well-Known Member
    93

    Apr 29, 2010
    534
    148
    93
    Male
    Senior nuclear reactor operator
    Pittsburgh, PA
    Yes to both questions.
     
  10. hyperlite

    hyperlite Well-Known Member
    36

    Sep 8, 2010
    100
    5
    36
    I did the same as justin with LP+. no issues here. The other method of doing a factory reset:

    -turn phone OFF
    -Hold down home button
    -power the phone on and continue holding home button until the android with an exclamation mark appears.
    -press the search button
    -use the volume rocker to navigate to the clear user data/factory reset option
    -press the camera button to select.
     
  11. Tumeg

    Tumeg Well-Known Member
    73

    Sep 9, 2010
    315
    94
    73
    I was also having these problems, but after I did a battery-pull all of the problems went away.
    It's running smoothly\perfectly now.
     
    NarniaHTC likes this.
  12. JJWSTAR

    JJWSTAR Well-Known Member
    15

    Jun 9, 2010
    63
    0
    15
    after the factory reset, will the contact info back up to gmail account automatically copy to the phone?
     
  13. JustinHEMI

    JustinHEMI Well-Known Member
    93

    Apr 29, 2010
    534
    148
    93
    Male
    Senior nuclear reactor operator
    Pittsburgh, PA
    Mine has, yes.
     
  14. twister6

    Guide
    223

    Jul 30, 2010
    2,223
    905
    223
    battery pull fixed mine as well. I actually had to do it twice. After initial Froyo update I was stuck at moto screen for 40+ minutes, so had to pull it once. Than, after reboot got stuck again due to LPP and pulled battery again. That "fixed" a lot of things including battery usage statistics :)
     
  15. Jim Dawson

    Jim Dawson Well-Known Member
    36

    Nov 27, 2009
    194
    9
    36
    East Alton, IL
    I updated this morning and, so far, everything is working ok, at least as good as it was before the update. I think the update was a waste of time. With the exception of Flash, it just added more Verizon bloatware.
     
  16. bigbadwulff

    bigbadwulff Well-Known Member
    143

    Jun 15, 2010
    2,442
    200
    143
    Absolutely zero problems here
     
  17. CaucasionJ

    CaucasionJ Well-Known Member
    38

    Aug 24, 2010
    175
    16
    38
    Male
    Chipotle Service Manager
    Ohio
    Right after i installed Froyo i got an update for LP on the market place. Maybe that was an update for a patch to run 2.2 on it?
     
  18. S373N

    S373N Member
    16

    Jun 19, 2010
    20
    2
    16
    IN / O.C.
    Haven't ran into any issues with mine yet. I also did a factory reset after update
     
  19. Ayrow

    Ayrow Well-Known Member
    26

    Nov 2, 2009
    70
    8
    26
    Mine has been flawless as well.

    Thank goodness. After being with the BB Storm family, I was scared of what might happen after upgrading.

    So far this phone has been spectacular.
     
  20. JustinHEMI

    JustinHEMI Well-Known Member
    93

    Apr 29, 2010
    534
    148
    93
    Male
    Senior nuclear reactor operator
    Pittsburgh, PA
    24 hours still going strong. No melt down like a couple others reported.
     
  21. bgillyjcu

    bgillyjcu Well-Known Member
    38

    Aug 19, 2010
    182
    22
    38
    Mine acted up a little yesterday. 2 times it asked me to force close or wait. I just waited and after a few seconds it kicked back into gear.

    I wonder if he is working on improving LP for 2.2 right now.
     
  22. muneeb25

    muneeb25 Active Member
    16

    Sep 3, 2010
    26
    3
    16
    Network Engineer
    DC & NYC
    I had a bit of a lag in the begining but after making sure i have the latest version of LPP and downloaded home switcher and make sure that i set LP as the default launcher, everything is working super smooth as of right now
     
  23. Willyg44

    Willyg44 Well-Known Member
    38

    Aug 3, 2010
    155
    13
    38
    Mine has been fine. And I love the better homescreen scrolling in the new update.
     
  24. Steven58

    Steven58 Reformed PH
    VIP Member
    3,823

    Feb 19, 2010
    32,921
    25,271
    3,823
    Male
    my lpp is great after 2.2 ota plus re-root. no trouble. huh.
     
  25. trophynuts

    trophynuts Well-Known Member
    313

    Jul 6, 2010
    5,630
    1,792
    313
    I work in a Tech related field. Have been in a tec
    SouthEastern US
    mine as well has been acting ******ed. Serious lag when coming out of screen lock, and also it's like the phone gets confused in which mode it should be in, landscape or portrait.

    i may try a battery pull, i am a former BB guy so i'm familiar with that.
     

Share This Page

Loading...