LCD will not turn on after going into powersave modeSupport


Last Updated:

  1. jhamrick

    jhamrick Member This Topic's Starter

    Joined:
    Sep 30, 2009
    Messages:
    5
    Likes Received:
    0
    Hi,

    So, I'm not too hopeful for being able to fix it, but I thought I'd ask. A few days ago, I dropped my phone in some water (it was completely submersed). I let it alone for a while and finally turned it back on to see if it works. Everything seems to be fine, except for the screen.

    The screen works fine if I'm using the phone, but I continually have trouble with the screen when I bring the phone out of powersave mode. There are three things that can happen:

    1) The screen comes on just like normal.
    2) The screen starts to come on at the top, but then stops and fades to black. Occasionally there are some green vertical lines that show. The backlight comes on.
    3) The screen does not respond in any way, shape, or form, and the backlight is also absent. The buttons, however, do light up.

    In case (2), I can usually hit the power button (to put it back into powersave) and then the Menu button a few times and eventually it'll come up normal.

    In case (3), nothing I do will fix it. If I wait for a while and check it again, it still will not work. The only remedy is to powercycle it by removing the battery and then replacing it. When I do that, the screen comes on perfectly (although, the T-Mobile G1 logo only shows up some of the time).

    The screen never dies when I'm using the phone (or at least, it hasn't yet). It's only when I try to bring it out of powersave that it causes problems. I have verified that the phone itself is still working when the screen is dead, as I can still receive calls.

    I've been purchasing insurance on the phone, so I can get a new one for less than full price, if necessary. But, this just seems to me like the LCD is not getting power all of the time, which makes me think that maybe I can fix it. I do not want to do anything that would void my insurance, however.

    So, does anybody have any ideas?

    Thanks,
    Jess
     

    Advertisement
  2. jhamrick

    jhamrick Member This Topic's Starter

    Joined:
    Sep 30, 2009
    Messages:
    5
    Likes Received:
    0
    This video shows almost exactly what's going on with mine, except that I can't bring the screen back up once it goes completely black:

    YouTube - G1 screen issue
     
  3. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210

    I think after seeing your video ... I would say you have a phone that needs to be returned for replacement ...

    BUT 1st :

    Have you gone into your settings and set it to NEVER time out ... and then try it ....?
     
  4. jhamrick

    jhamrick Member This Topic's Starter

    Joined:
    Sep 30, 2009
    Messages:
    5
    Likes Received:
    0
    Yes, I have set it to never time out, and it seems to work fine as long as I don't turn the screen off. This is a problem, though, because I can't keep the screen on *all* the time - I'll run out of battery within only a few hours.
     
  5. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210

    Understand ... I suggested that to see if a setting was doing the blanking ... that doesnt appear to be the case ...

    So my best guess is defective ... I assume you have done a factory reset as well ?
     
  6. jhamrick

    jhamrick Member This Topic's Starter

    Joined:
    Sep 30, 2009
    Messages:
    5
    Likes Received:
    0
    Not yet; I wanted to see if perhaps there was a solution that didn't require me to lose all of my apps and settings - but I'll try that now, and let you know how it goes.
     
  7. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210
    You can do a full backup of apps, settings, data, sms etc ... with MYBackup Pro ...

    But up to you ?
     
  8. jhamrick

    jhamrick Member This Topic's Starter

    Joined:
    Sep 30, 2009
    Messages:
    5
    Likes Received:
    0
    No luck with the factory reset. Exact same symptoms as before.
     
  9. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210
    Surely a bad unit .... return that bad puppy !! :eek:

    They may or may not be able to detect moisture damage .. !! take your best shot
     

Share This Page

Loading...