Legit/Legal Unlock Code Not Working AT&T S4General


Last Updated: 2014-12-22 08:48:57
  1. mvplilant

    mvplilant New Member

    Hi all. I apologize in advance if I have created a new thread of an already existing one. This is truly my first time ever using a forum for help.

    So here is my problem:
    Bought an AT&T S4 off eBay around May 2013. Then purchased an unlock code off eBay which worked perfectly with T-Mobile. Around January 2014 the phone's Wi-Fi stopped working. Phone still had 1 year manufacturers warranty active, so I sent it to Samsung. The phone's Wi-Fi was fixed and the PBA was replaced. Phone was restored back to factory as if purchased brand new. When turned on with T-Mobile SIM inside, it asked for the unlock code. I entered in the same unlock code purchased before and it says unlock code unsuccessful. (All of the internal specs were the same, i.e. the IMEI & Serial Number.)
    After hours and days and now months of trying to fix the problem with both Samsung's and AT&T's ignorant and stubborn customer support I have come here.
    To remove all suspicion that the unlock code I bought was faulty, I had my cousin request an unlock code directly from AT&T. After 1 month of him using the S4, the unlock came in. And surprise surprise, it was exactly the same as the one I had previously purchased.

    Can anyone help? Please keep in mind that I would rather not root the phone to get it to work with T-Mobile.

    Advertisement
  2. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    Wow, that sounds frustratingmvplilant.:( Have you tried talking to the T-Mo people. I've note much experience with GSM devices, but it could be you need a new T-Mo sim.:dontknow:

    PS, welcome to Android Forums.
  3. mvplilant

    mvplilant New Member

    Believe it or not, I called T-Mobile. But as I expected, they have nothing to do with unlocking - it's not their phone. I've also tried using a different T-Mobile SIM, but that didn't work either.
  4. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    OK, I wasn't sure as I come from the non-sim CDMA world:eek:
  5. GuitarG20

    GuitarG20 Clueless Senior Member Contributor

    Assuming you have already gone to AT&T to see if they can help, you might have to go directly back to Samsung. It's possible the board they gave you is somehow different than the ones they put in all the AT&T phones (this is unlikely, and it could have been an accident, but it's possible) and thus you need a different unlock code.
  6. mvplilant

    mvplilant New Member

    I didn't want to be too wordy in the original thread, so I left out lots of important information:
    After hours and days of talking to Samsung and AT&T, I figured that there might have been an issue with the newly installed PBA. Perhaps during Samsung's flashing process, the wrong internal specs were transferred to the new PBA. So I had Samsung replace the PBA a second time, but even still, the unlock code didn't work. (This is assuming Samsung didn't lie to just get rid of me.)
    I have tried almost everything. And now I'm more curious to figure out the issue than to get my S4 working.
    P.S. Is it possible that the new 4.4.2 android version is conflicting with the unlock?
  7. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    I have been searching around the interwebs and I found this. Doesn't sound good.:(

    HELP! GS4 Factory Unlock Problem!! - Android Forums at AndroidCentral.com

    I'll keep looking though.
    GuitarG20 likes this.
  8. bobolinko

    bobolinko Well-Known Member

    You're not the first person to get an unusable unlock code from Sammy/T-mobile.
    I have a Brand New GS4 purchased from T-Mo and they gave me an unlock code that would not work for nobody. I took it in to the place where I purchased it and they couldn't unlock the danged thing either. I gave up and used chainfire's reigon unlock and in less than a minute all was done! I can use anybody's sim that will allow the same frequencies to get service. Be aware, tho whether you get t code or unlock using other means, not all carriers have LTE and 4G. Some will be only EDGE!

    Bottom line tho, Chainfire FTW!!! (on XDA Developers)
    Good Luck
  9. mvplilant

    mvplilant New Member

    Thank you all for your responses. I really appreciate the concern and help! I guess I am left with but one option - root the S4. Does anyone have any preferences on which method to use in rooting the phone. Something easy and straightforward please. I cannot seem to find chainfire's reigon unlock for 4.4.2.
  10. distant traveller

    distant traveller New Member

    Hi

    Problem solved! I got an unlock code from AT&T for an off-contract Galaxy S4, and tried it one week later with a foreign (non-US) SIM card. When I tried it, it said "Unlock request unsuccessful". So knowing I had only 4 tries left, I scoured the internet for a reason or solution. Apparently this is a problem many people have been facing. After getting no definitive answers online, I attempted to try the unlock code again (it was around 2 am so ATT customer service was closed btw). So took out the foreign SIM, put it back in, put everything back together. Started it up and lo and behold, it didn't ask me for an unlock code! Thought it was too good to be true,so tried to make a call, and it worked!!!! So the moral of this story is, even though it may say unlock unsuccessful, it may well have worked successfully. So if you get the "unsuccessful" message, take out the SIM, put back in, reboot (if phone wasn't powered off already), and try to make a call or text. Essentially once it doesn't ask for an unlock code again with a non-ATT SIM inside then you are good to go. I will say though that it did take about a minute or two for the SIM to get service, perhaps because its a foreign SIM and was essentially roaming and looking for a partner carrier signal.

    Hope this helps.

Share This Page