Lenovo Ideapad A1 Root Instructions


  1. eldroid2783

    eldroid2783 Member


    Advertisement
  2. ducpiloti

    ducpiloti Well-Known Member

    unfortunately those instructions don't work...I tried SuperOneClick and when I click on Root with my A1 connected via USB (I see it mounted as a drive on my PC) it just freezes.
  3. emorrison33

    emorrison33 Active Member

    I had the same problem as ducpiloti.
  4. ajace

    ajace Member

    same, not working for me. the update did something?
  5. kamorant

    kamorant Member

    Hey guys,

    I suspect I had the same issues as you the SuperOneClick util just sat there and spun saying "waiting for device". In my case I had to install the ADB drivers.

    I used paulnelson88's instructions from this forum:

    Lenovo IdeaPad A1 7" Tablet Review and Root! - xda-developers

    The REAL trick was installing the ADB drivers. I had to google that, which yielded instructions on the google site.

    Google USB Driver | Android Developers

    If you don't install the drivers it won't work. There are a couple of other "tutorials" out there that don't mention the ADB drivers. So they fail too!

    Now I'm free to totally screw up my tablet! Yeah!

    Karl
  6. wallymann

    wallymann Member

  7. vedag

    vedag New Member

    I am just wondering if rooting makes a big difference? I bought the A1 for my 10 year old daughter for Christmas. The only thing that bothers me is netflix doesn't work. Thanks for any suggestions.
  8. fisherking3k

    fisherking3k Member

    odd.. netflix is working fine here... try again? check your software...is there an update available? (i JUST got my A1...)
  9. jt760362

    jt760362 New Member

    Just got the Ideapad A1 a couple of days back. Came with 2525_US kernel. I have not rooted it. I have not seen the random reboot issue. The forum has been an immense help, so thank to all.

    The only problem is that I am unable to sign in to the Netflix app. The error message is incorrect username or password. The version of the app is 1.7.0 build 510.

    Has anybody else seen this?
  10. jt760362

    jt760362 New Member

    I ended up calling Netflix and they asked me to key in a pure numerical password and this solved the problem. The Service Rep said that the password was somehow now being keyed in correctly! Very weird. I must say that she was very helpful.
  11. fisherking3k

    fisherking3k Member

    so...solvable. funny, i didn't have any problems logging in... but the bottom line is, netflix works.
  12. GTOgirl

    GTOgirl Well-Known Member

    I couldn't get SuperOneClick to work, so I searched XDA and found another way. Installed CWM recovery, then a file called A1Rooter, and then backed up and installed CM7. My tablet is hauling a** now! Woot!
  13. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I'm not sure how the file system is set up on a tablet, but if your rocking a ClockWorkMod recovery you might want to check out this: Playing with QtADB
    Even though it's in the LG Optimus V All Things Root sub-forum it works on most of the Phones. I use it Quite a bit for pulling and pushing apk's and other files and folders to the system. It allows the user to just straight Drag-n-Drop instead of pulling and pushing with shell commands.
    You still have to have ADB established in the system path or your PC.
    It allows access to fastboot as well (don't know about on a Tablet).
    It allows the user to do a lot more, but what it can do for a tablet, I don't know.

    Anyway, if someone with a CWMod recovery would like to download onto a PC and test to see what all, if anything can be done with it, then post in a new thread for the benefit of the other members that would be great.

    Thanks.
    AndyOpie150
  14. poophydroid

    poophydroid Member

    Hi, any suitable place to know more about rooting for non-linux folks?

    Thanks,
  15. AndyOpie150

    AndyOpie150 <strong> <a href="http://androidforums.com/optimus Contributor

    I didn't know squat about shell commands until messing up my first smart phone Last Year.
    The more you become comfortable using a command line the better it is for you. If you are not comfortable with a command line and shell commands thru ADB, then when when you mess up your phone (Even seasoned modders mess up there phones) you have a better chance of turning a situation that you could get you phone out of into a bricked phone.

    It's not hard to learn. I was 47 last year when I had to learn, and I over think everything.
    If I can learn anybody can. It is to your benefit to learn the simple commands needed to affect change to your system, recovery, boot.img, etc.

    This knowledge has gotten me out of quite a few self inflicted problems with my phone.

    I would start by getting the USB drivers for you tablet (a google search should do the trick) then get ADB set up on your PC. If it's a Windows Vista or 7 check this out: New pre-packaged ADB installation
    This has worked 100% of the time.

    Then google shell commands, and fastboot commands, then google Root access and File permissions.
    Next thing would be to follow the instructions here. There really not hard once you have read up on all the ^ above.

    Trying to root, install a custom flash_image, flash a custom recovery and ROM is best done with a little more knowledge. The more knowledge the less chance for mistakes, and if a mistake is made you will know how to fix it.
  16. kpearsonxyz

    kpearsonxyz Active Member

    I'd love to see help for those of us who only use Linux but have never rooted any Android device. Maybe I haven't looked hard enough?

    TIA

    Oh, and shell commands, or CLI, is the only way to get things done fast, right, and fun.

Share This Page