LEOS 2.0 - Official AnnouncementGeneral


  1. Rocky4u

    Rocky4u Well-Known Member

    ??LeOS 2.0 (Android 2.2) ????????? - ?phone???(??????) - ?Phone???? ????????????

    It seems it will be released tomorrow.

    Google Translate:
    "Hello everybody:
    Lenovo 2011 1 月 11 日 (星期二) 9:00 in the developer community association official release LeOS 2.0 trial version (3 versions), the developer applied only for testing, You are welcome to download the trial.
    Special Notice: This version is the official trial version, not mass production version, under the guidance of the professionals operating in strict accordance with the upgrade process, otherwise the version and use programming problems arising in the course borne by the developer.
    Thank you for the care and support Music Phone!
    Lenovo developer community
    January 10, 2011"

    Advertisement
  2. nordream

    nordream Member

    Is there a .apk of Android Market that is possible to install on Unicom 3GW100 OS2.0?
  3. Rocky4u

    Rocky4u Well-Known Member

    I haven't found one...
    Anyway I am downloading applications from the internet on my laptop...
  4. Rocky4u

    Rocky4u Well-Known Member

    in case anyone tried please let me know... I don't know how to do it with this tar.gz files.
  5. howard-1

    howard-1 Member

    You can unzip the "tar.gz" file with for ex. "7-Zip" and u will end up with a normal "image" file......
  6. punc

    punc Member

    After installing Leos2.0, Android Market apk is missing, where I can found this software?
  7. morz001

    morz001 Active Member

    is it risky to use this software/upgrade?
  8. Rocky4u

    Rocky4u Well-Known Member

    this one is the official firmware in a BETA stage.
    It doesn't have Google Android Market. It has the Lenovo Mobile Market.
    Maybe when it is final, someone will modify the ROM to have also the Android Market.
  9. Rocky4u

    Rocky4u Well-Known Member

    I installed last night and I found some improvements.
    Before upgrading make sure your battery is more than 90% charged.
    you know the drill... try it on your own risk.
    morz001 likes this.
  10. Pino13

    Pino13 Well-Known Member

    Just installed in my.

    So far so good.

    I was using the custom 2.2 before but the bugs was starting to bother me.
  11. Rocky4u

    Rocky4u Well-Known Member

    If anyone find out how to modify the weather gadget and other things to remove CN parts... please let me know.

    I tried to root using Androot but it failed.

    I didn't get the trick that this firmware is trial... what how come?
  12. Pino13

    Pino13 Well-Known Member

    You can root the Lephone with LeOS 2.0 using Z4root

    [APP] z4root - xda-developers
    Rocky4u likes this.
  13. Rocky4u

    Rocky4u Well-Known Member

  14. akhan5040

    akhan5040 Member

    I'm pretty new to rooting and i was wondering, What can be done on this phone after it's rooted? or rather What have you guys done to Lephone after it's rooted? Thanks in advance.
  15. nordream

    nordream Member

    Is there anybody who have managed to install a working version of Android Market on Leos 2.0 beta?
    If yes, tell us how to do it, please ! :)
  16. Pino13

    Pino13 Well-Known Member

    Nothing special, there a few apps that requires root to work, but it
  17. Pino13

    Pino13 Well-Known Member

    You can
    nordream likes this.
  18. nordream

    nordream Member

    I'm now running Android Market on leOS 2.0.
    To be honest I don't know excatly how I did it, but by downloading Google apps from the link in FAQ in post "Custom Android 2.3 (Gingerbread) released" I manage to get it to work.
    Follow the instruction in FAQ. Install all apps in packages, Clear cache data in "Manage application", some back and forth and viola it worked :)
    Rocky4u likes this.
  19. Rocky4u

    Rocky4u Well-Known Member

    Indeed I have the market... however it doesn't want to connect to google servers...
    I will try.

    I think we need adb...
    can anyone create a guide to use adb for lephone?
  20. Pino13

    Pino13 Well-Known Member

  21. nordream

    nordream Member

    Market and all Google apps are working and connecting, except for Google Earth, it dosent run at all.

    When Lenovo LePhone USB driver is installed on PC, (google: LePhone2.0-20101230.msi)
    use adb to push system and META-INF folders from gapps-hdpi-20101114-signed.zip to the phone with the following commands:

    adb push META-INF /system/META-INF/
    adb push system /system/

    There was insufficient space for all the apps with this command ?? Added the others manually afterwards.
    I think the META-INF folder is most important.

    But as I sayed, It's more luck than knowledge that made it work for me:)

    Try at your own risk
    Rocky4u likes this.
  22. nordream

    nordream Member

    See above post.

    After push and manually added the rest of the apps, delete cache data for all apps added.

    Hope you succeed!
  23. Pino13

    Pino13 Well-Known Member

  24. Pino13

    Pino13 Well-Known Member

    Ok, I installed the latest version of PC 91 suite and now I can use ADB.

    The problem now is that I can

Share This Page