Lepan TC970 does NOT workSupport


Last Updated:

  1. sad custumer

    sad custumer New Member

    Just got my lepan tablet on Xmas day and this evening decided to use it and it doesn't want to turn on. No signal, tried to charge but nothing happened.

    I need some help. I just threw the box away (Tuesday). I didn't think it would stop working.

    Any idea? Anyone?

    Advertisement
  2. johna2u

    johna2u Well-Known Member

    First go out to the trash and dig out the box if you can. You have a warranty and will need the box if you want to return it. Second - Are you charging it with the charger or with usb on the computer? They need to be charged with the charger. Computer USB does not have enough juice to charge the battery on these. #rd - If you are still having problems contact Le Pan at LePanTab.com. I have had a few issues with mine and they have been very responsive. Good Luck it is a great little machine.
  3. dwczbx

    dwczbx New Member

    My lepan refused to power up after it turned off after the set time interval. I got it to turn on by pressing down on the power button AND reset button CONCURRENTLY
    DeBelleMama and teejaiee like this.
  4. billday120373

    billday120373 Member

    First off, use a powered usb hub if you are connecting to pc to charge.

    Second FAQ , Le Pan has a faq for just such an issue under the support link it also contains reset info.
  5. Tslagle

    Tslagle New Member

    i got my Le Pan as a gift for Easter and i Only had my Le Pan for 2days and it was working just fine and i decided to get it charge up and now it wont turn on... its been charging for almost 20hrs and it still wont do a thing... the ambient light dont even work. Ive reset it a few times, held down the power button a few times and its still not doing a thing... its just a black screen... the thing is when i put the charger in it, after 10 sec the battery will show up and it would say that its charging but, the moment the battery disappears i dont know if its charing because the ambient light dont even work.. I need help please... dont want the money that was spent on this be put to waste...:(:confused:
  6. fuzzmanks

    fuzzmanks New Member

    Tslagle,
    You are charging using an A/C power outlet and not a USB port on a computer correct??
  7. dugdigger

    dugdigger Member

    Hi all: has anyone been able to contact le pan in the past few days. today is april 17th .I have a TC970 that is still under warranty. but can't reach anyone by phone or email either
  8. dugdigger

    dugdigger Member

    I have the exact same problem .were you able to contact customer service at le pan
  9. teejaiee

    teejaiee New Member

    I was so frustrated because I only had it a week and loved it and now this morning it would not turn on no matter I did it would not power on. I looked on this forum and it said to hold the reset button and the power at the same time...and it worked... and the best part is all my stuff was still there.... Thanks!
  10. wongfiona52

    wongfiona52 New Member

    thanks this helped ALOT. It was loading an app then it froze and it completely blacked out. then I read this comment about holding the reset button whole holding the on button and it turned back on.
  11. KingTei

    KingTei Member

    Hello Le Pan users,

    Everyone I need your assistance.

    My Le Pan has been OK until the past two days when it went off and hasn't come back on. I've tried to hold down the power button and press down the reset hole with a toothpick at the same time but I haven't been lucky.

    Can you please let me know if there's a special way to do the power button plus rest hole or if there's anything else I can do?

    I can't hold of anyone at their customer service and my email hasn't been replied to.
    Thanking you in advance guys.
  12. exscentric

    exscentric Well-Known Member

    Couple things in case you haven't tried.

    Charge it with the wall adapter.

    Use a paper clip instead of the toothpick, the switch might not be getting pushed with the toothpick.

    If that doesn't work - you will loose your data/apps with this quite possibly - hold down the volume - button then the power for a few seconds or the volume+ then power button. One of those may trigger a reset.
    KingTei likes this.
  13. KingTei

    KingTei Member

    I've tried holding down the volume button and the power button but no luck yet. I'm going to get a paper clip and try option 2. I'll keep you posted. Thanks.
  14. KingTei

    KingTei Member

    Hello Exscentric and everyone,

    I've tried the paper clip too but no joy. Do you know of another way to resolve the problem? What if my battery has really drained?
  15. exscentric

    exscentric Well-Known Member

    If it is in warr. contact lepan - they are slow but have ultimately been contacting people. If out of warr. it might be time for a new unit - would not be much more than repair I'd guess. Lepan might have an estimate for you, I don't know.
    KingTei likes this.
  16. ngittens

    ngittens New Member

    KingTei likes this.
  17. KingTei

    KingTei Member

    Hello Exscentric and everyone,

    I've run out of options and LePan is yet to get back to me. However I've resolved to buying a new battery. Does anyone know where I can get one?

    Thanks
  18. bplescigales

    bplescigales New Member

  19. bplescigales

    bplescigales New Member

    You can use the IPAD charger by using the small flat head screw driver to bend the small clip located on the left side of your Le Pan charging port. Looking at the charging port from the top of your Le pan, bird eye's view (Screen facing toward you), you will see a small metal part inside the charging port on the left side. That metal prevent you from inserting the IPAD connector to go into the charging port. After bending that metal part flat to the side, you will be able to insert the IPAD connector wire into the Le Pan. Hook that IPAD wire to your IPAD charger and plug into the electrical wall outlet. The Le Pan charging (Battery icon) will be showing on your screen and it will charge your Le Pan. I had the same issue with the Le Pan 920 that don't turn on at all after about 10 months. I sent back and they replace it for me. After a while it happended again. I found out that all the issue (problem) is the charging wire only (big flat connector with the USB on the other end) not the charger. Both of my Le Pan wire were bad, the charger (Little black box with electrical plug) are still good. I tried both charger with the IPAD wire and they are working. Now my Le Pan is charging and working fine! Hope this will help every one with the problem. Replace the wire will solve the problem.
  20. johna2u

    johna2u Well-Known Member

    You can buy a replacement Le pan 30 pin cable at Lepanshop.com. There is also a new user forum for Le Pan at LePanForum.com. if you don't want to bend the tabs on your tablet you can buy any generic iPad 30 pin connector and shave the plastic off both ends flush with the metal. You also need to insert it upside down. As iPad cables are reverse of Le Pan.

Share This Page