LG Eve GW620 Rogers rooting guide + Remove Rogers apps


  1. britbloke

    britbloke Well-Known Member

    OK, a while ago I said that I would start a thread on how to root the Rogers LG EVE GW620.
    All of this information I found through other forums, so I just followed the steps and got a rooted Eve quite simply. All thanks go to the original rooters (Zacpod) and the fine folks over at XDA.
    I was using Windows 7 so Vista or XP maybe slightly different, but not a whole lot. Also, I did this a few weeks ago so some of it is going from memory. If any edits are needed I will update this post.
    Getting started

    First, get yourself a copy of Android SDK (it's completely free) from here: http://developer.android.com/sdk/index.html
    Read the installation guide here: http://developer.android.com/sdk/installing.html
    You only need to install the SDK, not the Eclipse plugin.

    If you're using Windows, you'll also need the ADB (Android Debug Bridge) USB driver. Get it from here: http://developer.android.com/sdk/win-usb.html

    Download the LG USB drivers from this link.
    Linux and OSX users don't need a driver (lucky you!).

    How to install the LG USB and ADB USB drivers on Windows.

    This is the part that I had the most problems with, but that's mainly because I read the instructions wrong!
    First, install the LG USB drivers from the link above.

    Then, on the phone you need to enable USB debugging mode

    Settings ---> Applications ---> Development ---> USB debugging (put a check mark here)
    Connect the phone to your PC with the USB cable.

    In Windows, you should hear the beep on a connected device and the LG drivers should find it OK. In Windows, open up Device Manager and you should see 2 devices with yellow exclamation marks beside it and the description "LG USB Modem" (I'm going from memory here, so that may not be 100% accurate).

    Right click on the 2nd one, click "Update driver software", click "Browse my computer for driver software" then click "Let me pick from a list..." You should see "Android Phone" listed. Double click this and you should see a list of 3 options. Click on "Android ADB Interface" and click "Next". You'll probably see an "Update driver warning" box, so just click "Yes" to install it anyway.

    If you don't see 3 options, click "Have Disk..." and select the Android USB driver (android_winusb.inf) you downloaded earlier.

    After all this, you should now be able to get ADB shell access to your Eve. To check you have access follow these steps:
    If you're on Windows, open a Command Prompt window but make sure you "Run as administrator" to get the privilegies needed. Linux users can use Terminal.

    Navigate to your installed Android SDK (ie: "cd c:\SDK\tools\" if that's where you installed it).
    Now type "adb devices" to see if your Eve is detected. If it is, you're good to go on.

    Rooting (all credit to Zacpod)

    Now onto the actual root. All this is taken from Zacpod's excellent post found here: http://androidnetwork.org/forum/viewtopic.php?f=22&t=143 I'll be copying it almost verbatim, and I hope he doesn't mind ;)


    1. Download the Superuser Whitelist (http://koushikdutta.blurryfox.com/Superuser/Superuser.zip) and unzip it somewhere safe such as c:\SDK\tools\
    2. On the GW620 dial "3845#*620#" to get in to the secret menu
    3. Tap "Module Test" then tap "Stability Test" then tap "Enable Root Permission"
    4. Open a Command Prompt on Windows by pressing Windows Key + R, then type "cmd" in the empty field. Note, you should also run this with Administrator rights. Linux users can use Terminal.

    Navigate to your installed Android SDK (ie: "cd c:\SDK\tools\").


    1. Type "adb shell"
    2. You should get a #. If you get a $ then something didn't work. Shutdown the phone and PC and try again. If you get a # then all is well. Type "exit" to return to your PCs command prompt.
    3. Type "adb remount" to remount the GW620's file system as read-write so we can make changes.
    4. Type "adb shell cat /system/xbin/su > /system/xbin/su.original" [Note: This step may give you a "could not find path" error. Just continue on with step 5 and the root will still work.]
    5. Type "adb push bin/su /system/xbin/su"
    6. Type "adb push bin/su /system/bin/su"
    7. Type "adb shell chmod 4755 /system/xbin/su"
    8. Type "adb shell chmod 4755 /system/bin/su"
    9. Type "adb install bin/Superuser.apk"
    You will now have root access to your Eve and can now remove the Rogers apps.

    Removing the Rogers apps (credits to the people of XDA)


    1. Make sure your phone is in USB debugging mode (see beginning of guide).
    2. In the Command Prompt (or Terminal on Linux), make sure you're in your SDK Tools folder (c:\SDK\tools\)
    3. Type "adb shell". You should see "#"
    4. Type the following commands:
    Code (Text):
    1. adb remount
    Code (Text):
    1. mkdir /sdcard/backup
    Code (Text):
    1. cd /system/app
    Code (Text):
    1. dd if=MoxierMail-2.1.20.2-GW620-Rogers.apk of=/sdcard/backup/MoxierMail-2.1.20.2-GW620-Rogers.apk
    This backs up the MoxierMail app onto your SD card.
    Code (Text):
    1. rm MoxierMail-2.1.20.2-GW620-Rogers.apk
    Code (Text):
    1. dd if=Linkbook.apk of=/sdcard/backup/Linkbook.apk
    Again, creates a backup of the Linkbook app onto your SD card.

    Code (Text):
    1. dd if=Linkbook.odex of=/sdcard/backup/Linkbook.odex
    Again, creates a backup of the Linkbook app onto your SD card.
    Code (Text):
    1. rm Linkbook.odex
    Code (Text):
    1. rm Linkbook.apk
    Code (Text):
    1. dd if=MySpace.apk of=/sdcard/backup/MySpace.apk
    Code (Text):
    1. rm MySpace.apk
    Code (Text):
    1. dd if=RingsExtended.odex of=/sdcard/backup/RingsExtended.odex
    Code (Text):
    1. dd if=RingsExtended.apk of=/sdcard/backup/RingsExtended.apk
    Code (Text):
    1. rm RingsExtended.odex
    Code (Text):
    1. rm RingsExtended.apk
    You're done. Stay in the ADB shell for the next part.



    Enable deleting of pre-installed bookmarks

    In ADB shell, type:

    Code (Text):
    1. cd /data/data/com.android.browser/databases
    Code (Text):
    1. sqlite3 browser.db "update bookmarks set readonly=0;"
    This will allow you to delete the Rogers bookmarks.
    Type "exit" in the ADB shell to return you to the Command Prompt.


    Hopefully this should help out a few people that want to root and remove the Rogers apps. You may have problems with the Windows USB driver getting recognized as I do all the time. I have to keep re-installing the ADB driver for some reason, but it get's there eventually.
    Good luck!

    Advertisement
    :
  2. davidomackay

    davidomackay Member

    I'm going to try all this. I'll let you all know how it worked out for me when I do.
  3. BiggDaddy

    BiggDaddy Member

  4. britbloke

    britbloke Well-Known Member

    I've updated the first post to the new link. The updated drivers can be downloaded here.

    Unfortunately, it's not as easy as jailbreaking an iPhone!

    It looks like there's a lot of steps, but you can probably get through it in 30 mins. Take the time to read through the guide a few times to get yourself familiar.
  5. maps

    maps New Member

    Just a quick one:

    In the remove "Remove the Rogers App" section between steps two and three you need to do an "adb remount".

    If you do not remount the phone as writeable you can not issue the "rm ***" commands.
  6. britbloke

    britbloke Well-Known Member

    Thanks maps. I was bound to forget something! Updated 1st post.
  7. RaymondR

    RaymondR Member

    I am working on this root kit right now.

    Windows 7 64 bit
    LG Eve, had it less than a week

    I have installed the SDK, the USB drivers and have managed to get to step 2 under the section "Navigate to your installed Android SDK (ie: "cd c:\SDK\tools\")."
    This is the part where you use "adb shell" and you should see the # sign. I always get the $ sign, even after multiple reboots of phone and computer.

    The command line I am running has administrator access.
    "adb devices" DOES return a device number
    USB debugging mode is ON
    I tapped the "enable root access" option in the hidden menu on the Eve

    Any ideas? I was reading on a link about another phone and apparently if you get a $ sign then you do not have "su rights". For that particular example the instructions include typing su and then they get the # sign.
    For the Eve it doesn't work that way. If you type su at the $ sign you get a
    "su: permission denied" message.

    Does anyone have an idea of how to get this to work? Has anyone got this work?

    If you need additional information about my phone/computer I would be happy to list it.

    I'm also going to go back to the beginning on this and make sure I didn't miss something in the instructions.

    Thanks!
  8. britbloke

    britbloke Well-Known Member

    I'm not 100% sure, but it sounds like you haven't enabled root permissions using the secret menu from step 2 at the beginning of my guide. I would try restarting the phone and your PC (BTW, I'm running Win7 64bit too and have never seen the $).

    The "su" or "sudo" means superuser, basically full admin rights to change any file on the system, including root.
  9. RaymondR

    RaymondR Member

    You were right. I must not have had the root permissions from the secret menu.

    I went in, set them in the secret menu and restarted the phone. When I brought it up and connected I now have the # sign.
    Thanks for getting me to try that again!

    Now for some rooting..... :)
  10. britbloke

    britbloke Well-Known Member

    Glad it worked for you. Enjoy your rooted phone!
  11. BiggDaddy

    BiggDaddy Member

    when i get to the step Type adb shell cat /system/xbin/su > /system/xbin/su.original
    i get The system can not find the path specified
  12. britbloke

    britbloke Well-Known Member

    I've replied to your PM and also updated the guide.
  13. BiggDaddy

    BiggDaddy Member

    ok so on step 5
    adb push bin/su /system/xbin/su
    i get- cannot stat 'bin/su': no such file or directory
  14. BiggDaddy

    BiggDaddy Member

    i feel like such a newb, im only hours from sticking my sim card back in my blackberry, love this eve but hate all the rogers crap on it.
  15. dufourjm

    dufourjm Member

    You really hate the Rogers crap... :eek: personnally I just do not use it... I rooted my phone to install some software... I didn't even bother to remove Rogers software. But I will probably uninstall Telenav and Linkbook that I do not use.

    I think it's not worth going back to your BlackBerry. I have nothing agains Blackberry. I just think Android offer more openness and flexibility. The problem is that Rogers does not respect the philosphy behind it. But is seem like Rogers is not alone in this case as I read from the commentaries of some other people here.
  16. BiggDaddy

    BiggDaddy Member

    you know what i think that you might be right, what do i need to do to change the theme on this thing more like the hero?
  17. SpL3rG3

    SpL3rG3 Active Member

    when i try to do step 5 in the guide, my command prompt window fills with ASCII characters and my lappy starts beeping. a few seconds after this, my system is totally locked up. Any ideas whats going on here?

    Thx
  18. britbloke

    britbloke Well-Known Member

    That's a very strange error! Can you try on another computer?
  19. SpL3rG3

    SpL3rG3 Active Member

    For some reason, my XP system (32-bit) will not pick up the Android_winusb.inf driver file for my eve. if i take the phone out of USB Debug mode, my PC picks up the phone no problem. Anyone else having this problem or know why my PC isn't picking up the driver correctly?
  20. Nismo

    Nismo Member

    when we get updated to android 1.6 would we have to root the phone again? since the update should be here soonish, deciding if i should try this now or wait till we get upgraded
  21. britbloke

    britbloke Well-Known Member

    Yes, we will more than likely have to re-root after 1.6.
  22. bikbok

    bikbok Well-Known Member

    I get the same error..

    Edit: LOL I got it. I just placed the bin folder in the wrong place in Windows.
    OK, so now I am rooted. I have heard that this helps if you want to install paid applications. But if I look in Market now, I still get only freeware or adware..
  23. Palantir

    Palantir Member

    I download and paid for GolfCard with Google Checkout on my unrooted LG Eve. No problems here for buying apps!
  24. bikbok

    bikbok Well-Known Member

    It depends on where in the world you are located. In Norway we can't access the paid section in Google Market. With an unrooted phone, I could install market enabler, then I managed to buy apps :)
Loading...

Share This Page