LG Eve GW620 Rogers rooting guide + Remove Rogers apps


Last Updated: 2013-02-10 22:34:29
  1. Zentropy

    Zentropy Member

    Hi, I'm trying to root my Eve as well, but I'm encountering the exact same problem as the person above. I've read through the first steps a few times to see if I've forgotten anything, but as far as I can see I've done exactly what I've read.

    Your comment left me a little confused though, since RaymondR stated that he did indeed enable root permissions before posting here.

    I am positive I've tapped the "Enable Root Permissions" as well. There was no prompt or confirmation of any sort short of the selection feedback though; is it supposed to be like that?

    And if not, is there any other possible cause for this? Thanks.

    Advertisement
  2. britbloke

    britbloke Well-Known Member

    RaymondR went back and made sure to "enable root permission" again, then he re-started his phone and it worked. Did you try restarting your phone?

    When you click on "enable root permission" there is no feedback other than it high lights when you touch it, and it vibrates. There's no confirmation.
  3. Zentropy

    Zentropy Member

    Thanks for your help. I had restarted my phone, but for some reason I failed to read the part where you told me to restart my computer. After I did though, I was able to proceed.

    I'm now at the "Removing Rogers Apps" step and I've encountered some more problems though.

    After "adb shell", am I supposed to type "exit" before "adb remount"? And should the code I type following that be in front of the # sign?

    During the "mkdir /sdcard/backup" step, I am told "The syntax of the command is incorrect". I didn't see any typos, am I doing something else wrong?

    I wasn't too concerned about backing up MoxierMail though, so I tried to move onto the "rm MoxierMail" step. I did this in front of the # and was told "rm failed for MoxierMail, Read-only file system" despite my going back to remount.

    How should I proceed? Thanks again for any help.
  4. britbloke

    britbloke Well-Known Member

    The "rm failed for MoxierMail, Read-only file system" error is because you didn't use "adb remount" which is what allows you to make changes.

    Try typing "adb remount" before entering adb shell. That worked for me the 2nd time I had to root. I'm not sure if it's because I updated the FW to 10f.

    I think the "mkdir /sdcard/backup" error is because you're not in adb shell and/or you didn't enable "adb remount".
  5. britbloke

    britbloke Well-Known Member

    It looks like your phone still hasn't enabled root permission from the secret menu:


    1. On the GW620 dial "3845#*620#" to get in to the secret menu
    2. Tap "Module Test" then tap "Stability Test" then tap "Enable Root Permission"
    Do this again, and then "adb remount", then "adb shell".

    If it still doesn't work, try restarting both PC and phone, and then enter the secret menu again.
  6. Zentropy

    Zentropy Member

    I thought I did enable root permissions. Multiple times with restarts too, but for some reason nothing ever worked.

    After a few attempts though, I was finally able to remove MySpace, Linkbook, and the Moxier apps. Thanks for all your help, it really was appreciated. Just a couple more questions though.

    Is it possible to remove TeleNav GPS Navigator at all? Also, the "Java Downloads" bookmark?

    Other than that, everything seems to work fine and hopefully, the Eve will stop freezing and rebooting itself.
  7. britbloke

    britbloke Well-Known Member

    Yes, you can remove the TeleNav app. On the Rogers Eve, the apk begins with tn*. I can't remember the rest, but it's a long filename. It's easy to find.
  8. severed_hand

    severed_hand New Member

    Has anyone here done this root with XP?
  9. bikbok

    bikbok Well-Known Member

    haven't tried, but it should work if you only log in as admin in the beginning.
  10. severed_hand

    severed_hand New Member

    Thanks britbloke, I found your little guide easier to follow than other threads out there. This guide works for XP well enough.

    Bye bye "Moxier" Mail, Linkbook and MySpace. I think it is totally ridiculous that Rogers would not allow the owner of this phone the option to uninstall this useless software. I have better things to hog my limited RAM with, like EasyTether for example (which works great on the EVE, BTW).

    I want the 1.6 update (should it ever appear) but then I will have to go in and root out whatever crappy software they decided to burden me with again. I definitely want the fabled firmware update that supposedly fixes the space bar/texting issue and throttles down the home keys.

    If anyone successfully roots out Telenav please post the code in this thread, I'm afraid I'm not intuitive enough, and a total noob to rooting to figure it out on my own.

    I'm a fan of this little phone, but Rogers and LG seemingly decided to use Canada as a test market, and don't seem to care very much whether their customers are pleased with a) the unremovable software and b) a rapidly aging OS. Android 1.5 works, but clogging the RAM and slowing the processor with unnecessary software is pretty hard to forgive. This will have a major influence on my next phone and carrier purchase. Right now, I can't see sticking with Rogers, as they seem to be the major roadblock to a really enjoyable phone.
  11. britbloke

    britbloke Well-Known Member

    I did manage to find the TeleNav app and delete it from my phone. I can't remember the full filename now, but it beings with "TN..." and has some version numbers at the end of the file name. It's also quite a long file name. It's easy enough to spot if you do the "ls" command when you're in the apps directory.

    When you find it, can you post the full file name and I can add it to the 1st post.
  12. Zentropy

    Zentropy Member

    The TeleNav app filename is as follows:

    Edit: I believe this is the correct filename.

    tn55-android-LG_eve-2003.apk


    tn55-android-Houdini-signed.apk

    I found it here.


    To access the apps directory britbloke is referring to above, type "ls system/app" while in the adb shell.

    I haven't been able to remove it myself, but only because I'm being told it's read-only, regardless of the number of times I restart my computer/phone or enable root permissions via the secret menu.

    I also sort of regret removing Rings Extended. I was blindly following the guide and not thinking about what I was going, but with it gone I don't think I'm able to customize ringtones anymore. I found it in the Marketplace but I can't seem to reinstall it due to an "Incompatible update", which I suspect means I need to find an older version of it to use.

    As for the v10f firmware update, it does indeed fix the space bar issue but I don't think there's a difference in the sensitivity of the home/return panels. =\

    The link on LG's site is down, but if you really want it I've uploaded it here. It's pretty intuitive; if you can root your phone then updating shouldn''t be a problem.
  13. bikbok

    bikbok Well-Known Member

    Do you really have to use ADB to delete apps? If you have root enabled and install better terminal pro, shouldn't it be possible to run the rm commands from that terminal? I tried but I only get that it is "read only". It must be possible to change this from terminal on the phone, so that you can do this without being connected to the computer, no?
  14. britbloke

    britbloke Well-Known Member

    It's possible that it may work that way. I might try it tonight to see how it goes.

    However, purely for easy of use (bigger screen, easy copy/paste of commands) it maybe better to use a PC for adb shell.
  15. bikbok

    bikbok Well-Known Member

    Yes, I know it's easier, but just for curiosity it would be fun to try. I couldn't do it with just "su" and the commands, but I think it would work by first installing Root Manager: Root Manager - This app has a read/write remount function.
  16. leonardofrazao

    leonardofrazao New Member

    Hi! When I tap "Enable Root Permission" I'm asked to enter a root password. What can I do?
  17. britbloke

    britbloke Well-Known Member

    I've never heard of that before. What firmware are you on?
  18. leonardofrazao

    leonardofrazao New Member

    I am from Brazil.
    Here's my phone info:

    Model name: GW620f
    Firmware version: 1.5
    kernel version: 2.6.27 LGE@new1 #4
    Software version: GW620f-V10a
  19. britbloke

    britbloke Well-Known Member

    I would try using the official LG update tool to get a newer software version. I'm currently running V10f, so it seems like you have an older software version.

    Try updating, then rooting again.
  20. boxx0r

    boxx0r Active Member

    Can Rogers apps be removed without rooting the phone?
  21. boxx0r

    boxx0r Active Member

    also, does rooting void the warranty on rogers?
  22. bikbok

    bikbok Well-Known Member

    I can confirm that this works.
    After enabling root access on your GW620, you can use Root Manager and enable read/write remount. Then you can browse and delete what you want.
  23. pykler

    pykler New Member

    I am planning to root my device this weekend using this guide, does rooting my phone allow me to put SIM cards that are not rogers in it? or do i still have to look for an unlock code for that?
  24. britbloke

    britbloke Well-Known Member

    No, rooting doesn't unlock the phone. You'll have to look on eBay for a seller that can give you an unlock code which is based on your phones unique IMEI.

Share This Page