LG Eve GW620 Rogers rooting guide + Remove Rogers apps


  1. boxx0r

    boxx0r Active Member

    anyone?
  2. britbloke

    britbloke Well-Known Member

    I would highly doubt it, but give it a try. The easiest way to try is to download Astro from the Market. It's a good file manager, similar to Explorer on Windows. It will let you look through folders, delete them, etc.
  3. boxx0r

    boxx0r Active Member

    Tried using Astro, but when I tried to uninstall moxier mail for example, it said it was unable to uninstall. Maybe I should try rooting. Is "un"rooting an Eve possible/as easy as rooting it? Also, does it void the warranty?
  4. britbloke

    britbloke Well-Known Member

    Technically you are voiding your warranty as you're making changes to the OS. However, you can always restore back to a stock Rogers / LG firmware if you ever have to send in your phone. Not sure if it completely reverses the root, but all the Rogers apps will be back.
  5. connora

    connora Member

    I've already installed the drivers and adb,but adb shell shows no device.

    The 2nd LG USB Modem installed as an Android Phone.

    I'm using winXP,SP2 PRO, these are my steps.
    enable USB Debugging mode,dial 3845....and enable root permission,restart my phone,connect my phone to PC,install the drivers.
    win+R TO open CMD window,cd to the sdk tools directory,adb shell,shows device not found...

    in my device manager,there's an android phone class,under it is an android Adb..


    I've failed adb in ubuntu....

    solved,I manually installed the driver in the sdk/usb_dr,use the adb in sdk/tools.
  6. inberno

    inberno New Member

    Hi! When I tap "Enable Root Permission" I'm asked to enter a root password.

    i have a GW620 orange with a V10N (installed yesterday by d the software updater agent).

    I searched through many forums and very people have the same problem, but nobody knows anything.

    Can u help me?
  7. britbloke

    britbloke Well-Known Member

    It sounds like the LG V10N software has extra security when trying to enable root permissions. Unless you can somehow find out what the password is, you may be out of luck in rooting V10N.
  8. muddled

    muddled Member

    Hi all,

    i have a successfully rooted my phone thanks to the various posters here - thanks guys! You rock!

    one tip - if you are not getting the # prompt, but getting the $ prompt instead, then you need to power-down your phone and start it up again. That solved the problem for me, at least. (others have said this in other forum posts, but I wanted to reiterate to raise it up on the Google hit list)

    One question for the group - I got rid of most of the Rogers crapola (telenav, moxier*, etc), but there's a whole section of Roger's links still in my "applications" list. The my5 link, weather, home, stocks, etc.... I want rid of ALL of them, but I can't find where those links live... any idea? Probably in a database somewhere, but I haven't had time to explore all the different sqlite3 databases on the machine yet... guidance appreciated!

    Cheers all!

    Muddled
  9. They went away for me when I deleted the Rogers.apk, The only thing I kept is the MyAccount.apk which I downloaded from the marketplace.

    Here is a diff of what went away

    Code (Text):
    1.  
    2. 3d2
    3. < Rogers.apk
    4. 9d7
    5. < RingsExtended.odex
    6. 18d15
    7. < IM_RGS.apk
    8. 29d25
    9. < Rogers.odex
    10. 52d47
    11. < FaceBook.apk
    12. 56,57d50
    13. < Linkbook.odex
    14. < MoxierMail-2.1.20.2-GW620-Rogers.apk
    15. 76d68
    16. < MySpace.apk
    17. 91d82
    18. < Email.apk
    19. 102d92
    20. < RingsExtended.apk
    21. 109d98
    22. < Linkbook.apk
    23. 118d106
    24. < RogersImPlugin.apk
    25. 123d110
    26. < IM_RGS.odex
    27. 133d119
    28. < Email.odex
    29.  
    --
    Pykler
    muddled likes this.
  10. How did you get rid of TeleNav? what was it called? :confused:
  11. britbloke

    britbloke Well-Known Member

    It's called tn55-android-LG_eve-2003.apk
  12. muddled

    muddled Member

    Just a quick note - in another of the Android developers forums the hackers are quite convinced that they'll have a functional android 2.0 for the Eve within a couple of months! BUT!! IMPORTANT!! YOU MUST NOT UPGRADE TO 1.6 if you plan to use their hack to upgrade to 2.0. This is because the "secret code" to get to the root menu seems to have changed between 1.5 and 1.6, so you wont b e able to hack 1.6 until someone leaks that code...

    Just a heads-up :)

    Muddled
  13. kropbj

    kropbj Member

    I have one question and hopefully someone can answer this for me. I followed the directions to a tee as far as I know but when I get to step 9 (Type "adb install bin/Superuser.apk) I get a message that says "install: not found"

    I'm unable to get passed this point.

    I placed the superuser whitelist in my /sdk/tools/ directory exactly as specified.

    Any ideas.
  14. SpL3rG3

    SpL3rG3 Active Member

    Try typing the full path name of the superuser file instead. When I rooted my phone, i had to type the full path name of my superuser file, even though i updated my windows path to include the SDK/TOOLS folder.
    masum73 likes this.
  15. skater008

    skater008 New Member


    Hi, Here is robbiechang come from china. now I have a LG GW620 in hand and faced software installation issue. so I follow all your steps and done it. but now the new problem that is I can't download the software from the electronic market.
    Another question that is I don't know how to install the software into the SD card and uninstall original software such as Gmail, Google talk and etc.

    Look forward to your prompt reply and high appreciate for that.
  16. skater008

    skater008 New Member

    I answer myself. I reset the phone by follow steps and solved this problem.
    settings---application---manage applications---download manager---clear data
    Restart the phone and the problem was solved.
    Anyway, thanks for everybody.
  17. amax

    amax New Member

    Hi all;
    Im new to this,so apologies in advance for any obvious bonehead moves.
    Im following the instructions so kindly laid out by britbloke, but....... my xp sp2,with lg drivers installed and showing up in Device Manager will not show android phone in list , nor will it show me sdk usb driver to update driver with. I have usb debugging enabled, and root permissions enabled. I am following britblokes instructions to the letter as far as I can tell. Any thoughts?
    rootless in Vancouver
  18. bamaredwingsfan

    bamaredwingsfan Well-Known Member

    Is there anyway possible this could be made to work on the LG ally? That phone is really handcuffed by the LG Home app, and socialite, and there is no way to remove them:(
  19. Space Dog

    Space Dog New Member

    So on both Vista and XP I get stuck at the exact same spot every time. First I plug in my Eve and it has to find the drivers, Ive tried directing it to the folder specifically as well as using Device Manager and every time I get the error Unable to install driver....you might want to contact the website blah blah blah. Anyone know what I might be doing wrong.

    (In Windows, you should hear the beep on a connected device and the LG drivers should find it OK. In Windows, open up Device Manager and you should see 2 devices with yellow exclamation marks beside it and the description "LG USB Modem" (I'm going from memory here, so that may not be 100% accurate).

    Right click on the 2nd one, click "Update driver software", click "Browse my computer for driver software" then click "Let me pick from a list..." You should see "Android Phone" listed. Double click this and you should see a list of 3 options. Click on "Android ADB Interface" and click "Next". You'll probably see an "Update driver warning" box, so just click "Yes" to install it anyway.)

    It`s this part that I am having dificulty with. Up to this part I have done everything correctly, including the Android SDK and installed all the addons found within.

    Please Help
    Space Dog
  20. Space Dog

    Space Dog New Member

    This is my exact problem!
  21. Jim_NZ

    Jim_NZ New Member

    I had same problem, it was because none of the the vendor IDs defined in the android_winusb.inf file didnt match my device.
    Back in device manager, right click the second LG USB Modem, properties, Details tab.
    Mine shows USB\VID_1004&PID_6171&MI_01\6&AF0B60F&0&0001
    which doesnt match any entries in the INF file.
    eg this was the first set of entries in winusb.inf (scroll down a bit to see them)
    ; HTC Dream
    %SingleAdbInterface% = USB_Install, USB\VID_0BB4&PID_0C01
    %CompositeAdbInterface% = USB_Install, USB\VID_0BB4&PID_0C02&MI_01
    %SingleBootLoaderInterface% = USB_Install, USB\VID_0BB4&PID_0FFF

    so I copied them & pasted in my vendor ID to make another set for my phone and inserted at the top:
    ; LG GW620
    %SingleAdbInterface% = USB_Install, USB\VID_1004&PID_6171
    %CompositeAdbInterface% = USB_Install, USB\VID_1004&PID_6171&MI_01
    %SingleBootLoaderInterface% = USB_Install, USB\VID_1004&PID_0FFF
    ;
    saved the file, and tried update driver again, again pointing it to usb_driver directory
    => bingo, it found it, installed an Android Phone device with a child of Android Composite ADB interface.
  22. masum73

    masum73 New Member

    I'm having the same issue (cannot stat 'bin/su': No such file or directory
    ). What is the path to the correct folder to place this? Currently, I have the whole SuperUser folder under android tools folder. Is that correct?
    I will appreciate any feedback.
    @Britbloke thanks for this guide.

    EDIT: I solved this by using the full path to the superuser directory.

    Original step: 5. Type "adb push bin/su /system/xbin/su"
    Modified for my PC: Type: "[FONT=&quot]adb push [/FONT]C:\Users\Masu\Desktop\Tools\android-sdk-windows\tools\Superuser\[FONT=&quot]bin/su /system/xbin/su"[/FONT]

    I had to do the same for steps 6 and 9 as well.
  23. masum73

    masum73 New Member

    I am stuck on step 9 -[FONT=&quot]Type "adb install push [/FONT]C:\Users\Masu\Desktop\Tools\android-sdk-windows\tools\Superuser\[FONT=&quot]bin/Superuser.apk"

    When I enter this commad I the following error:

    177 KB/s (18880 bytes in 0.104s)
    pkg: push
    Failure [INSTALL_FAILED_INSUFFICIENT_STORAGE]

    Any ideas or suggestions?
    [/FONT]
  24. masum73

    masum73 New Member

    Update: After restarting my PC & Resetting my device. and moving the contents of the Superuser to android tools i was able to root LG GW620.
  25. x5starblunt

    x5starblunt Member

    I really dont see the android phone that's supposed to be listed. Im running windows 7, USB debugging is checked and im sure i installed everything, help?
Loading...

Share This Page