LG G2x No networkSupport


  1. cmronald

    cmronald New Member

    I'm from Sri Lanka and I got a unlocked, rooted T-mobile G2x (Android version 2.3.7/ cyanogenMod-phoenixBlood_V1.5).
    But when I insert my Sim card no network present.
    No signal icon displays.
    on the status page of the About phone section it displays my phone number.
    Signal strength varies around -80dBm2
    But it shows the Network as Unknown.
    Mobilw network type as unknown.
    Service state as out of service.
    Mobile network state as Disconnected.

    Camera function seems to crash when ever i open it.
    The ebay seller telling me that phone worked for him.
    Please help me to resolve this.

    Advertisement
  2. timmyjoe42

    timmyjoe42 Well-Known Member

    I have found that whenever I pull the battery in mine and then boot up that I have no network connection. Once it is fully booted, I reboot and the data connection initializes. I hope a simple reboot works for you. I am also running CM7. Have you tried a different ROM?
  3. cmronald

    cmronald New Member

    Thanks timmyjoe42 for your reply but rebooting does not make any difference. I tried two SIM card so far.
    I'm not very good at Android roms but trying to update or restore a different rom. I tried but failed to update. I'll try again. I'll let you all know.
    Can it be a hardware problem?
  4. phroe

    phroe New Member

    Has anyone solved this issue? No matter what I do it does not come back up. I have rooted, changed roms, and checked my ril with getril, returned it to stock, still no sim card read. HELP!!! or does anyone want to trade or buy?
  5. brdo

    brdo New Member


    I have the same problem.

    Hi, I have LG G2x phone and problem with network.

    I'm in Europe and I got a NEW unlocked, rooted T-mobile G2x
    Android version 2.3.7
    CyanogenMod-phoenix HellFire v2.1

    When I insert my Sim card no network present
    "Mobile network not available".
    I try with two SIM card but a get same message.

    I try with some other solutions but they work with only
    for android v_2.3.3.

    Rooting doesn't work too.

    I thinking to go back to Froyo (original native system)
    but don't know how.

    Also I can't establish connection PC-phone.

    Any suggestions?

    Thanks
  6. brdo

    brdo New Member

    I also try all kind of reset (reboot) it doesn't work too.

    I'm trying to find answer on web almost two weeks
    and I read so many issues about this problem.
    People in US also have same problem, and they solution
    was to turn back phone to the seller, after all attempts
    to solve this problem. I can't do this.

Share This Page