LG Revolution Google Voice Integration Issues VerizonSupport

Last Updated:

  1. rushjjyyz

    rushjjyyz Member


    A week ago I got my Revo from Verizon. I live in a 4G LTE area. I use GV heavily, but I could not make this phone work with it.

    First, GV will not verify the number.

    Also, I cannot call the number from Gmail's call phones feature. It says "number not valid". Obviously the phone works otherwise OK and people can call me from land lines and other physical mobiles.

    Now what I tried, all to no avail:

    1. Wait and try to verify again
    2. Delete the number from GV and add it back in
    3. Change my cell number (210) 23X - XXXX
    4. Try verifying by forwarding to other phone

    I can use the GV app - dialer from the phone to make all kinds of calls, but my problem is if I don't verify, GV will not forward calls to my Revo, I cannot use the GV voicemail, etc.

    I looked up Google's and LG's support and nothing there. I called Verizon and they say it

  2. 1of7627

    1of7627 Well-Known Member

    Does your Revo have a number that's new to you or did you have it on a previous phone? I use Google Voice (not heavily) and had my mobile number previously on several phones. GV didn't have any problem verifying it and I tried things out this morning to check and it seems to work okay. Seems like a Google problem for some reason.
  3. rushjjyyz

    rushjjyyz Member

    No, it has a new number.

    However, I tried changing the number and the problem persists...
  4. hedylogus

    hedylogus Member

    I use voice almost exclusively and i haven't had any issues, other than the occasional google voice server delay issues.

    i find it hard to believe it is a rev issue, especially if you can use the app just fine. if voice isn't allowing you verify your number, my guess is that it's either an issue with the google verification process, or an issue with the verizon number. i can't think up a scenario where the phone would play a role (esp when the app works fine). i'm responding a little late, are you still experiencing this issue?
  5. rushjjyyz

    rushjjyyz Member

    Thanks for the reply,

    Yes, I am still having this problem. As I said before, the app works just fine but since I cannot verify the number, I can't use GV's voicemail and forward calls from my GV number.

    I changed the number and still the same problem.

    Do you think it may be related to the area code?

    Another thing that puzzles me is I cannot call the Revo from Gmail's call phone feature.

  6. hedylogus

    hedylogus Member

    that's an interesting point.....what area code are you using?
  7. rushjjyyz

    rushjjyyz Member

    I got a 210 on the phone and 214 on GV...
  8. Bman24

    Bman24 New Member

    It's not a Big Red issue. I worked VZW Tech Supp until about a year ago. VZW literally only provides the data link on this issue. If you're not having data issues with anything else, it's a GV issue. The old standby for this is uninstall the GV app, then reinstall. If issue persist, try changing the settings and then change them back. Outside of that it's all GV. GV isn't known for addressing issues that they don't find themselves, or seem to impact a lot of people. Apple is just as bad if not worse for trying to pass the buck back to service providers. BB was great, they'd take anything.

    Have you rooted?
  9. rushjjyyz

    rushjjyyz Member

    Thanks Bman24,

    Actually, after five weeks of trying, last week it went through.
    I ignore what changed, but it seemed to support that indeed it is a GV issue.

    Now it works perfectly.

    Thanks a lot,
  10. krizz1980

    krizz1980 New Member

    Code (Text):
    Code (Text):
    Code (Text):
  11. Koolaidpjpants

    Koolaidpjpants New Member

    I am having a similar, at least I think it is similar, issue with GV. It is installed and seems to be configured properly, however it is not pulling my voicemails. Does anyone have a possible solution to this issue?

Share This Page