LG Revolution Root: The Windows ADB Way


Last Updated: 2013-06-28 17:00:31
  1. stetsonaw

    stetsonaw Well-Known Member

    Remember, I am not at fault if you brick your phone, now, proceed.

    If you are going to do a factory reset, or root or anything like that, make sure you have your 4G activated. [/QUOTE]

    Connect your phone in charge only mode to install the LG Bootstrapper and drivers, or grab the LG Universal Drivers here.

    Change your USB Mode to Internet Connection
    Go into Settings/Applications/Development and ensure USB Debugging is turned on
    If all goes according to plan, you should see the ADB Ladybug icon in your notification bar

    I updated the Rootzwiki page with the same info found below.

    Busybox actually comes installed by LG on the Revo, how awesome is that??

    Download the rageagainstthecage binary
    Download the SU binary
    Move these files to the same directory your adb.exe is in.

    Code (Text):
    1. The > and # characters below illustrate the prompt
    2. you should have, if you have the $ when you go into adb shell,
    3. exit out and type 'adb usb' then go back into adb shell and
    4. you should see the #
    Open Command prompt (either use the Windows Key+R and type cmd or start/run, then type cmd)
    32-bit users: >cd c:\program files\android\android-sdk\platform-tools
    64-bit users: >cd c:\program files (x86)\android\android-sdk\platform-tools
    Or >cd (whatever directory adb is in)

    >adb devices (verifies you are connected)
    >adb push rageagainstthecage-arm5.bin /data/local/temp/rage
    (if the above command fails due to read-only, type 'adb usb' then 'adb root' to validate root status, then 'adb devices' again to verify connection)
    >adb push su /data/local/temp/su
    >adb shell chmod 777 /data/local/temp/rage
    >adb shell ./data/local/temp/rage
    >adb shell (If this gives you a $ prompt instead of a # prompt, type 'su', if that fails, 'exit', 'adb usb' like above.)
    #mount -o remount,rw -t ext3 /dev/mmcblk0p12 /system
    #busybox cp /data/local/temp/su /system/bin/su
    #chmod 6755 /system/bin/su

    Verify the file is in place w/correct permissions

    #cd /system/bin
    #ls -l *su
    -rwsr-sr-x root root 26248 2011-05-29 01:09 su
    (permissions name access filesize date time filename)

    At this point, you may way to remove the files you put in /data/local/temp (optional):
    #rm /data/local/temp/su
    #rm /data/local/temp/rage

    continue with commands
    #reboot

    Download and install SuperUser from the Market

    Thanks Zennmaster, _mrbirdman_ for finding the linux routes and birdman for helping me out, and droidx8971 for helping me find all the information possible!

    Now go bug XDA to create a Revo forum!

    Advertisement
    Joseph the Red and Ufkal like this.
  2. Haxcid

    Haxcid Well-Known Member

    Nicely done. Followed the steps and it appears to work perfectly.

    My antivirus software had to be disabled as it kept removing rageagainstthecage-arm5.bin as a virus. Once that was done however everything worked exactly as described. Thus far its not a brick so I assume I am good as gold.

    Now to wait for a recovery mod so when I start hacking the OS apart to remove the bloat I can easily recover should I hose something. LOL.

    H.
  3. stetsonaw

    stetsonaw Well-Known Member

    Awesome! I'm waiting on the same thing. I want to deodex it so bad! But not gonna risk it. And yeah, your AV will pop since it IS in fact a trojan, but a controlled one :D
  4. Haxcid

    Haxcid Well-Known Member

    yeah I downloaded Titanium backup pro 3.8.2 for the time being. Never used it, figured I give it a shot and see about freezing some stuff.

    I see you are from Omaha. I am originally from a small town outside Lincoln.
  5. stetsonaw

    stetsonaw Well-Known Member

    You haz PM's turned off! I went to high school in Waverly.
  6. stetsonaw

    stetsonaw Well-Known Member

    Not gonna give up. Gonna get them on live chat Tuesday.
  7. kalvinl33

    kalvinl33 Active Member

    Wow..... i sure hope you can get around to them
    stetsonaw likes this.
  8. Haxcid

    Haxcid Well-Known Member

    DOOD!!! My aunt and uncle live in Waverly. I'm from Davey. My cousins live in Lincoln and my Grandparents have a large farm outside Raymond. When did you graduate?
  9. Haxcid

    Haxcid Well-Known Member

    Eventually they will release the source. They always do. That will be good for doing roms. With a recovery mod you can get around needing the source cuz you can just nand backup your own phone, mess it up, then restore it back if need be.

    Can't wait. Really want to get the bloat off this. Hate Verizon apps.
  10. stetsonaw

    stetsonaw Well-Known Member

    Just freeze them so they don't run/show up in the drawer.
  11. njKeever

    njKeever Well-Known Member

    So awesome, thank you! For some reason when I downloaded the SU it acquired a .txt extension somehow so it wouldn't push. I redownloaded and everything worked like a charm!
  12. Ufkal

    Ufkal Well-Known Member

    Thank you, Thank you, Thank you!!!! Now I can use my titanium backup. I'm happy.
  13. stetsonaw

    stetsonaw Well-Known Member

    Do NOT restore your old SMS/MMS Message, I broke the stock messaging app doing that.
  14. Ufkal

    Ufkal Well-Known Member

    thanks for that heads up. I all I really want to restore is my angry birds. LOL..
  15. stetsonaw

    stetsonaw Well-Known Member

    LOL, same here, all 3 of them, and stupid zombies.
  16. njKeever

    njKeever Well-Known Member

    Yeah, that messed me up to. Had to do a factory wipe and reroot. :( Everything seems to be good now though.
  17. stetsonaw

    stetsonaw Well-Known Member

    same here, except my phone wouldn't recognize the sim after the reset, lol! So i had to do everything all over again as i have a new phone ;)
  18. Rav20

    Rav20 Well-Known Member

    Anyone know if setcpu works?
  19. stetsonaw

    stetsonaw Well-Known Member

    It will but won't really do you any good because you don't have a custom kernel. You may be able to under clock though.
  20. kramerica

    kramerica Well-Known Member

    Hey guys! Grand Island native here.

    Im looking at this phone myself as 4G comes to West Michigan next month. Tried the TB and between the battery and reboots, good lord. Was wanting to hold out for the Bionic, but the largest concern i have is the lack of attention this phone seems to be getting. I love theming and ROM's but have nary the skills to make them (just modify them). :)

    We might have to put Stetson and GunnerJim on the fast track to all things dev for this phone. Shouldnt be a problem if you both quit your jobs and make it full time learning and developing. Hop to it!
  21. stetsonaw

    stetsonaw Well-Known Member

    LOL, would take a LARGE amount of donations for that to happen! I'm a themer myself, not a ROM dev, hopefully here soon the action starts going on it!
  22. kramerica

    kramerica Well-Known Member

    I can only hope so. There is just something about adding some life to menu's and icon's that make the phone even more exciting. I gotta tell you that I am really digging the looks and style of this phone just from messing with it in the store.

    Now if I could get myself to pull the trigger and the other things fell in line, I would be all over it.
  23. stetsonaw

    stetsonaw Well-Known Member

    i'm already running many of my themed apps, twitter, gmail, facebook, the old DeskClock app (cuz the new one sux!). Want to deodex so bad so i can theme the framework, but not without custom recovery to get me back to stock!
  24. kramerica

    kramerica Well-Known Member

    Good stuff!
  25. xxxegoxxx

    xxxegoxxx Active Member

    so everytime I check to see if the device is connected, it tells me it's offline. did i miss something?

    nevermind, figured it out

Share This Page