LGL45C Boot.Img


Last Updated:

  1. jackv4

    jackv4 Well-Known Member This Topic's Starter

    Joined:
    Jun 28, 2012
    Messages:
    48
    Likes Received:
    10
    Here is the boot.img for any LGL45C Phone for those who are stuck in a bootloop and are still able to get into cwm
     

    Attached Files:


    Advertisement
    phloggo, desearcher and MH58 like this.
  2. Sonic132

    Sonic132 Member

    Joined:
    Mar 8, 2012
    Messages:
    13
    Likes Received:
    0
    Is this the stock Boot.img?
    Because I screwed up and wipe the SD card with the Nandroid on it.
     
  3. jackv4

    jackv4 Well-Known Member This Topic's Starter

    Joined:
    Jun 28, 2012
    Messages:
    48
    Likes Received:
    10
    Yes it is
     
  4. stloftis

    stloftis Member

    Joined:
    Oct 14, 2012
    Messages:
    11
    Likes Received:
    1
    does this file need to be renamed or anything else before I install it thru cwm?
     
  5. icymanipulator

    icymanipulator Member

    Joined:
    Oct 20, 2012
    Messages:
    8
    Likes Received:
    3
    Can this be used in emergency download mode to unbrick the lgl45c?

    I need help as I tried rooting it and it bricked on me, now it will only enter Emergency Download Mode or Boot as far as the LG splash screen, I have tried many things and so far no luck, the last I tried was using KDZ_FW-UPZ.exe and that didn't work even though everything did what it was supossed to...

    Any help would be greatly appreciated!!!
     
  6. 4218kris

    4218kris Member

    Joined:
    Sep 29, 2012
    Messages:
    6
    Likes Received:
    0
    any luck?
     
  7. Salman Johnson

    Salman Johnson Member

    Joined:
    Feb 13, 2013
    Messages:
    7
    Likes Received:
    0
    How would you use this? Like how do you install it
     
  8. hokie36

    hokie36 Member

    Joined:
    Dec 2, 2013
    Messages:
    14
    Likes Received:
    2
    yea, same dumb question here, how should i install this boot.img file?
    i'm stuck in the CWM recovery no matter how I boot, connected to PC and adb sees the phone, but not fastboot.
    tried flash your stock_ROM flashable zip, but reboot takes it back to recovery again.

    looked for some generic "adb flash/install boot.img" threads yet none was done successfully...
     
  9. RickHalle

    RickHalle New Member

    Joined:
    Dec 19, 2013
    Messages:
    2
    Likes Received:
    0
    Okay, I must be missing something here. My LGL45C is stuck booting to the cwm menu and that is all. I tried adding this zip to the sdcard and cwm aborts the installation. I suspect there is an installer script or busybox or something that needs to go with it. Note that I tried to do everything right and have at least 4 backup roms that were previously working before it got stuck in this boot loop. (I was trying to get a backup after a factory data wipe)
     
  10. snfproductions

    snfproductions New Member

    Joined:
    Dec 23, 2013
    Messages:
    4
    Likes Received:
    0
    any solution to this yet? I did the same thing.
     
  11. hokie36

    hokie36 Member

    Joined:
    Dec 2, 2013
    Messages:
    14
    Likes Received:
    2
    Any of you guys had luck? I still don't know how to flash a boot.img while I cannot boot to the OS and use the "flash_image" script, or enter fastboot mode for this particular phone.
    So how to...?
     
  12. RickHalle

    RickHalle New Member

    Joined:
    Dec 19, 2013
    Messages:
    2
    Likes Received:
    0
    No luck here, I messed with it for about 5 days and then gave up and got another phone. If someone does figure it out I would love to get that one working again. Note that the battery is long since dead and was not charging when plugged in so whatever it is will need to work via the cable.

    FWIW, this seems to be a CWM boot issue and there is no way once installed to get around it.
     
  13. hokie36

    hokie36 Member

    Joined:
    Dec 2, 2013
    Messages:
    14
    Likes Received:
    2
    Thanks for the message! And similarly here, I think at some point, I pushed the button too quick and didn't use the original boot.img. (which is specified in the thread of both ROMs for L45C). So I'm stuck with a boot.img from those ROMs, not original one. As a result it won't boot pass CWM no matter what stuff I flash. Without flashing the original boot.img (which was supplied here), I don't think I can make the phone boot to OS.

    In the other "How to Unbrick xxx" thread, I, like many, had difficulty restore the phone as well. I even managed to get an updated version of that red LG logo software, which is now called "LGMobile Support Tool". It'll download factory image but once it enters the flashing step, the software reports an error and didn't flash it. That is the same as reported using early tools in that thread. SO, you can't restore it.

    You cannnot factory restore your phone or flash a correct boot.img back onto it. Well, it is soft bricked, but it is BRICKED.

    I decided not to waste more time on this dev-diminished device but sell it for whatever it'll get.
     
  14. RealWelder

    RealWelder Active Member

    Joined:
    Oct 27, 2015
    Messages:
    35
    Likes Received:
    2
    A guy buy the name of BigJake posted this for the optimus q, it work also for the recovery bootloop issue on l45c. Just install zip from sdcard. Then go to Advanaced/RestartRecovery and it will factory reset the phone thru the new (stock) recovery then boot into android. Then just reflash CWM! Unfortunately for me before I tried this I flashed your boot.img that said it was for the 45c but turns out it was for the 55c so now I have no CWM and no touchscreen to grant SU permissions to adb to flash correct boot img. If anyone has any ideas on this please let me know. I am into the os tho just no touch screen or recovery.

    Edit: Solved my problem by using "adb root" command to restart adb with root. Then I flashed CWM back on it and restored my backup. NOTE for others who may have this issue, with the md5 mismatch on your backup. Just delete the nandroid.md5 file from your backup and create a new (blank) file and name it nandroid.md5, then CWM will skip the md5 checks. I am glad I figured this thing out... I was stressing! If anyone needs help pm me and I can try to help as much as possible.
     

    Attached Files:

    Last edited: Nov 26, 2015
    #14

Share This Page

Loading...