Root Link2SD Mount script error

Discussion in 'Android Devices' started by Demented755, Jun 7, 2012.

  1. Demented755

    Demented755 Well-Known Member
    43

    Mar 10, 2012
    250
    34
    43
    The moon
    I'm trying to set-up Link2SD on a fresh install of the Metro recovery image but keep getting the same error.

    Choosing ext2 for the 2nd partition.
    Before I was getting an error that said there's not enough space on device.


    I've already tried wiping everything and reinstalling the recovery image but that doesn't seem to have helped any. Also just redid the partition in CWM; 256M with 0M swap which didn't help. I'm actually going to wipe and put the recovery image in again since I accidentally hit "fix permissions" in CWM and processes keep failing, but I doubt if this will fix the Link2SD issue.

    Any help is appreciated on how to solve this issue so I can use Link2SD.
     

    Advertisement

  2. blaze420916

    blaze420916 Well-Known Member
    93

    Jan 27, 2012
    886
    104
    93
    electrition
    Sacramento
    Format your sd card
     
  3. Demented755

    Demented755 Well-Known Member
    43

    Mar 10, 2012
    250
    34
    43
    The moon
    Formatting hasn't helped.
     
  4. Spikebob21

    Spikebob21 Well-Known Member
    43

    Apr 28, 2012
    170
    47
    43
    Brooksville, FL
    Is the error from links2sd or in cwm?
     
  5. Demented755

    Demented755 Well-Known Member
    43

    Mar 10, 2012
    250
    34
    43
    The moon
  6. Spz0

    Spz0 Well-Known Member
    113

    May 17, 2012
    773
    252
    113
    OR
    You know, I've been having this problem a lot with link2sd with the admire/vitality. I must have formatted my sdcard half a dozen times.
    The only thing that solved it for me, was mounting via fat32 instead of ext. =\
     
  7. Demented755

    Demented755 Well-Known Member
    43

    Mar 10, 2012
    250
    34
    43
    The moon
    I finally got it sorted. Without formatting or partitioning again it decided to start working after flashing another recovery image again.
     
  8. QahsiLuhgom

    QahsiLuhgom New Member
    15

    Dec 4, 2014
    4
    0
    15
    Male
    What do u mean by flashing
     
  9. QahsiLuhgom

    QahsiLuhgom New Member
    15

    Dec 4, 2014
    4
    0
    15
    Male
    Because I've got the same problem and I can't fix it
     
  10. Geezer873

    Geezer873 New Member
    25

    Feb 15, 2011
    3
    0
    25
    I had the same problem and made it go away by setting both partitions (ext2 & Fat32) to Primary in the MiniTool Partition wizard.
    Completed the feat at 03:08 17 Jan 2015.

    Flame On -
    For a Geezer like me with over 20 years software test experience it was counter-intuitive that both partitions could be primary. If I had to have paid my consulting fee rates this fix would have cost me $1500!
    Flame Off

    I did not check the forum before I made this post. I am a Galaxy Victory owner That is running stock Sprint Android Ver 4.1.2

    Sorry :oops::saddroid:

    Regards
     
    #10 Geezer873, Jan 24, 2015
    Last edited: Jan 24, 2015

Share This Page

Loading...