Linked contacts display nameSupport


Last Updated:

  1. jayloren724

    jayloren724 Member This Topic's Starter

    Joined:
    Jul 17, 2010
    Messages:
    21
    Likes Received:
    0
    I've done a search and couldn't find any definitive answer and couldn't figure it out on my own.

    Is there a way to select which name you want to display for linked contacts? For example, I have a contact with 4 linked profiles (phone, google, facebook, twitter); It is displaying the twitter name and I'd rather it display the actual name (from any of the other linked profiles). When i go to edit this contact, the first name and last name is what i want it to display, yet it still display the twitter name.
     

    Advertisement
  2. KW802

    KW802 Member

    Joined:
    Aug 16, 2010
    Messages:
    5
    Likes Received:
    0
    I'm bumping this as I have the exact same problem (but with my Droid 2).

    It seems no matter what I try it ends up displaying the Twitter name in my Contacts list. I would prefer that it show either the Phone contact name or the Google contact name.
     
  3. jayloren724

    jayloren724 Member This Topic's Starter

    Joined:
    Jul 17, 2010
    Messages:
    21
    Likes Received:
    0
    I've never figured out how to get it to work, I've tried every possible combination of unlinking, editing, saving, re-linking, etc.

    In the end, I removed my twitter from accounts (so it doesn't show up in my contact list), as I'm using the native twitter app, without syncing contacts.

    You say that you're having the same problem on your Droid 2, which is running Froyo. I was hoping the Froyo update for the X would have fixed this, but it might not be the case since you're experiencing this too. This is really unfortunate.
     
  4. KW802

    KW802 Member

    Joined:
    Aug 16, 2010
    Messages:
    5
    Likes Received:
    0
    It's very frustrating. For whatever reason it seems to give priority to the other accounts like Twitter & Facebook over the Phone & Google accounts. For example, I also removed Twitter from my list of accounts but now the Facebook names are showing instead of the Phone or Google names.

    I've been trying the same thing as you... unlinking, re-linking, trying different methods of linking (eg: linking the Google account to the Facebook and the other way around, linking the Facebook account to the Google account), removing & re-adding my FB credentials, etc., all with no luck.
     
  5. earnric

    earnric New Member

    Joined:
    Aug 6, 2010
    Messages:
    3
    Likes Received:
    0
    Just posting so I get a reply if this one is solved.

    My friends' twitter names show up in the contacts: but I want there REAL names to show -- AND for those contacts to be linked to twitter.

    Seems straight-forward enough huh?
     
  6. WickedGoddess

    WickedGoddess New Member

    Joined:
    Aug 25, 2010
    Messages:
    1
    Likes Received:
    0
    Same problem here. It's driving me nuts!
     
  7. fancypantz

    fancypantz New Member

    Joined:
    Oct 24, 2010
    Messages:
    4
    Likes Received:
    0
    Also having the same problem! x_x
     
  8. musicandnumbers

    musicandnumbers Member

    Joined:
    Jun 23, 2010
    Messages:
    5
    Likes Received:
    1
    I've tried every combination of deleting, creating, editing, unlinking, relinking, you name it. Nothing works!
     
    fancypantz likes this.
  9. mxsjw

    mxsjw Well-Known Member

    Joined:
    Jul 7, 2010
    Messages:
    1,311
    Likes Received:
    171
    I think, and I'm saying this is what worked for me...
    Start by Un-linking them if you've already linked some up.
    Pull up the contact you don't want to keep the name for and link it to the one you do want the name to be.

    Example.
    John Doe (do not want this name)
    John Doe Sr. (this is the correct name)

    Pull up "John Doe", click hard menu button, select Link contact, select "John Doe Sr.".
     
  10. fancypantz

    fancypantz New Member

    Joined:
    Oct 24, 2010
    Messages:
    4
    Likes Received:
    0
    That didn't work for me either. *sigh* :(
     
  11. bbuck002

    bbuck002 Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    622
    Likes Received:
    60
  12. bjwheeler

    bjwheeler New Member

    Joined:
    Nov 27, 2010
    Messages:
    3
    Likes Received:
    0
    Same problem here with new droid pro. Just posting so I can get notified about a solution if there is one.
     
  13. jenwski93

    jenwski93 New Member

    Joined:
    Dec 18, 2010
    Messages:
    3
    Likes Received:
    0
    still having this problem, like everyone else, have tried all options. i don't remember having this problem with my droid 1...there was an option to select priority of linked contacts I believe. that needs to be included with an update asap!

    for the meantime, deleting my twitter accounts from my accounts and just using tweetcaster helps...but that seems like a silly solution.
     
  14. lolhoward

    lolhoward Member

    Joined:
    Jan 22, 2011
    Messages:
    7
    Likes Received:
    0
    Select the contact you have linked them all to. Press the linked symbol/button then click the down arrow next to his/her name and you can select there contact name shown from either google/fb/twitter etc.
     
  15. Shiuko

    Shiuko New Member

    Joined:
    Mar 24, 2011
    Messages:
    4
    Likes Received:
    0
    This works for me, (on Dell Streak5 2.2.2 official ROM) I can't guarantee that it'll work for you, but can I guarantee that it's worth a try. :D

    Separate all of the different accounts linked to the main contact and then go to edit (from the main contact as this is the name that you want to use) go to join and join then one by one to the main contact.

    Alternatively, create a new contact with the name that you'd want to be used and input a phone number as it won't save it otherwise.
    Once it's done, go to edit contact (this same contact that you have just created )and then go to join and join then all together one by one always starting from the number that you'd want to use as your identifier.


    I hope that my instructions are clear enough for you all to follow, if not, ask away and I'll try to make myself more clear.

    It's all clear in my head, but English is my second language (I'm Spanish) so it's slightly more difficult to put it into words.
     
  16. billy221

    billy221 New Member

    Joined:
    Apr 7, 2011
    Messages:
    1
    Likes Received:
    0
    Your directions make sense. However, on my DroidX, neither method you provided helps.

    Thank you. Hopefully this will be corrected sometime in the next year...I may just upgrade to an HTC.
     
  17. stefien

    stefien New Member

    Joined:
    Feb 24, 2011
    Messages:
    4
    Likes Received:
    1
    Here's the only way I know of that works.

    Create a phone contact with the name you want to be displayed. Don't put any other info in, just the name. Join that to the contact. The name you created will take precedence.

    Hope this helps!
     
  18. mylady8

    mylady8 New Member

    Joined:
    Jun 27, 2012
    Messages:
    1
    Likes Received:
    0
    I know this is old but:
    go to contacts
    click on the contact you want to edit
    in their options press "mark default" => you will get a list
    pick the one you want to show as display name.
     
  19. Waltz In Air

    Waltz In Air New Member

    Joined:
    Apr 18, 2015
    Messages:
    1
    Likes Received:
    0
    I just figured it out (for Samsung S4 Active)! It's the same as the previous reply though.

    Click the contact, click the option button (the left of the home button), then click "Mark as default", then click your desire displayed name for that contact.

    Ta-da!
     
  20. Moss Staples

    Moss Staples New Member

    Joined:
    Jun 19, 2015
    Messages:
    1
    Likes Received:
    0
    So this last method used to work but as of an android update on my S4 a couple of days ago, there is no longer the "mark as default" option when in a contact. You can select a default number or email address etc by holding on the data point you want but the same is not true for names.
     
  21. Graham Chamberlain

    Graham Chamberlain New Member

    Joined:
    Oct 18, 2015
    Messages:
    1
    Likes Received:
    0
    This just worked on my Samsung Galaxy S4 with Skype 6.6.0.333:
    click on the contact
    click Edit Contact in the (bottom left) option menu
    click on the contact name to Edit as required and
    then click the 'tick' icon top right to save
    QED
     

Share This Page

Loading...