Linux + UnrEVOked3


Last Updated:

  1. NoShftShck16

    NoShftShck16 Well-Known Member

    I'm looking for a few answers on how to do the painless root on Ubuntu

    1. Download unrEVOked3 for Linux (check)
    2. What now? (be descriptive)

    Do I literally just connect the phone and double-click the file in the tar.gz?

    Advertisement
  2. outsid0r

    outsid0r Active Member

    yes, it is that painless
  3. govee

    govee Active Member

    I had to extract the executable ("reflash") to use it. I extracted the file to my SDK/tools folder. I did not have to chmod to run the app. I navigated to the SDK/tools folder and ran "reflash". A GUI pops up and says at the bottom waiting for phone to be connected. Once I connect the phone, the phone quickly reboots and the gui indicates waiting on bootlaoder. This is as far as I get, so I have no idea whats next.

    you can also execute the app through terminal by changing the directory to the one with the reflash file and coding "reflash" and the gui will run the same.
    NoShftShck16 likes this.
  4. Neotericpiguy

    Neotericpiguy Member

    This is the process I took that seems to work.
    1 Download Unrevoked v3
    2 Connect phone to computer and make sure the phone is on.
    3 untar reflash.tar.gz "tar -xzf reflash.tar.gz"
    4 run "sudo ./reflash" - ./reflash needs to be run with admin privledges.
    5 "Waiting for bootloader..." will come up and restart your phone.
    6 "Waiting for reboot..." will restart your phone after the necessary changes are made.
    7 "Rebooting into recovery..." will again restart your phone and drop you off at the ClockworkMod.
    8 "Done!" is the final message and you can safely press the trackball button to select reboot.

    Nice quick and easy. Unrevoked really out did them selves with the GUI.
  5. NoShftShck16

    NoShftShck16 Well-Known Member

    You guys are all lifesavers. I havent used windows in so long that the painless root was very very painful.
  6. govee

    govee Active Member

    run as root was probably what i was missing. Thanks:)
  7. govee

    govee Active Member

    Just wondering... I remember that generally Gui's are not suppose to be run with sudo, but with gksudo. Is that not the case any more?
  8. NoShftShck16

    NoShftShck16 Well-Known Member

    No idea, but i ran it with sudo without any problems.

    Ubuntu 10.4 64bt
  9. govee

    govee Active Member

    Using sudo did it. That was way too easy. Now time to get the other items going.
  10. im using an ubuntu live cd to root using unrevoked3 on my powerbook but when i run "sudo ./reflash" i get a syntax error
  11. govee

    govee Active Member

    I'm not sure but since you haven't installed I am not sure you can run sudo. Maybe try "sudo su" and then "./reflash".
  12. okay, i'm trying that right now.

    Just tried that i got "bash: ./reflash: cannot execute binary file" any ideas?
  13. Neotericpiguy

    Neotericpiguy Member

    chmod 755 reflash
    sudo ./reflash

    this should make reflash executable.
  14. When I execute "chmod 755" then "sudo ./reflash" I still get "./reflash: 1: Syntax error: ")" unexpected"
  15. Neotericpiguy

    Neotericpiguy Member

    ./reflash: 1: Syntax error: ")" unexpected

    Sounds like an error when you are running a script. I would try and download the newer unrevoked 3.1 for linux tar.gz and try extracting and running it again.
  16. Thanks for all your help I just used unrevoked on my dads MacBook pro instead though
  17. Anc82

    Anc82 New Member

    So I have recently aquired my wife's handmedown Incredible and am trying to root it. I'm running Ubuntu 8.4 and have downloaded the Linux version unrevoked3 and it appears to run, but doesn't recognize that my phone is plugged in. I've tried all four settings, Charge, HTC Sync, Disk Drive, and Network, no dice.

    Any ideas? Thanks.
  18. sdrawkcab25

    sdrawkcab25 Guides Guide

    Are you running it as superuser?

Share This Page