1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

List of apps I've removed from /system/app (after Motoblur disable)


  1. p_025

    p_025 Well-Known Member

    After using the process to disable/bypass Motoblur I posted at http://androidforums.com/devour-all...ss-motoblur-keep-your-apps-root-required.html I now had a rooted Devour without Motoblur and a ton of bloat, and other stuff in /system/app that I didn't need anymore. So I spent a few hours seeing what could be removed and what couldn't, with minimal impact on the actual functionality of the phone.

    Turns out, after bypassing Blur like that, a great deal can be done away with. Since Blur is bypassed completely, you won't be getting your email through it, and your Facebook won't be synced, so all the Blur stuff related to those can be removed. The only problem I've had so far is going into Settings->Accounts gives a force close, but that's simply because of bypassing Blur itself.

    Here's a complete list of APKs and ODEXes I've removed from my /system/app folder without any noticeable problems on my phone. On the contrary, it seems to run smoother and has far fewer problems with random reboots. If anyone can point out any problems removing these does cause, I'll be more than happy to remove it from the list. You could also probably remove a lot more than this (such as Alarm Clock and Calculator) but I keep those because I use them. It's up to you.
    Code (Text):

    AdminFeedNotifier-release.apk & odex - Unknown
    CityID.apk - CityID (bloat)
    com.verizon.handset.mim.apk - MobileIM (bloat)
    com.vzw.vvm.android.apk - Visual Voice Mail (bloat)
    DlnaDms.apk & odex - DLNA app (bloat, I don't know wtf it's for)
    DlnaSystemService.apk & odex - DLNA services (bloat, I don't know wtf it's for)
    DrmProvider.apk & odex - Unknown
    Email-release.apk & odex - Blur e-mail engine, useless once Blur is bypassed.
    FriendFeed-release.apk & odex - Happenings (Blur)
    HelpCenter-release.apk & odex - Help Center (bloat)
    MessagesWidget-release.apk & odex - Messages widget (Blur)
    Messaging-release.apk & odex - Messaging (Blur), text messaging will work without this!
    MotoPhonePortal.apk & odex - Phone portal (Blur), useless bullcrap when you connect to your computer by USB
    Music.apk & odex - Music, I just removed it because I'd rather use Tunewiki
    MusicSync.apk & odex - VCast Music Sync (bloat)
    News-release.apk & odex - News (Blur)
    PicoTts.apk & odex - unknown
    QuickOffice.apk - QuickOffice. I actually kept this one since it's not useless!
    SetupWidget-release.apk - unknown
    SocialMessaging-release.apk & odex - Facebook messaging portion of Blur
    SocialShare-release.apk & odex - Facebook picture/status sharing portion of Blur?
    StatusWidget-release.apk & odex - Facebook status changing widget (Blur)
    TtsService.apk & odex - Text-To-Speech service? TTS apps still seem to work without this…
    Universal-release.apk & odex - unknown
    Upgrader.apk & odex - Phone firmware upgrader? After Blur disable it won't work anyway.
    VCastMusic.apk - VCast Music (bloat)
    VCastVideos.apk - VCast Video (bloat)
    VoiceSearch.apk - Voice Search (bloat?)
    VpnServices.apk & odex - Virtual Private Networking, never understood how to set up this bullcrap
    VSuiteApp.apk & odex - Voice Commands, see below
    VZNav.apk - VZ Navigator (bloat)
    WeatherForecast-release.apk & odex - Weather widget (bloat)
    WorkContacts-release.apk & odex - unknown
    The thing with VSuiteApp.apk is once you remove it, you will get infinite Force Close errors. Just restart your phone, and it will shut up. But you can imagine, it will break the Voice Command button. Well, someone already thought of that too. You know how the Devour lacks a Search button? Let's kill two birds with one stone.

    Go into /system/usr/keylayout/ and open adp5588_keypad.kl and find the line "key 71 VR" and replace VR with SEARCH and save the file. Restart your phone for it to work.

    Until you know exactly how removing all this crap will affect your phone, you should probably simply rename the files to have ".bak" at the end so you can restore them should you want them again. If you do go ahead and delete them, you can free up some space in /system for other things, like apps you want to keep should you have to do a "factory reset". Please post results in this thread, I'll be watching it closely. Always remember, if your phone gets "bricked" you can flash the original Devour SBF file.

    Advertisement
    :
    deuce237bblock likes this.
  2. erickrocks1126

    erickrocks1126 Active Member

    I've successfully rooted and permanently bypassed Motoblur. Next step is to start removing un-needed apps. Question, as implied by the title...do you need to used ADB to remove these apps? I tried using Astro file manager to rename...said insufficient permissions. Then tried to delete using Astro and just got an error. Assuming I'll have to use ADB? If so, I'm guessing I run

    adb shell
    su
    then start doing the "rm" on the apk/odex files?

    Thanks!
  3. p_025

    p_025 Well-Known Member

    You can use ADB if you like. It is easier to use a file manager that will ask for and use superuser permissions though (like Root Explorer). Astro probably doesn't work since it doesn't look like it actually has root permissions even though your phone is rooted.
    erickrocks1126 likes this.
  4. erickrocks1126

    erickrocks1126 Active Member

    p_025 -- thanks again! I'll look for Root Explorer and replace Astro. If I did use ADB, is the process above in my previous post the way to do it? Looking to use ADB more so I can learn it...doing things like the above would be good hands on training! ;-)
  5. deuce237bblock

    deuce237bblock New Member

    Hello p_025, I have a quick question, after I removed the Voice Command app (VSuiteApp.apk) I went into the /system/usr/keylayout/ and opened adp5588_keypad.kl and edited the "key 71 VR" to say "key 71 SEARCH" like you say in your post but when I go to save it I get an error saying "Error occurred when trying to save file. It will not be saved." I am using ES File Explorer and the ES Note Editor to edit the file.
    Could it be ES File Explorer why I get this error? What did you use to edit this file?
  6. p_025

    p_025 Well-Known Member

    You need to be sure to have /system mounted as R/W. I used the text editor built into Root Explorer to edit the file.
  7. deuce237bblock

    deuce237bblock New Member

    How do I mount /system as R/W?

    Edit: I found a solution, I used Ghost Commander (a Root Explorer alternative) to edit the file, I tried ES File Explorer, Astro File Manager, and some other file manager apps but none of them permitted superuser permissions and didn't offer "Mount Points" or "Root Mode" to mount in to "rw" mode and mount back to "ro" mode like Ghost Commander does.
  8. JSAII

    JSAII Member

    After deleting all of the files you have posted above I have run into a minor error that keeps popping up. This pops up "The application Home(process com.motorola.blur.home) has stopped unexpectedly. Please try again." whenever I am adding or removing an app from the desktop screen.
    is this normal? If so any help or suggestion would be awesome!
Loading...

Share This Page