Long press search doesn't work with hardware keyboard openSupport


Last Updated:

  1. jason600

    jason600 New Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    4
    Likes Received:
    0
    On my UK Milestone (rooted), long press on the search button only works when the hardware keyboard is shut, when the keyboard is open, long press works the same as a short press.

    While looking for a fix for this, I found very little information on the net, so I'm wondering if it's a problem with only selected devices. Can anyone confirm for me if theirs works or not?

    Also, has anyone got any ideas on how I can fix it.

    I have OpenSearch assigned to long press search, and since I always use the hardware keyboard, I need to close it, long press search, then open the keyboard. It's annoying.

    I've looked at editing the qwerty.kl file in /system/user/keylayout, my idea was to try to redefine to search key on the keyboard (between left alt and @) to launch OpenSearch, but it apears that I can only redefine keys to other keys that way, not launch apps.

    Any and all help appreciated.

    Thanks
     

    Advertisement
  2. thesloth

    thesloth Member

    Joined:
    Mar 15, 2010
    Messages:
    17
    Likes Received:
    0
    sorry i can't help you out here, but i can confirm that i have this same problem (on a telus milestone). hope to see this fixed!
     
  3. jason600

    jason600 New Member This Topic's Starter

    Joined:
    Jun 22, 2010
    Messages:
    4
    Likes Received:
    0
    Thanks for the confirmation.

    I found sort of a workaround for anyone who is interested. Go to Preferences, Applications, Quick Launch. There you can define shortcuts to launch applications. To use, press and hold Search and the letter you have configured. For example, I configured the letter Q to launch OpenSearch, so to launch, I just press Search and Q.

    It is really a great, quick way to launch apps when you have your keyboard open.
     
  4. fejker

    fejker Well-Known Member

    Joined:
    Feb 8, 2010
    Messages:
    248
    Likes Received:
    50
    When I try to long-press the search button with the keyboard open on my Milestone the phone reboots after closing the hardware keyboard. :s

    I never use this feature anyway, just thought I'd share my results.

    PS: I'm pressing the search button on the hardware keyboard.
     

Share This Page

Loading...