Lost ability for USB Mass StorageSupport


Last Updated: 2013-06-11 17:24:06
  1. doctorj77

    doctorj77 Member

    Yesterday:

    Noticed I no longer had the ability to connect via USB for mass storage to my PC. I rebooted the phone once, then it worked. Got what i needed onto my work laptop

    Today:

    Tried same thing again, connected via usb cable, just sits there charging. Doesn't prompt me to connect. So I rebooted my device like yesterday. Upon reboot, I got message that the 73.1mb VS920ZV8 OTA update applied successfully.

    I'm thinking, cool, maybe that fixed it. Nope. still can't get USB to mount for mass storage to my PC. Anyone having this same issue with their spectrum? I can't even find it the long way, the option now in the menu settings, doesn't' exist now. While I'd like to blame the V8 update, appears this happened before the download occurred.
    .
    .
    .
    .
    EDIT: may have found the problem. It looks like it might be my laptop. But its weird, all 4 ports it fails to connect on . Took it to a co-workers laptop, tried it on one port, failed, tried it on 3 others and it worked. Then went back to the 1st one I tried, and now that's working. So all 4 on his laptop are working now. But still, all 4 on mine are not
    .
    .
    .
    .

    Maybe its just time for a new laptop & phone.......... ugh!

    Advertisement
  2. ortrigger

    ortrigger Well-Known Member Contributor


    Try rebooting with the cable connected to your phone.
  3. doctorj77

    doctorj77 Member

    No love for the reboot. I pulled the battery too, nothing. I did just test with a co-workers USB cable for his Nexus, nothing changed.
  4. Harry2

    Harry2 Well-Known Member

    If your phone got Jelly Bean with this update might be this the reason for failing to connect as mass storage. JB hasn't this feature any more.

    But your laptop should you let choosing to connect as media.
    Make sure your laptop is connected to the internet, because of the needed new drivers.

    Harry
  5. doctorj77

    doctorj77 Member

    WTH, I just got it work, once. Screen had been off for a min, but still attached to the usb cable, but detached at the other end. So I plugged it into my laptop, and whoilah, buzzed twice "on silent mode", and prompted me to change my connection type.

    I did the exact same steps over and over, and now I can't get it to do it again.
  6. doctorj77

    doctorj77 Member

    Yeah no issues with my laptop. Technically its my work one, but its same connection, usb cable, that I've been using nearly a year now. My LG is still on ICS for now. But I'm just blown away, its temperamental.
  7. ortrigger

    ortrigger Well-Known Member Contributor

    Are you on stock, rooted? Or do you have a rom installed?
  8. Yoinx

    Yoinx Well-Known Member

    Try going to your settings > storage > hit your menu button and set your usb option there maybe?
  9. chaby

    chaby New Member

    yes... i think i found a small solution... (maybe not the best) but it works...
    make sure you have all the drivers installed... and you have to be rooted.

    go to your app store (google play) and download "USB switcher for SGS1 on CM"

    (if you dont have google play try to download the apk elsewhere.. download it and use another phone (that the computer does detect) put your the sd card and copy the file.. after put the sd card on your phone and install...)


    ok back to business .. after you download the app

    connect the phone to the pc with the usb cable...
    open the app and and click.. "change to MTP" .. then select "Yes, reboot now"
    if you see a sign saying.. "superuser stopped (or any other app) ITS NORMAL
    dont click ok.. just let it reboot....

    once the phone turns on... WITH THE USB PLUGGED.... it should work...

    for some reason on my phone.. Lg revo vs920... I HAVE TO DO IT TWICE... idk why? :?
    it just works the second time...

    the bad part is... you'll have to reboot (twice in my case) every time i connect the phone to the pc...

    maybe it will work permanently for someone else..

    anyway im sooooo glad it worked!!

    its not the best way.... but its a way... because i tried everything ....

    if anyone else has another solution.. please let me know..

    also.. please let me know .. if this worked for you...

    luck!
  10. Yoinx

    Yoinx Well-Known Member

    Seems like a very roundabout way to do it. As I posted above... the option to change to Mass Storage has been changed in 4.2.2 so it's now a menu option in the storage screen.

    Did you try toggling it there and it didn't work?
  11. reeseboy

    reeseboy Well-Known Member

    You don't need the app for that to work... rebooting your phone while its plugged into the computer generally does the trick.
  12. oliverjames

    oliverjames Member

    Rebooting with phone usb plugged to computer did it for me. USB mass storage option now re-enabled.

Share This Page