Loudspeaker defaults to ON for calls?!Support


Last Updated:

  1. gnirtS

    gnirtS Member This Topic's Starter

    Joined:
    Jun 30, 2010
    Messages:
    10
    Likes Received:
    0
    Im running a non branded desire at 2.2 but its developed an annoying problem.

    Whenever i make a call or answer a call it defaults to loud speaker ON and i have to press the button to disable it. I can't see any menu setting anywhere to cause or change this so any idea how i fix this?

    Also, maybe unrelated but whenever i first boot the phone it comes up with an icon saying "car mode on" which i have to disable by clicking on it (but this doesnt stop the speaker phone behaviour)

    Any idea how i can get speaker phone to default off?
     

    Advertisement
  2. applefruit

    applefruit Well-Known Member

    Joined:
    Jun 9, 2010
    Messages:
    63
    Likes Received:
    3
    Get tasker.
     
  3. Moogle

    Moogle Well-Known Member

    Joined:
    Jun 22, 2010
    Messages:
    117
    Likes Received:
    1
    Can't really help, but I'd say the car mode thing sounds definitely linked. Had you added any accessory or done anything differently just before the car more thing started?
     
  4. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,304
    Check all the ports for pocket lint or something that could be making contact, making it think its docked.

    I had this issue, but a battery pull solved
     
  5. gnirtS

    gnirtS Member This Topic's Starter

    Joined:
    Jun 30, 2010
    Messages:
    10
    Likes Received:
    0
    Cleaned the USB port as best i can but doesnt fix it.

    Its not in car mode all the time - on first boot it has car icon which i then select to disable. The icon vanishes. However calls still go to speaker unless i hit the button to transfer to earpiece even without it.

    Tried battery pulls, reboots etc. Reluctant to factory reset due to losing apps etc.

    No accessories used with the phone at all.
     
  6. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,304
    download mybackup free (its a 30 day trial) from the market. Should do a good job backing up most of your data and apps.

    Also, its possible the automatic backup from the desire will kick in and ask you to restore too.
     
  7. mlines

    mlines Active Member

    Joined:
    Jun 8, 2010
    Messages:
    27
    Likes Received:
    1
    Any solution to this???

    I have the same problem except mine reverts to Car Mode all the time

    Martin
     
  8. gnirtS

    gnirtS Member This Topic's Starter

    Joined:
    Jun 30, 2010
    Messages:
    10
    Likes Received:
    0
    Not found one yet. tried a factor restore and no joy (mybackp managed to lose lots of app data and settings too).

    Mine isnt doing it all the time, it puts car mode on boot but i can turn it off. BUT it routes all calls to speaker phone until i press to turn speaker off.

    Looks like next stage for me is screwdrivers to get the phone apart to see if theres a short.
     
  9. SpicyTacoto

    SpicyTacoto Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    70
    Likes Received:
    4
    just developed this exact same issue myself. Any luck with a fix?
     
  10. SUroot

    SUroot Well-Known Member Developer

    Joined:
    May 25, 2010
    Messages:
    23,925
    Likes Received:
    5,304
  11. ceejaycee

    ceejaycee New Member

    Joined:
    May 24, 2011
    Messages:
    2
    Likes Received:
    0
    I think it is to do with the micro usb port. I've been having the same problem and also if I try to listen to music with my headphones plugged in the volume is way up and I cant adjust it even if in sound settings the volume is showing as really low. I've tried all the suggestions on other threads to no avail. The only way I temporarily solved the problem was to mess about with the charger cable in the micro usb port and I got the problem to go away for a bit. The only problem is when I plug in again to recharge the problem came back. Rather frustrating huh!!
     

Share This Page

Loading...