Low MemorySupport


Last Updated:

  1. rebecca757

    rebecca757 New Member

    My wife is having problems is a Motorola Flip Side she keeps on getting a low mem. message. we cleared the cache and deleted apps. I have no clue what to do next. I am a iphone user any help would be appreicated .

    Thanks

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Move here for better response.
  3. rebecca757

    rebecca757 New Member

    where did it get moved to. i think the link is broke
  4. abmoraz

    abmoraz New Member

    I had the same problems. The guys at the AT&T store couldn't fix either. I eventually had to do a factory reset. MotoBlur restored my contacts and i had to restore all of my apps, but now my phone is running fine.
  5. macgiobuin

    macgiobuin Well-Known Member

    I deleted several apps that I never used and re-started the phone...fixed it for me.
  6. laserdoc1

    laserdoc1 New Member

    Hi there...just found this site and ithas ben helpful. I too noticed my flipside after one month is giving me "Device storage full" message. I have deleted all the aps i could and it still is giving me the same reading. Do I have to do a factory restore..?
    The AT&T store was unable to fix the pbm as well.
    If I have to do a facdtory restore what is the procedure?
    I am new to the Android phone but I enjoy the versatility it offers me.

    Any suggestions would be GREATLY appreciated.

    This is my first post.

    abmoraz post above was read and appreciated.

    Thanks in advance. :) Charlie
  7. isionous

    isionous Member

    summary:

    I think it is the /data/local.prop.bak file that grows and grows and eventually fills up the /data partition that causes this problem. Rebooting the phone or doing a 'rm /data/local.prop.bak' is a workaround, but not a solution. It is possible that de-garbaging your /data/local.prop file will solve the /data/local.prop.bak problem. I am seeing if that solves the problem on my phone.

    details:

    I have a Motorola Flipside and I have been getting the "Device storage full" messages about once a day as well. Rebooting the phone seems to make the problem go away for a while.

    Using a terminal emulator, I did a df commands, which showed that my /data partition has lots of free space right after bootup, but has very-little free space once I get the "Device storage full" message. All other partitions seemed fine and RAM usage seemed fine. The problem is the /data partition only.

    Then, to diagnose what is taking up all the space on the /data partition, I used du commands, which showed that the only significant growth in storage used was for the /data/local.prop.bak file.

    I imagined there's a bug such that the phone improperly backs up /data/local.prop in a way that /data/local.prop.bak indefinitely grows.

    I looked at my /data/local.prop file, which seems do have some "ro.sys.*=0" lines, and then I have a lot of binary (non-ASCII) garbage and "=0" thrown in there. My local.prop is about 16.8MB. From my understanding, prop files are only supposed to contain ASCII name=value pairs. I have de-garbaged my /data/local.prop file and I will see how that goes.

    edit1:

    By the way, my de-garbaged /data/local.prop file is now only 288 bytes.

    edit2:

    Looks like /data/local.prop.bak is still growing (maybe slower than before), and as far as I can tell there is just repeated garbage in there. Looks like /data/local.prop.bak is completely useless. I could try to investigate what app or android process is buggily appending to /data/local.prop.bak, but I'm tempted to do a "chmod a-w /data/local.prop.bak; chown 0:0 /data/local.prop.bak" as a quick-fix to prevent any modification of the file.

    edit3:

    In order to mess with /data/local.prop.bak like I have (and also to do storage diagnosis with the 'df' and 'du' commands), you phone will need to be rooted and will probably need busybox (which usually accompanies rooting your phone).

    edit4:

    It's been about a week and making /data/local.prop.bak a zero-size unwritable file has prevented /data/local.prop.bak from growing. I have noticed no ill effects in the operation of my phone. I do wonder that process/app garbaged up my /data/local.prop and what process/app was making those worthless backups.
  8. SDM1977

    SDM1977 Member

    Anyone find a sollution to the Low memory problem. I have 2 of these phones on my accout and both suffer from the problem. A reset and a master reset will help, but only temporarily. I been on the phone with ATT and mortoral and neither seem to have a clue. I am goign to request they replace the phones under warranty, but have my doubts it will solve the problems as it seems to be more of a software issue and not the hardware.
  9. isionous

    isionous Member

    I found a solution to my low memory problem. The steps I describe in my post above solved the problem for me. Have you tried what I did?
  10. SDM1977

    SDM1977 Member

    No, I have not had the time to find a way to root this phone. So I am not able to try your sollution. If it is indeed software related motorola needs to step up and release and update with a fix.

    Back on phone again with ATT yesterday and getting more run around. All the cache clearing and resets do nothing but temporarily clear the memory. For the second time they have failed to call back to see how the phone is doing as promised. Though I am not surprised at that. Lucky for them this must not have been a hot selling phone and unlucky for me as they don't want to spend the time to fix the problem.
  11. macgiobuin

    macgiobuin Well-Known Member

    I took my phone in to the local AT&T store. I had them save all my info, and then re-set the phone to factory settings. They re-loaded my stuff back onto the phone and oila! I have not had the low memory message since. This was a few weeks back.
  12. msidwell

    msidwell New Member

    I need help with this Low Memory Issue as well...I get a "Storage Device Full" error message several times a day and have to reboot my phone which is only a temporary fix! It is very annoying and I wish I knew what to do to fix this problem. Anybody found the solution yet????
  13. isionous

    isionous Member

    Yes. If you look in this thread, I share the steps I took to diagnose and solve my problem. Other people have also mentioned taking their phone to their provider's store and having good results.
  14. Psychv4

    Psychv4 Member

    Alright so as far as the df command goes i got that and I see what youren talking about. Now can you explain what it is you do when you use a du command. when i type in "du" it comes up as "not found"
    at that, my terminal emulator has SuperUser permissions but it still says a lot of what i try to access is denied
    for instance if i type in /data it comes up as access denied.

    All i really need though is a step by step if you can on how to freeze that file
  15. isionous

    isionous Member


    1. Determine if you have BusyBox. Use the command "type busybox". If the output is "busybox is /system/bin/busybox" or something like that, you have BusyBox. If the output is "busybox: not found", you need to install BusyBox. You probably have BusyBox if you have SuperUser capabilities.
    2. Once you have BusyBox installed, use "busybox du" to execute du. You might not need to use du right now.
    3. If you are getting "access denied" messages, you should probably run the "su" command which will cause you to become the superuser. Be careful about what you are doing as superuser. You can mess up your phone.
    4. First, you might want to assume that /data/local.prop and /data/local.prop.bak are the culprits. Do a "busybox ls -lh /data/local.prop*" to see how big /data/local.prop and /data/local.prop.bak are. If they are big (greater than 1024 bytes), they are probably the culprit.
    5. IF /data/local.prop AND /data/local.prop.bak ARE THE CULPRIT, then use some editor (I use "busybox vi", but you might not be familiar with vi) to delete anything that isn't a valid line in /data/local.prop. A valid line should be all ASCII and of the form "SomeName=SomeValue". You should delete /data/local.prop.bak and do a "busybox touch /data/local.prop.bak" and a "busybox chmod ugo-w /data/local.prop.bak" as superuser. The touch and chmod should prevent anyone from writing to /data/local.prop.bak.
    6. IF those files are NOT THE CULPRIT. You'll have to do your own digging with "busybox du". What I did was some du commands with the output redirected to a text file. I did the du right after a reset and a du when storage was getting low and did a comparison.
    I hope this helps some.
    Psychv4 likes this.
  16. Buford

    Buford New Member

    NuB to DROID here .. having these issues .. how do i hack it like isonous specifies??
  17. isionous

    isionous Member

    You'll have to be more specific in what information you require. I feel I've already been very detailed.
  18. macgiobuin

    macgiobuin Well-Known Member

    It is easier to just take it to AT&T, have them save all your stuff, and then have them re-set to factory settings. The store can re-load all your contacts, and Marketplace stores all of your apps in "My Apps"....after re-set, open the Marketplace and go to "My Apps" and download the ones you want re-loaded.

    The downside is that some of your contact info is lost. To alleviate this, put all your contacts on GMail and then sync your phone. When you re-set, all your contacts are at GMail and automatically reload along with your calendar (if synced with GMail).
  19. toxicwaste

    toxicwaste New Member


    I too am a victim of the motorola flipside from att, was given the flipside as "an equal or lesser value phone" to replace my HTC wildfire when Alltel switched to ATT in my area, when i asked why they said it was the default android phone for the switch so i went with it, i had one fail completely within the first week of service, the store replaced it with another flipside after i told them i was unhappy with the phone to include it did not have the android 2.2 os and that the internal memory was so small that it cpuld not even handle half the messages and apps my wildfire had the capacity for, but I am off my soapbox now, I like the phone for its physical keyboard but thats where my like of it ends. when it comes to these smartphones i have had my share of them but i have yet to root one or even have one that is really capable of having a modified os different from the factory installed. i just wanted to figure out how to move file and maybe apps to the sdcard and how to save photos directly to the sd card so i dont have to delete photos or apps just to take more photos or videos. anybody know how to do that with out voiding the warranty? please let me know ok?
  20. macgiobuin

    macgiobuin Well-Known Member

    I finally ditched the Flipside and got the Atrix 2. 8 gigs of internal memory and 32 gigs in a memory card eliminate any worries about low memory. the battery lasts for a lot longer in Atrix 2 than the Flipside ever did. My advice is to switch as soon as you possibly can.
  21. TakashiStormii

    TakashiStormii New Member

    Any chance someone can tell me the exact keying needed for deleting the unwanted files from that directory in the emulator?
  22. franbugs

    franbugs New Member

    What, how and huh! How do I even start to do this. I am computer savvy but this sounds almost like using dos commands on the phone, and I do not even know where to start. Rooting - what is that, how do I do it. It sounds like you have the tech savvy to do what I want, but is it done on my computer with the cable attached to the usb or is this something I do on the phone, and where do I get the resources, and how do I run the commands on the phone?

Share This Page