1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

LT7033E: Cannot get RC29 drivers to install for this tablet


  1. tabosko

    tabosko New Member

    Ive tried every variation of the mentioned install methods and nothing works. Ive tried different computers as well and still nothing. anytime I navigate regardless of the method to the driver folder windows does not recognize anything in it as a suitable driver for the device. Im using the RC29 drivers listed in the posts and running windows 7 32bit. any help is greatly appreciated :)

    Advertisement
    :
  2. SuperNoober

    SuperNoober Well-Known Member

    The Curtis Klu was shipped already rooted beginning with the LT7033D and later. Because your device is already rooted, you do not need to install any drivers onto your computer, and you do not need to use the root toolkit. The fact is you don't need to use your computer at all.

    On your tablet...
    If you haven't already done so, download and install ES File Explorer here...
    es_file_explorer_v1.6.2.4.apk (2.81 MB) (Thanks Mavrikmeercat & Scary Alien)

    Download but DO NOT INSTALL...
    com.android.vending-1.apk

    Then follow the directions given in post #3 of the step by step guide.
    The entire process will be quite painless if you follow the directions.
  3. tabosko

    tabosko New Member

    thats odd cause before I even sought out this subject I tried the process listed here, I would normally used ES or root explorer for this type of stuff...nothing worked nor did any root required apps.

    on a side note I did get the tab rooted using some samsung drivers already installed on my laptop via a force install. the device is now rooted (or possibly re-rooted lol) Ill give the process another try and see what happens.
Loading...

Share This Page