M130 Rooted!


Last Updated:

  1. rasta4rest

    rasta4rest Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    55
    Likes Received:
    16
    I have the same issue here , the wifi error thing because from what i search i suppose the wifi driver load failure .
    If you have the same problem don't recklessly do factory reset!!!
    it can be solved in many ways , if you still got the root access.
    Now i still find a way how it can be solveable in stock ROM without root access.
    Any information would be great , need some geeks to help us found out the solution. Because i think it's a side effect from this root method.
     

    Advertisement
  2. ptimario

    ptimario New Member

    Joined:
    Mar 29, 2012
    Messages:
    4
    Likes Received:
    0
    i fixed my wifi error problem. i replaced my sh file with the same sh file from an unrooted commando, rebooted, and the wifi error went away.

    it was my own fault for not following the directions correctly.
     
  3. NE_Phil

    NE_Phil Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    48
    Likes Received:
    5
    A question for those who have successfully rooted M130:

    I typically have wifi & gps turned off - conserves the battery Do you think keeping them both turned off while rooting will help avoid the Wifi problem others have had?
     
  4. rasta4rest

    rasta4rest Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    55
    Likes Received:
    16
    I guess it's a random cause.
    But if you do exactly the guide says , you won't face the problem.
    Just backup the original unrooted sh files to sdcard, in case same problem might came up you can easily restore it.
     
    el bandido and NE_Phil like this.
  5. ~aRBy~

    ~aRBy~ Well-Known Member

    Joined:
    Oct 18, 2011
    Messages:
    59
    Likes Received:
    2
    with my wife's commando, she almost always has wi-fi turned on. when i fallowed the steps with her phone (wi-fi on) the root would not take. superusr and busybox would not install. i turned wi-fi off and re-fallowed the steps and everything worked fine. now her's is rooted and there is no wi-fi or Bluetooth problems. so i guess what im saying is turn bluetooth and wi-fi off before starting.
     
  6. immanoob

    immanoob New Member

    Joined:
    Dec 14, 2012
    Messages:
    2
    Likes Received:
    15
    When I rooted mine I only had my normal Data/cell-service connection going, and nothing else... No wifi or bluetooth. Now after the root I can turn everything on and off as I please, no catches or anything out of the ordinary. I've even tried a couple wifi hotspot apps, with no luck on the hotspot part only the ad-hoc wifi tethering. And still no catches with anything. So I suppose it works best if you only have your data/cell-service going.
     
  7. elderlypunk

    elderlypunk Well-Known Member

    Joined:
    Dec 12, 2011
    Messages:
    98
    Likes Received:
    6
    I concur with the general consensus which is to follow the op's instructions PRECISELY. You should have no issue if you do. But if you are unsure of how to fix yourself I'd there is an issue, or of your ability to type each command letter for letter, you may want to hold off a bit. This phone is pretty unforgiving if something goes awry. There are MUCH easier phones to try and root on your first go-round, IMHO....
     
  8. rasta4rest

    rasta4rest Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    55
    Likes Received:
    16




    init.qcom.sdio.sh is a script to load wifi driver,you won't successfully root your device when the script's already active.
    The problem comes when the device's already rooted and it's trying to load the original script.
    It then change the sh script permission to -rw-rw-rw which cant be executed (missing the -x or executable permission for all users).
    If im not wrong,the modified script name then become init.qcom.sdio.sh.bak with -rwxrwxrwx permission and this is the working script or you can just change the permission the sh file with root access.
     
  9. csmiles

    csmiles Member

    Joined:
    Dec 10, 2012
    Messages:
    20
    Likes Received:
    0
    when I tried to root I had WiFi and blue off. only noticed the error durring the process. I'm not lazy and not reading all the info, just learning as I go. aka noob. this is probably my doing. however I've tried over10 times and cant get su to push nor WiFi to come on. New phone Monday. and I'm going to root that b****.
     
  10. rasta4rest

    rasta4rest Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    55
    Likes Received:
    16
    First : you should check init.qcom.sdio.sh permission as described above (rwxrwxrwx) so you can add a new line and the system can executed the script properly at system restart/reboot.
    If not match as described above,then im sure your wifi driver wont load because the script permission and you cannot root either.

    Second : check the permission of /system and /system/bin
    They should've drwxrwxrwx,so you can push su binary to /system/bin.

    Last : after reboot if you successfully push the su binary before,you should check /system/bin/su permission and owner.group should be root.root.
     
  11. LimitedRelease

    LimitedRelease Well-Known Member

    Joined:
    Nov 9, 2012
    Messages:
    60
    Likes Received:
    7
    so has anyone else lost the ability to edit to init.qcom.sdio.sh post root?
     
  12. rasta4rest

    rasta4rest Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    55
    Likes Received:
    16
    I think it's impossible to lost ability to edit the .sh file if you still have root access.
    IMHO you can do almost anything to your device with root access,that's include bricking your device lol...
     
  13. brevitas2005

    brevitas2005 Active Member

    Joined:
    Dec 17, 2011
    Messages:
    25
    Likes Received:
    1
    where did you find it? the second step goto ,init.qcom.sdio.sh, I am lost here i read over it again but i must be missing something. The only thing there is group password shadow and gshadow.


    Nevermind. Now I see had to go to favorites then phone.
     
  14. brevitas2005

    brevitas2005 Active Member

    Joined:
    Dec 17, 2011
    Messages:
    25
    Likes Received:
    1
    Thanks finally rooted once more.
     
  15. NE_Phil

    NE_Phil Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    48
    Likes Received:
    5
    Rooting M130 is something I really want to do. I know I'm susceptible to some vulnerabilities and missing some improvements by leaving it at M070.

    Well, last night I decided to take the plunge. I unfroze Innopath and allowed it to update from M070 to M080. Alas, the update fails each and every time.
    The only message I get after the failure is

    UPDATE FAILED OR INCOMPLETE.
    reason: IP_PREVIOUS_UPDATE_FAILED,

    It then tells me to try again. I've tried about 10 times with the exact same result.
    Anybody have any ideas as to how I can get past this?
    Thanks in advace.
     
  16. jova33

    jova33 Well-Known Member

    Joined:
    Oct 19, 2011
    Messages:
    1,566
    Likes Received:
    180
    Call Verizon and tell them.... if you're still under warranty they'll send you a replacement. I had to do this once because inopath kept trying to update and kept failing to the point it went over my data.
     
  17. legoverse

    legoverse New Member

    Joined:
    Dec 16, 2012
    Messages:
    3
    Likes Received:
    0
    ACK! after a bunch of attempts to get busybox working, I finally, CAREFULLY, reviewed my edits of the .sh file. I had a boo boo. :rolleyes:

    After that, all is well. THANK YOU FOR THE ROOT! You :rock:


    One question though... the part about original settings reversion:
    Removing the lines is easy enough, but what is the procedure for returning permissions and owners back to originals?
     
  18. jfever311

    jfever311 Well-Known Member

    Joined:
    Jan 8, 2012
    Messages:
    168
    Likes Received:
    8
    This root method is pretty easy, yet easy to screw up at the same time. One small typo and it will not work.

    Now can someone hurry it up and unlock this freakin bootloader!!
     
  19. Furrner

    Furrner Member

    Joined:
    Feb 28, 2012
    Messages:
    18
    Likes Received:
    10
    Auto correct is a pain, carefully check what you have typed before saving. Chmod became Chloe every time I typed it. :mad:

    Now rooted and very happy with the result. A big thank you to the guys who figured this out.
     
  20. legoverse

    legoverse New Member

    Joined:
    Dec 16, 2012
    Messages:
    3
    Likes Received:
    0
    In another thread, Rafael mentioned that it's a good idea to backup contacts from within the contact app (contacts:export). Good Advice.

    I wish I'd seen that before rooting and tinkering :(
    All my phone contacts are gone, and gone from the verizon.com site as well. Not sure why. My corporate and google contacts are OK though.

    Rationalization time... I really did need to cleanup a lot of old contacts anyway...
     
  21. duckstacker

    duckstacker Member

    Joined:
    Dec 6, 2011
    Messages:
    7
    Likes Received:
    0
    actually easier than I thought it would be
     
  22. duckstacker

    duckstacker Member

    Joined:
    Dec 6, 2011
    Messages:
    7
    Likes Received:
    0
    Thanks so much been waiting a long time....Thank you Thank you Thank you
     
  23. duckstacker

    duckstacker Member

    Joined:
    Dec 6, 2011
    Messages:
    7
    Likes Received:
    0
    Can't quite get the wifi tether to work with the new root on commando , anybody have a solution?
     
  24. colinnc

    colinnc New Member

    Joined:
    Dec 15, 2012
    Messages:
    1
    Likes Received:
    0
    Anyone know what the original permissions are for the two directories (/system & /system/bin)?

    Thanks!
     
  25. tommytopdrive

    tommytopdrive Well-Known Member This Topic's Starter

    Joined:
    Oct 20, 2012
    Messages:
    51
    Likes Received:
    66
    /system - rwxr-xr-x
    /system/bin - rwxr-xr-x
     

Share This Page

Loading...