M130 Rooted!


Last Updated:

  1. tommytopdrive

    tommytopdrive Well-Known Member

    Verizon and casio have locked this thing down quite well, however, just like with all the others, there is usually an app that is preventing unadulterated tether. I was removing apps to see what happens and after doing a free for all on the apps i decided to try the tether and i didnt get the dreaded verizon screen saying i had to conform to their standards. The only problem was i was tweaking with the modem so much that now it wont connect to any cell tower. Had to return to stock and will get another one...without tweaking the modwm this time. Interesting side note - after full wipe and all modem settings to factory i got SIM CARD MISSING. I believe they had this phone made without the sim card slot, but from one of the photos under the " white tape" on the back (posted on phandroid), I thought I saw a place where you could mount the sim slot. The battery would have to be slimmer though....just an observation. I also think the japanese version does have a SIM, and the TYPE-L definately has a SIM...thats the one I am trying to get from Japan.

    Advertisement
    duckstacker likes this.
  2. duckstacker

    duckstacker Member

    wifi tether for root users works on my commando, it connects easily to my wireless pc . but none of my tablets in the house even sees the thing , I was needing it to take to work, thus the tablets . I did read somewhere that because of dhoc or some kind of signal the wifi would only work with pc because of security settings in the signal?? Anyway thanks so much for figuring this out. If I freeze the activecare will this keep it from taking anymore updates?
  3. dodgef25

    dodgef25 Well-Known Member

    Back when I used to be rooted with M80 I used barnacle wifi teather. It worked perfectly. Now days I have the stock verizon Wifi teather free. It works great.

    By the way it was ruled in court that Verizon can't stop you from using 3rd party teathers. I posted a link a while back.

    https://play.google.com/store/apps/details?id=net.szym.barnacle
  4. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    The FCC ruled against verizon that if you don't have unlimited data tethering needs to be included free.

    You are already paying for the data, you can use it how you please
  5. elysian722

    elysian722 New Member

    Setup an account just to thank you, I had recently switched to a Gnex because of lack root on my C771 but I am very active and constantly afraid I will smash it.

    Everything went smooth as butter except for the wifi issue which has already been discussed.
    ie: first time around I did beginning steps with wifi on and couldn't copy SU in. Second time around I shut off wifi before reboot .. and all was good.

    I also encountered an issue with WIFI not turning on at the end of root that was corrected by resetting proper permissions to init.qcom.sdio.sh.

    PS. I did all of this without bothering with ADB. I don't know if there is a reason that you all like ES File so much I much prefer to use File Explorer FX. Especially when editing system files.
  6. lokisource

    lokisource Member

  7. NE_Phil

    NE_Phil Well-Known Member

    Called VZW support and because I can't update to M130 they are sending me a replacement Commando.

    Here's my concern. Superuser is showing in the apps list. Will this be a problem once I return the phone? They made sure that I understood there might be a $300 charge if they determine I added software (like rooting it), it was water damaged or broken, etc.
    It's in very good shape other than my rooting it. I checked under manage applications and I can't uninstall superuser.

    Or is this something they will not follow up on?
  8. duckstacker

    duckstacker Member

    I am fortunately on unlimited data and hope to stay that way, I will try barnacle and let you no Thanks
  9. duckstacker

    duckstacker Member

    same result with barnacle , it will connect to pc , but not to tablets I am really confused.
  10. hacker1969

    hacker1969 New Member

    This is awesome and just way too easy! I had just about given up hope that there would ever be root for this phone, but I wake up this morning, search Google for commando root and lo and behold I am led here.

    Excellent job guys, now I can use the phone the way it was meant to be used without all of the bloat. Off to try to install linux on it now!

    Edit: Just installed Backtrack and while slow due to 800mhz proc and lack of ram, it is working flawlessly even with the gnome gui loaded. Best to stay in cli mode though, it's not as painfull.
    Again, thanks to all who helped to make this happen, now I have a rugged pentesting (albeit no wireless testing due to not being able to place card in monitor mode) device!
  11. duckstacker

    duckstacker Member

    The paid wifi hotspot feature from Verizon creates a full fledged wifi infrustructure mode hotspot. The wifi tethering application for the rooted Commando only creates an ad-hoc wifi connection. The problem with android tablets is they do not support ad-hoc wifi networking stock and you will need to root the tablet to be able to make the changes needed to enable ad-hoc networking. quoted from this page Casio G Zone Commando problem - Mobile Hot Spot [Archive] - Android Apps - Android Market
  12. jova33

    jova33 Well-Known Member

    You have to root your device, remove the superuser stuff, and then bring it back to stock
  13. jova33

    jova33 Well-Known Member

    That ROM isn't for the Casio Commando lol. That's the Casio Commando ROM ported to another device.
    No one has made a ROM for the Commando. Something with the radios if I remember correctly.
  14. lokisource

    lokisource Member

    Yes after diving in the deep end and not playing in the kiddy pool enough
    i realized it but after i "lost" my phone and got a replacement i am back in this game.
  15. lokisource

    lokisource Member

    had to "mount file system" under root settings in ES Explorer to gain rwx again to clear original changes
  16. Willster419

    Willster419 The Casio Smartphone Guru Guide

    a lot of people set up accounts to do the same thing, like i did a while back. :) I had the wifi problem too, but alraedy has been discussed. (and second on this fourm to be rooted if u count tommytopdrive) also we chose es file explorer because it worked when i tried it. you can use what you want, but it was known good, ya'know?
    cheers
  17. elderlypunk

    elderlypunk Well-Known Member

  18. jova33

    jova33 Well-Known Member

    Or terminal emulator - very useful tool if you know how to use it
  19. elderlypunk

    elderlypunk Well-Known Member

    Yep, that's how I did this whole process. I was at work with no pc access, so no adb. I actually prefer working right on the phone, so it worked out fine by me...
  20. tommytopdrive

    tommytopdrive Well-Known Member

    Anyone have the http address for the m130 update? I remember somewhere in this forum you can check on your phone after rooted for the address, but all my stuff shows up empty. I am interested in the radio.diff file. The file should be a ".dat" file. This bootloader is a pain.
  21. shue

    shue New Member

    another noob here.

    i can't get the su file to move over from the sd card to the phone. i assume it is because my init file is not showing rwxrwxrwx it is showing -rw. i leave the wifi off all the time, so i turned it on and back off with no luck. what am i doing wrong?
  22. JKH62

    JKH62 Well-Known Member

    Great work discovering the exploit. It's what I have been wanting since I got the commando in the 1st place. Hopefully I will get some time to try it on mine tomorrow.
  23. lokisource

    lokisource Member

    Are speaking of...? CASIO G'zOne COMMANDO
  24. JKH62

    JKH62 Well-Known Member

    A picture is worth 1000 words........

    I am totally smiling like a ****** with gas right now. It was a little funky and the 3rd time was a charm. I had issues copying SU and permissions but got it.

    Follow the instructions to the letter on the 1st page and it works.

    [​IMG]
  25. cubannotquban

    cubannotquban New Member

    Hi could somone please ol please help lol. I have done and completed all these steps nermerous times but still no root. :^

Share This Page