Magic Bad ROM recovery problem!


Last Updated:

  1. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    so i got stuck in a loop today.. doing the HoFo Rom 1.1.1 update and im having trouble using my nandroid back up files.

    I took the boot/system/data from nandroid and put it in the tools folder of the SDK

    in the cmd i type: fastboot flash boot boot.img and i get

    Sending boot... OK
    writing boot....
    FAILED remote: signature verify fail

    i am connected since i get a serial back when i put fastboot devices
    tried taking out the SD card and reinserting
    tried it with a different computer and still failing

    any help would be appreciated. Thanks!

    Misc Info: 32A/2005 SPL
     

    Advertisement
  2. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    boot into recovery mode (hold power + home) and then do a data wipe, and try backing up the nandroid backup again
     
  3. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    are u saying to data wipe then use the nandroid files to recover?
     
  4. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    ya it might work.

    I learned that you just gotta play around with these things to get them to work
     
  5. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    i just get a pic of a phone and a !... nothing on the screen
    nvm i figured it out...
    i will try and wipe and update
     
  6. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    still the same... failed....
    any other ideas?
     
  7. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    Hmm very interesting.

    Are you flashing in correct order?

    Fastboot flash boot boot.img
    fastboot flash system system.img
    fastboot flash userdata data.img
     
  8. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    yes sir, i can't even get past the boot.img
    it fails right there
     
  9. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    so you are in fastboot (power + back)?

    well, flash the ROM you were using before, then try to restore again.
     
  10. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    yeah im in fastboot USB when i do the fastboot boot boot.img

    i will try that
     
  11. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    queston..
    why can't i just nandroid v2.2 restore??? or is it not designed like that?
     
  12. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    Well as far as I know there is no restore option (at least not for me)
     
  13. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    i tried what you said and it didn't work..
    wait you tellibng me when you are in fastboot, there is nandroid v2.2 restore option
     
  14. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    there is no option like that in Recovery mode

    Skip the boot, flash the system and data.

    Honestly it seems as if the backup has been corrupted or something
     
  15. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    what happens if i do skip the boot?.. om sorry, im just scared
     
  16. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    nothing will happen.

    As far as I know boot is responsible mostly for well.. booting. And since you already have the correct boot since you flashed the same ROM you are trying to backup, you can skip this step.
     
  17. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    im still kinda scared.... does the boot have to be according to the rom??
     
  18. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    Do not be scared, I have done this myself!

    Just flash to the ROM that is the same as the backup.
     
  19. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    so just skip the boot? and flash the system?
     
  20. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    Pretty much. Yiu won't screw it up any further
     
  21. XxXSnake23XxX

    XxXSnake23XxX Active Member This Topic's Starter

    Joined:
    Aug 16, 2009
    Messages:
    27
    Likes Received:
    0
    thanks for ALL your help i got it working now!:D
     
  22. UnderWhat?

    UnderWhat? Well-Known Member

    Joined:
    Aug 5, 2009
    Messages:
    180
    Likes Received:
    34
    No probem, enjoy
     

Share This Page

Loading...