Magic with E911 Update: No Observing (Atlantic) Daylights Savings Time


Last Updated:

  1. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    I noticed today that my Magic with the E911 update is not observing daylights savings time. I'm located in New Brunswick, DST: GMT-03:00 Atlantic Daylight Savings Time is the time zone that I need, but the Magic does not have it. I spoke with Tech support who said to choose any GMT-03:00 time, then my cordless died. So, I called back. While waiting on hold, I choose a random GMT-03:00 West Greenland Time, and checked off Automatic which worked for only a few short seconds, once the handset realized that I was trying to trick it! The handset then tries to choose the correct setting: GMT-03:00 Atlantic Daylight Savings Time and fails, so it auto defaults to: GMT-04:00 Atlantic Standard Time.

    Now, I know I can manually choose set the time, but the thing is when I manually set the time the clock on the handset works, of course. But the time stamps in Gmail on my handset are incorrect, it takes an hour off the manually set time.

    Anyone else in Atlantic Canada having issues?
     

    Advertisement
  2. GreatBigDog

    GreatBigDog Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    495
    Likes Received:
    46
    I'm on PEI and I'm having no issues. Did you restart your phone to re-sync the time with rogers servers.
     
  3. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    Thanks for the reply. I've tried that many times...just tried it again and for a second it looked like it worked, until it reverted back to the wrong time. Can you check what time zone yours is on? Are you on GMT-03:00 Atlantic Daylight Savings Time? I found a post on HF that a few people mentioned having issues too..
     
  4. GreatBigDog

    GreatBigDog Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    495
    Likes Received:
    46
    Mine is set to automatic and is showing GMT-03:00 Atlantic Daylight Savings.
     
  5. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    When I set mine to GMT-04:00 Atlantic Standard Time and then select automatic it attempts to set GMT-03:00 Atlantic Daylight Savings and then after a few seconds, it goes back to GMT-04:00 Atlantic Standard Time.
     
  6. GreatBigDog

    GreatBigDog Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    495
    Likes Received:
    46
    If you call tech support they are going to tell you to do a wipe on the phone. So why not go ahead and do it. If it still won't set properly, call tech support and report the problem. If you have already performed the wipe and it still doesn't work you can get them do perform a warranty replacement on the phone. Since the Magic+ is just released you will receive a brand new phone from Rogers.

    gbd
     
  7. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    I did call Tech Support, on Tuesday or Wednesday. They were to call me back with in 48 hours...it's now Saturday. Not that I expected a call back since it's been the current trend, I tried wiping the phone and it didn't work for me...Awesome.
     
  8. GreatBigDog

    GreatBigDog Well-Known Member

    Joined:
    Dec 3, 2009
    Messages:
    495
    Likes Received:
    46
    So call tech support back and insist that if they can't solve your problem that you want them to send you a replacement phone. I had a problem with my magic after the update in that the Sense UI would sometimes freeze and then reload, not the entire phone, just the UI. Wipe didn't help me so Rogers sent me a Magic+, haven't had the problem with new phone.

    gbd
     
  9. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    I'm going to call tomorrow, I've decided that I won't waste my time on the weekends dealing with the Rogers fiscal. It'll be 2 months in a few days since everything started to go down hill.
     
  10. zortoflaven

    zortoflaven Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    58
    Likes Received:
    1
    I set my Magic back to auto time and it is showing up correctly now. It wasn't before and I just manually set it an hour ahead. I am in Halifax, FYI.
     
  11. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    Thanks! That worked great!...until sometime between 11pm - 4:05am when the phone decided reject the settings and automatically set it back to the wrong time. Causing my alarm not to go off at 4:05am because it was an hour behind.

    I'll be calling Rogers after I leave the office today for sure. In fact, I still haven't gotten that phone call that was to come 48 hours after I spoke to someone last week not that I truly expected it.
     
  12. woodlawn

    woodlawn Member

    Joined:
    Jan 11, 2010
    Messages:
    18
    Likes Received:
    0
    Mine switched all by itself, I had no issues.
     
  13. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    Rogers sent me a Magic+, which does not observe daylight savings time either.
     
  14. Otis2003

    Otis2003 New Member

    Joined:
    Apr 17, 2010
    Messages:
    1
    Likes Received:
    0
    I am having the same issue. Tech support was a complete waste of time. I'd like to know if anyone has done a hard reset on this phone to correct this issue. I really do not want to hard reset my phone and wipe out paid apps unless I know for certain it will fix this.

    I have a sneaking suspicion that this is an Android bug.
     
  15. zortoflaven

    zortoflaven Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    58
    Likes Received:
    1
    I always thought that auto time was a tower function. Your phone polls the tower for the time or something.

    Mine was wrong, but after a day or two it sorted out (and honestly it's been like that for a while with all sorts of phones). I wouldn't call it an Android issue just yet, especially since many of us had no issues.
     
  16. Recc113

    Recc113 Member

    Joined:
    Mar 8, 2010
    Messages:
    24
    Likes Received:
    0
    I've got a friend running a dream w/ the 911 update and her time didn't adjust with daylight savings either, so I turned off auto and set the time by hand and it seems to have worked
     
  17. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    I bet her time stamps for her Gmail are off.
     
  18. Jedstah

    Jedstah Member This Topic's Starter

    Joined:
    Jan 20, 2010
    Messages:
    14
    Likes Received:
    0
    Still waiting...
     

Share This Page

Loading...