main clock wont stay current


  1. UTnick

    UTnick Well-Known Member

    My main clock won't refresh after the phone turns on or comes back on from airplane mode. The widget clock is working just fine, though. Anyone else seeing this and or know how to fix it?

    Advertisement
    :
  2. bretwalters13

    bretwalters13 Member

    im having the same problem. it just started tonite
  3. philip0871

    philip0871 Member

    Both my main clock and my widget clock fell behind an hour tonight. Date and time settings are set to automatic so I know I didnt accidentally change something. I have been using my phone heavily for the past 5 minutes and the clock has yet to correct itself.
  4. UTnick

    UTnick Well-Known Member

    Haha. Our US Sprint phones think we are part of the European Union. HTC forgot to set our daylight savings time correctly and our phones are changing on October 25th like they do in Europe.
  5. ToxicToastKatz

    ToxicToastKatz Well-Known Member


    *shakes head in disbelief*

    I'm not too nitpicky about certain stuff. I understand things will be missed or overlooked on occasion, but seriously? Something as simple as this? To have the clock not function properly on a smartphone is pretty bad.
  6. t1jordan

    t1jordan Well-Known Member

    When you change the clock. make sure to uncheck the "city label" it will post the correct time.
  7. t1jordan

    t1jordan Well-Known Member

    I dont mean any harm but, sometimes i dont know where you people get this stuff from. My clock time is correct and has been. if you uncheck the city label. the time will be correct in your area.
  8. LTZguy

    LTZguy Well-Known Member

    I guess we are just making it up. I brought my original hero back yesterday and got a replacement. My other one would never sleep. This one sleeps but the time is wrong. the time was correct on my original one. and just because you are not having a problem doesnt mean the problem doesnt exist. So please keep your ignorant comments to yourself. The original poster wasnt asking for a comment like :"i dont know where you people get this stuff from. My clock time is correct and has been."...obviously he's having a problem...and so am i. I hope you do to so you can eat your words. :)
  9. t1jordan

    t1jordan Well-Known Member

    Im not saying that he made it up. Take your time and read the threads. we have already discussed this information. I can make any comment that I want. And let the man speak for himself. you dont have to come to his rescue. The clock on here is a issue, but if you do what we say you want have a problem. The clock issue is all around the bored. And why would you want me to have phone problems. You sound like a hater!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
  10. UTnick

    UTnick Well-Known Member

    alright, fellas. if you don't believe me -- fine. here is what happened. starting around 1:00 am central time my phone clocks weren't agreeing. the widget clock was fine, but the clock on the status bar was freezing on the time the phone was turned on at, or switched from airplane mode. anyway, once 2:00 am hit (to be specific october 25th at 2:00 am) my status bar clock switched to 1:00 am again and the widget clock showed the correct time. my girlfriend's instinct showed the correct time.

    now i am assuming the only reason the phone would drop an hour for any reason at 2:00 am in the morning is because of daylight savings time. here in the states that isn't set to happen until november 1st, however, in the EU that was set for October 25th at 2:00 am. yes, my clock is set to automatically sync with the network, but the reason i think it was the phone is the time on the status bar sticking and the widget working -- my girlfriend's sprint phone didn't have a problem at all -- and all this coincides perfectly with the EU's daylight savings standard.

    now, if you think i am full of crap or ******** that is fine. it is still my contention that this was a software bug.
  11. LTZguy

    LTZguy Well-Known Member

    OMG! yes i'm a hater! You figured me out...my feelings are so hurt!
  12. mustang5o

    mustang5o Well-Known Member

    My Hero did the same thing and caused me to be late to work this morning. Where is this "city label" thing you are talking about? This places one more check in the column to return the phone and wait for bugs to get worked out.
  13. inline325i

    inline325i Member

    I know it sounds crazy but i had the exact same thing happen to me this morning.... The clock widget was correct was 6:30 am..... main time on phone had 5:30 am .... I literally took a double take and was like WTF....???? Checked the settings to see what was set...it was set to automatic.... I went in and manually changed to "Central" time....then changed back to "auto" still went back to 1 hour off.....

    Restarted the phone and dunno but it came up correct, widget and main time was correct...... I dunno what the deal was but........ i can confirm i had the same issues others here described....
  14. Bernal

    Bernal Well-Known Member

    If the time is wrong on your phone try this, it worked for me.

    Update your phone PRL and Profile. To do so, from the home screen click menu-->settings-->about phone-->system updates and then click Update PRL and wait for it to update if it needs to. Mine updated from 60654 to 60655 (you can see the PRL number on the Status page which is just below the System Updates menu option. After that I did the Update Profile. Once that finished, the status bar clock immediately showed the correct time.

    When I went back to the home screen, I noticed that the clock widget was still showing the old time. Perhaps I could have waiting and it may have updated at some point, but I simply removed it from the screen and then re-added it at which point it showed the correct time.

    Good luck...
  15. romeosidvicious

    romeosidvicious Well-Known Member

    Mine displayed the wrong time in the status bar last night and the right time in the time widget but it was 0300 and I decided to deal with it this morning. I got up this morning and lo and behold both clocks agreed and were right. No idea what caused the original issue but it fixed itself.
  16. mamiamjo

    mamiamjo Well-Known Member

    Mine was wrong this morning as well.
    I figured that they had the DST figured incorrectly or something. It was showing as current city (houston) and showing one time, but then in the city list under Houston it was showing an hour later (which was correct). I unchecked "current city" and clicked on Houston. The clock was then showing the correct time, but the task bar clock was still showing an hour behind. I ended up re-booting and the time has been correct since.
  17. philip0871

    philip0871 Member

    Obviously there is something wrong with the phone or network. I shouldnt have to modify the settings to make the clock respond correctly, especially when it was working fine up until last night.
  18. mustang5o

    mustang5o Well-Known Member

    I put mine back to auto with network and it's working so far. Although I have removed any clock widgets from my home screen. Still not sure what is meant by unchecking the city label. Where is this done?
  19. hake0305

    hake0305 Well-Known Member

    I refreshed my PRL updates, removed the clock widget then readded it. It still it one hour ahead. I too believe it is off due to day light savings because mine jumped an hour forward Sunday morning when I looked at it. But what doesn't make sense is shouldn't it jump back an hour? (Spring forward, Fall behind)

    I went to settings and manually changed the clock to not auto update and that worked until today. Auto update is still unchecked, so the small clock in the upper right hand corner is correct (what I set it to) but the widget is an hour ahead. My city is correct, Minneapolis (Central time).

    Any help would be appreciated... Is there somewhere we can report this to Sprint?
  20. ToxicToastKatz

    ToxicToastKatz Well-Known Member


    It's not a "Sprint" error. It's an HTC software bug. They are aware of it and will have it fixed in the OS update. No release date for the update, but it seems like it shouldn't be too long based on my conversation with an HTC rep. They have identified a lot of software bugs (99.99999% of which are all being discussed in these forums) and are aware of the urgency to repair them. They are currently working with Sprint Engineer's (based on my phone call) to fix all of them. Since there are quite a few, several hot-fixes would be necessary. Instead of doing that, they are going to roll them all out with the update. Because they plan to do it that way, I'm guessing they are pretty close to a release, otherwise there is going to be a lot more phone calls pouring into them.
  21. hake0305

    hake0305 Well-Known Member

    Thank you for the quick update!!!
  22. UTnick

    UTnick Well-Known Member

    thank you for proving me not crazy.
  23. itsaddison

    itsaddison Active Member

    For what it's worth, mine corrected itself today.
  24. qsoundrich

    qsoundrich Member

    I've figured out what is causing this bug, but I don't know how to fix it on my Eris. I live in Erie, Colorado, which is also near Lafayette, CO. I noticed that after rebooting my phone it switched to Lafayette. Now normally the big clock is on eastern time, and the little clock is showing the correct time (Mountain.) When it went to Lafayette, it went to Central time. Now there's a big Erie, PA in Eastern time and a couple of Lafayettes in Central time (LA being the biggest.)

    The HTC developers JUST looked at the name of the city and matched it to their very small database. They didn't bother looking at the state as well! So rather than getting paired up with Denver, I'm stuck with whatever time it is in Pennsylvania. They really should be getting time information directly from the towers or geolocation, rather than trying to figure it out internally in the phone. Perhaps they were trying to save space in the memory, but this is really cheesy.

    The fix is to go in and turn off automatic settings and set it to your current time zone. This bug could cause some serious problems for people who go to a wrongly-named city and expecting to be woken in the morning by their alarm!
Loading...

Share This Page