1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

"Main version is older"-Hboot 0.93.0001 -How to beat it ?


  1. pawel_kd

    pawel_kd Member

    It is an brand Desire, I rooted, I loaded custom rom (worked fine), but the ROM manager screwed up something. I guess, it reflashed the bootloader (or recovery?), but failed. :(
    Now the desire cannot boot. It stucked at the screen, with logo afer reset and freez.
    The bootloader says :

    BRAVO PVT3 SHIP S-ON
    HBOOT-0.93.0001
    MICROP-051d
    TOUCH PANEL-SYNW0101
    RADIO-5.10.05.23

    If I try to go to RECOVERY the screen goes white, and nothing happens.

    If I put the PB99IMG.zip to SD card, the HBOOT finds it, but says, "Main version is older"

    Is any way to reFlash the rom ? :confused:

    What to do ? :confused:

    Advertisement
  2. teppic74

    teppic74 Well-Known Member

    Use an RUU with equal or higher release number compared to what you originally had, or try the PB99IMG.zip file from the 'alternative froyo installation' thread in the main forum.
  3. Rastaman-FB

    Rastaman-FB Well-Known Member

    btw rom manager does not reflash the bootloader or recovery.
    it puts a fake recovery in a clockworkmod folder on sdcard and uses root to make a adb reboot to the clockworkmod zip rather than full recovery

    if you take the sdcard out can you get to recovery?
    how did you root the device?
  4. pawel_kd

    pawel_kd Member

    No, it`s impossible - Recovery gives me operator logo, after 5 sec black bar at the top of screen and telephone down (not not really off - computer sees it as a android device).

    I used unrevoked method - but after reset the telephone remained dead. I took out battery and SD - It helped.

    I wanted to fix it.

    With RomManager -> Flash ClockworkMod Recovery -> Reboot into Recovery

    Since then Desire cannot boot.
    For 30 sec I have a logo then reset logo 5 sec and freez, like I wrote above.
  5. SUroot

    SUroot Well-Known Member

    If you can't get into recovery via ill down plus power then recovery, sound like ruu is the only way you can go
  6. pawel_kd

    pawel_kd Member

    But how ? RUU gives me <error 170> :confused: I think loaded system is needed. :(
  7. SUroot

    SUroot Well-Known Member

    See teppic74's earlier reply.
  8. Rastaman-FB

    Rastaman-FB Well-Known Member

    sounds like recovery did not successfully flash from unrevoked.
    if you manage to get to the red triangle when the sdcard is out then i think the sdcard is causing a problem with loading recovery

    try this. take the sdcard out and put it in a card reader
    (copy the contents off the card to a computer)
    format the card as fat32
    on the computer go to the <backup folder you made>/clockworkmod/download/koush.tandtgaming.com/recoveries/ copy recover-clockwork-2.5.0.7-bravo.zip
    paste it to the root of the card, rename it to update.zip (delete update.zip if you already have it there
    place the card back into the device and boot to recovery
    if it doesnt autoload the hold volup+ power when in recovery, there maybe an option for apply update.zip.
    this may get you into the fake flash recovery where you can then try applying a custom rom like teppics.
    once done then try using unrevoked again to flash a recovery
  9. teppic74

    teppic74 Well-Known Member

    That's not going to work - if recovery is broken there's nothing you can do but flash an RUU. You definitely can't reflash recovery unless you re-run unrevoked3 (or use S-OFF) because of the hardware lock; stock recovery will not run fake flash under any circumstances.
  10. SUroot

    SUroot Well-Known Member

    Indeed, that only works on the engineering recovery we talked about the other week
  11. Rastaman-FB

    Rastaman-FB Well-Known Member

    well he cant do either as he cannot boot to main rom which both require.

    i thought if the device was rooted you might be able to use update.zip even if you didnt have engineering

    i havent seen a standard recovery menu as i modified mine pretty quickly

    ahh well


    EDIT: Teppic, how did you make that pb99img.zip?
    if he has a goldcard is it possible for the latest possible version to be converted into a pb99img.zip and then flashed?
  12. teppic74

    teppic74 Well-Known Member

    A rooted phone won't change recovery (you don't need to be rooted for custom recovery, and custom recovery won't provide root).

    The latest unbranded RUU is available as a PB99IMG.zip file as described. So if the phone was unbranded, no goldcard will be necessary to fix it. This method doesn't require a working recovery or working ROM.
  13. pawel_kd

    pawel_kd Member

    I also suppose that unrevoked is responsible for my problem.

    But Desire does not want to fully load system even without SDcard.

    I tried - exactly as you wrote - No change :confused:
    With pb99img.zip I get error: "Main version is older" - That's the point

    My Desire is brand-one. What can I do ?

    Now, I launched successfully RUU :) under USB_Fastboot ! :)

    But I tried a number of stock images-roms (with GoldCard - my phone is brand one) and each time I get error:

    140:BOOTLOADER VERSION ERROR - on Desire screen : "Main Version is older" :confused:

    My rom version: 2.15.118.1

    What else can be done ???
  14. teppic74

    teppic74 Well-Known Member

  15. pawel_kd

    pawel_kd Member

    Yep, goldcard present - but sitll "Main version is older"

    Yep - but Downgrade requires system - I have only access to Hboot .
  16. teppic74

    teppic74 Well-Known Member

    You have a bit of a problem then. You could try a branded update with a higher release number (e.g. Three's froyo), and then downgrade that.
  17. Rastaman-FB

    Rastaman-FB Well-Known Member

    could i ask what would happen if you renamed the fake clockwork update.zip to PB99IMG.zip

    ive not tried it but wondered if it could some how initiate recovery

    im not trying to confuse matters, im just interested if anyone has tried it
  18. teppic74

    teppic74 Well-Known Member

    It wouldn't work.

    The PB99IMG.zip method flashes the phone, it doesn't use recovery at all (and so works when recovery is broken).
  19. Rastaman-FB

    Rastaman-FB Well-Known Member

    ahh ok
  20. pawel_kd

    pawel_kd Member

    I made a little progress :) - I have access to recovery, at the beginning is:

    E:/Can`t open /cache/recovery/command


    Can I do something now and maybe and solve my problem? :confused:
  21. SUroot

    SUroot Well-Known Member

    What if you press vol up at that point? I get that error whenever I manually not into recovery although o rooted with an ancient method and have a different recovery mo doubt
  22. pawel_kd

    pawel_kd Member

    When I try in recovery to manually flash via update.zip :

    E:error in /sdcard/update.zip
    (status 7)
    Installation aborted

    >:confused: ?
  23. Rastaman-FB

    Rastaman-FB Well-Known Member

    what is this update.zip?
    a recovery or a rom?
  24. pawel_kd

    pawel_kd Member

    I tried both - always : an error


    So, I give up :mad:

    I`m sending the phone to an authorized service.

    We'll see - warranty success or not :confused: (

    Thanx 2ever1 for time :) and help :)

Share This Page