Major Flaw with Pattern Lock or How to Brick your Droid


  1. vincentp

    vincentp Well-Known Member

    I don't use the lock pattern, but I have to ask the original poster anyway. When you were trying "username@XXXX.com", did you ever just try "username"? The only reason I ask is because on any Google page, you log in using the user name only, not your e-mail address.
  2. dave412_4

    dave412_4 Well-Known Member

    i think your right for the life of me i cant remember when i had to do it.
  3. minyangmao

    minyangmao Well-Known Member

    "username", "username@gmail.com", and "username@googlemail.com" all do not work if you are unfortunate enough to have a Droid that carries this particular bug. the issue does not appear to be a wrong entry, as the phone does not attempt to connect to the network when "checking" the correctness of the entry. Question for those for whom this is NOT an issue - does your droid seem to contact the network when you enter the username and password, or does it seem to pull it out of some in-phone hidey hole?
  4. gotwillk

    gotwillk Well-Known Member

    i remember this happening to me once too BUT it did not brick my phone. my coworker was playing with my phone and he tried to guess my pw too many times. got that screen to enter your gmail/google info or whatever. i entered in my gmail acct associated with the phone. didnt work. tried again. didnt work. and then, i forgot what i did, but i think i just hit "cancel" or the back button and backed out of that screen somehow, and got back to the unlock screen, entered my pw, and it unlocked.
  5. Droidood

    Droidood Well-Known Member

    This is why I use Astro to hide all the personal pictures stored on my phone and never turn on the lock pattern :p
  6. punkzanyj

    punkzanyj Well-Known Member

    Wow, that's really lenient. You forget your PIN at the ATM and you get like 3 tries before you're locked out and have to call customer service.

    Yes the username password thing is a problem, but you gotta admit, it takes a hell of a lot of work to get there.

    Here's a tip: Use a pattern that makes sense to you. With the dot configuration you can make several letters and numbers, such as J, C, h, L, u, N, T, X, S, 4, 2, z, y, M, W, G and V. I was using a checkmark gesture for awhile.

    And as to the "I don't have anything to hide" person? You'd be surprised what can be done with your phone in just a few minutes. My partner didn't lock his phone, and left it on the bus. He realized the second he got off the bus that he lost his phone. Within minutes a group of kids found his phone, went through his call logs and text messages and started sending f*cked up messages to me and to his sister. They said they had killed him, that they had beaten him up, that they were still beating him up. His phone didn't have internet access or gmail access -- imagine what someone could do with just 5 minutes and access to everything on your phone. If they have access to your work email, they could get you fired. If they have access to other important information they could get you sued, you could loose clients, friends, potential dates. A little digging could turn up that your friend who just got a ps3 is on vacation and here's his address, now your unlocked phone has compromised someone else's safety.

    It's not about what you have to hide, it's about what someone can do to your life in the time it takes you to realize your phone is missing and try to recover it or have it shut off.
  7. steeguin

    steeguin New Member

    I had the same problem, I think i may have found the solution.

    I was able to unlock it with the last account that I had added to gmail. So in other words not my primary account.

    It would be interesting know if this works for someone else.

    chris
  8. dougwilson2000

    dougwilson2000 Well-Known Member

    That is kinda interesting. I have 3 gmail accounts sync'd to my phone. Which account would unlock my phone? How would I find out in advance?
  9. steeguin

    steeguin New Member

    For me it was the last account that I added to android. When I setup my phone I added my primary account first and my secondary accounts next. The one that unlocks the phone is the last account that I entered.

    Example

    If you added the accounts in this order to droid:

    1@gmail.com
    2@gmail.com
    3@gmail.com

    You would have to unlock droid with 3@gmail.com

    chris
  10. tsaunders

    tsaunders Well-Known Member

    I only have one account and can't unlock the phone. After I saw this issue I turned off the pattern lock.
  11. ivanpk

    ivanpk Active Member

    I can attest that this is true. I set the pattern lock, and was seeing what happens if you do not enter it correctly. It locked me out for 30 seconds, and gives you a link to enter your google account info to reset the passcode. I entered my information and it did not work. After the 30 seconds, I entered the correct password and turned off passcode lock. I will not be using it until this is fixed!
  12. Maxxy

    Maxxy Well-Known Member

    I just found a solution for this issue in this thread. Look at the posts 128-129. It worked perfectly for my Magic.
  13. SinfulDragon

    SinfulDragon Well-Known Member

    REP to you good sir!!!!
    I haven't had a pattern lock for some time and just turned it on, no idea what it was apparently because I went through all 20 tries with no success, was about to call VZW but then decided what the hell, why not try my other google account even though its not the primary and presto, unlocked and let me set a new code, not that I'll need it, I'm never turning that shit on again LOL!!!
  14. derjur

    derjur New Member

    I found a solution that works for me. Thought I'd share here.

    If it's not accepting your password for your email account, try entering "null" (literally type it out) as the password.

    I couldn't believe it.
  15. Psychokitty

    Psychokitty Well-Known Member

    I never use the pattern lock, but I have to say that if this is true, it's far worse a security issue than people being locked out of their phones. A lock is used for a reason. Yeah, you should be able to get in, but others should NEVER be able to, even if you need to break out the bolt cutters in the end.
  16. QuasiNerd

    QuasiNerd Well-Known Member

    I have a Moto Droid that is completely locked up. None of the fixes so far work. In fact, there was never a lock pattern set up on the phone, so I'm not sure if somehow got "pocket" set???
    Is anyone still having issues with this?

    Please help. I do not want to do a factory reset.
  17. brettlewis

    brettlewis Well-Known Member

    did you try not typing in the @gmail.com

    that worked for me the one time I did this.
  18. QuasiNerd

    QuasiNerd Well-Known Member

    I have tried all of the fixes I can find on many different sites.

    -leaving off @gmail.com
    -trying xxxxxx@google.mail.com
    -resetting gmail password online
    -using old passwords
    -typing in the word "null" as the password
    -having someone else call and hitting the back button after answering
    -repeatedly opening and closing phone while hitting any multitude of buttons (there are a bunch of theories on this one)
    -flipping off the computer screen with BOTH hands

    Nothing. I think I'm going to have to try a factory reset. I just can't believe that this is a known bug that has been around for 8 months plus and it is still happening to people.

    It blows goats, I tell you.
  19. QuasiNerd

    QuasiNerd Well-Known Member

    OK... so I don't know if this worked for me by some sort of Droid magic, but I'll post it in case it helps someone else.

    -Turn off phone
    -Power up into recovery
    -Wipe cache partition
    -Reboot

    When the phone came back up, it still showed the lock screen, but this time it took the first thing I put in. I'm glad I happened to remember what I put in, because the phone will ask you for the old pattern in order to disable the lock pattern in Settings.

    After that I realized that nothing was syncing to Google, which may have been caused by other attempts to unlock the phone (i.e. - password changes). I had to re-enter the Google account information and new password, then sync everything. So far so good. I just wish there was a way to permanently get rid of the pattern lock option.

    At least I didn't have to do a factory reset :D
  20. Titaniac

    Titaniac Well-Known Member

    QuasiNerd likes this.
  21. T-800

    T-800 New Member

    NICE! This got me out of my jam with my Behold II Android 1.6.

    -Mike
  22. shepetelis

    shepetelis New Member

    helped me too [HERO] !! thanks!
  23. droiderest

    droiderest New Member

    Hi all,

    I don't consider myself better or smarter than anyone on here, but I just find it unbelievable to think you could forget your unlock pattern and/or be so worried about forgetting it that you don't use one at all. I mean, some many not prefer to have one, but to not have it just because you are afraid of forgetting it is kind of sad. I mean, how do you remember your voicemail password (if required), ATM pin, SSN, etc if you can't remember a simple 4-5 dot pattern? Again, not calling any one person out on this thread (God knows I've made my own share of dumb mistakes), but I just don't understand how this can be an issue. And even if you do forget it momentarily, 19 attempts sound like more than enough to refresh your memory.

    I'd also spend 30 minutes poking fun at the nimrod who couldn't understand why phone security might be worth having, but I'm watching House right now and don't feel like making my fingers tired over someone who probably can't read well anyway.
  24. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    It's not a matter of not remembering it, but sometimes background process (think sync) will make the interface completely slow to respond.

    Last week I was trying to enter my pattern, and I swiped it as normal - and it entered 3 incorrect swipes successively, as it entered the first 2 dots then gave me an error about being the wrong pattern, skipped the 3rd dot and entered the 4-6th dots, same error, then entered the last dot and again gave me the error message. I turned off the screen and waited a couple of minutes and tried again and it took all 7 dots the first time. I've been using the same swipe pattern since I enabled it way back when when it was first available to me, so I know I didn't forget it - bu as you can see, the phone was simply not able to respond fast enough to my super-fast swiping, and I almost had locked my phone.
Loading...

Share This Page