Major input delay 4.4.2Support


  1. coogsig

    coogsig New Member

    Hello,

    I recently switched from iPhone to Android and got a Moto X. I've noticed I'm getting some major input lag. The weirdest thing though, is that it only happens in some instances. Some examples of discrepancies:

    • The calculator is very laggy, while the keyboard is snappy.

    • I had a pin-unlock and there was terrible input delay, but when i switched it to a password-unlock: no delay.

    • In the phone app, if I'm typing on a number from the number pad, its slow, but if I'm typing a name to find someone in my address book, its fast.

    • The back and home buttons are fast but the apps button lags

    Games are unplayable.

    I decided to enable the "visual feedback for touches" and I can verify that it's not the touchscreen itself because I can see the visual indicator immediately after touching, but the delay is still there for the OS.

    I also downloaded a touchscreen app and I noticed that it registers swipes perfectly, but I have to hold my finger down to register dots...

    Can anyone help me please?

    Things i've tried with no success - different launcher, ART runtime, reducing animation speeds in developer settings, turning off active display, clearing cache, and finally a factory reset. I'm at my wits end on how to fix this issue. It really is a deal breaker for me as the lag is so obvious.

    Advertisement
    :
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    Welcome to the forums, coogsig! :wavey:
    Couple questions up front:
    -What model do you have and have you tried updating firmware?
    -How long have you had your phone?

    It's possible you may have a lemon. I've only spent a small amount of time with my wife's Moto X and never noticed any input lag. Since the latest crop of phones I've had, I've never seen anything as bad as what you describe (my '12 Nexus 7 is pretty atrocious with input lag though). It sounds like you've done just about everything possible to find the culprit. If you're still within a return window, I'd try to exchange for another one.
  3. Thom

    Thom Premium Guide Member Guide

    It is hard to know what state your phone is currently in. Turn off developer options. Try running in Safe Mode (disabling all apps you added without uninstalling them). If the problems stop they are caused by an app that you added.

    When you did the Factory Data Reset ... did you also do a Wipe Cache Partition at the same time? Do you periodically do a Wipe Cache Partition? (I do it once a week.)

    A while back on a different device there was a person with a lot of problems associates with his screen. We could not reproduce the problems. We finally got him to let someone else manipulate his phone and the problems were not there for them. The problems were only there when he used the phone. Conclusion ... he was not physically compatible with the phone. You could try letting someone else enter the information on your phone as a test.

    ... Thom
  4. coogsig

    coogsig New Member

    Thanks for the responses guys.

    I was able to try a work colleague's Moto X and his works just fine. I held them right next to each other and pressing the app launching button at the same time you see a noticeable difference in when mine responds.

    Breadnatty,

    My System Version is 165.44.1.ghost_att.ATT.en.US
    which I believe is the latest.

    Also, I just got the phone last week, it's brand new. The only apps I've installed are MobileIron for my work email and then a few games. I tried Thom's suggestion of turning off developer mode and restarting in safe mode and the lag is still there.

    I don't think it's a personal perception issue on my part, because the keyboard and the back/home/recent apps buttons are snappy. It's just everything else!!

    I'm trying to decide if to send it back to Motorolla or wait for the new OS update to see if it fixes anything..

    :mad:
  5. coogsig

    coogsig New Member

    Hallelujah! I fixed it!

    It was the Magnification Gestures!

    I turned that off and voila! everything is responsive again! Now, I just need to learn to live without those gestures, oh well, better than a laggy phone. Hopefully it can be fixed in a future firmware update.

    I hope this thread can help others with similar problems!
    breadnatty08 likes this.
  6. Thom

    Thom Premium Guide Member Guide

    Great.

    I really like the triple-tap to magnify the small print (like descriptions in Play Store). I use Nova Launcher Prime on the Droid Maxx on Kit Kat 4.4.4. Its double-tap is not supported under the latest release of Nova Launcher Prime if tipple-tap us also enabled.

    (The incident I cited was not a user perception problem ... it was a very real incompatibility between the user and the device. Another user of his device did not have the problem.)

    ... Thom
Loading...

Share This Page