MAJOR ISSUE: X only turns on every few tries..laggy and wont allow me to hard resetSupport


Last Updated:

  1. Patsum

    Patsum Well-Known Member This Topic's Starter

    Joined:
    May 9, 2010
    Messages:
    62
    Likes Received:
    1
    Im on stock motorblur 2.1...
    Just yesterday the phone started lagging hard. I took the battery out..it wouldn't turn on and would freeze at the M logo...found out that now it will only boot up if I pop the battery out, put it back in, wait 10 minutes then hit power... My Settings physical key stopped responding peroid today. and I cant do a hard reset because in order to do that it restars the phone and it freezes at the M logo...I tried to hit HOME and POWER when turning on but it wont even enter that service menu...

    help?

    it still lags like hell when I get it to even boot...
    no physical damage or anything.
    been working for weeks now perfectly
     

    Advertisement
  2. ECFfighter7232

    ECFfighter7232 Well-Known Member

    Joined:
    Jul 21, 2010
    Messages:
    1,493
    Likes Received:
    336
    personally I would try to do a flash with the .sbf. It might not work, but its atleast work a shot.
     
  3. CriticalMass

    CriticalMass Well-Known Member

    Joined:
    Jun 5, 2010
    Messages:
    197
    Likes Received:
    14

    Probably a run-away app you've installed?
     
  4. mahers

    mahers Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    1,320
    Likes Received:
    164
    Exchange it.
     
  5. bigbadwulff

    bigbadwulff Well-Known Member

    Joined:
    Jun 15, 2010
    Messages:
    2,442
    Likes Received:
    200
    You sure the battery isn't too low?
     
  6. 2horses

    2horses Well-Known Member

    Joined:
    May 11, 2010
    Messages:
    583
    Likes Received:
    47
    I second the battery strength. Try plugging it in to a charger while it's down, give it a few minutes, and then try to power it up again.
     

Share This Page

Loading...