[MAJOR SOLUTION] Fix your slow 3g speeds:EVO4g


  1. Mr. Ed

    Mr. Ed Well-Known Member

    Just call sprint and get your msl
  2. daman7676

    daman7676 Well-Known Member


    +1

    Just called and told them I was an advance Android user and that I just needed my MSL.

    This fix WORKED! Thank you to everyone who figured this out. I was getting about 125k down and now I'm over 1000k down when testing 3G speeds.

    This is how 3G should be.
  3. captain008

    captain008 Well-Known Member

    Thanks MR. Ed for advice!! I really did not see a great improvement in the results, the only notable thing is that my speeds stayed above 1.0 mbps. I will say that this did help me with web browsing considerably. Loading pages like androidforums used to take a hot minute, but after this it loads up pretty well and does not get stuck on the site banner. Here are my speeds (Using Speedtest in mbps) without the mod:
    1.08/.57
    1.4/.59
    1.0/.39
    .94/.26
    1.15/.32

    Then after the mod:
    1.2/.27
    1.16/.32
    1.22/.36
    1.11/.33
    1.07/.21

    Again thanks for the help and the advice.
  4. 2kwik4u

    2kwik4u Member

    Registered on this forum just to respond to this thread.

    Got a fancy new EVO 4G from the office a few weeks ago. I was moved to the EVO from a Blackberry 9000 running on AT&T's network. I felt ever since I got it that attachments were coming down slow in my email, my web surfing was slower than it should be, and in general the network performance was junk. My Blackberry was snappy in all network performance regards as compared to my new EVO. At the suggestion of a good friend of mine I started doing some research, at the suggestion of my boss I took the phone into the local Sprint store......

    The Sprint store was useless. 100% useless. They took an hour and a half to check the hardware. I was the 4th person in the store I think. They have done TWO hard resets on the phone causing me to lose all data, apps, contacts, etc. Luckily my contacts, mail, and calender resides on an exchange server, so it comes back pretty quickly. They finally told me that the phone seemed fine, and that the speedtest.net app was falsely reporting the speed (despite the results from my home wifi connection showing a consistent 10mb down). I politely asked for my MSL so that I could fix the problem myself, and was denied. The manager was called over, I explained my problems, and was denied my MSL number again. I said fine, it is what it is, then politely expressed my displeasure with the network performance, and went on my way. Just as a refernce, the speed INSIDE the Sprint store across what they said was a "fine" 3G connection was fairly consistent in the 60 to 100kbps down. Yea, less than .1mb down on the fastest connection they offer here in town.

    So off to this thread I headed, downloaded the CDMA workshop, found my MSL number, did the changes to the network settings as directed, and DID NOT update the PRL.

    Network speeds on my couch through the 3G connection before were between 120 and 140kbps down, and in the low 60's up. After the setting changes, the speeds are up to between 750 and 800kbps down, and in the high 900's up. Amazing change! Everything feels more "normal" to what I am used to experiencing on my AT&T Blackberry. My Facebook news feed no longer takes over a minute to load, it loads new in 15-30 seconds. Forums are loading in equally faster times. The network feels "snappy" like I would expect from it.

    I'm going to test my hotspot performance next. I had problems with it connecting yesterday at all. Might have been on a bad tower, might have been the rainy weather, I don't know. But timing out while trying to load a remote desktop session just wasn't acceptable, and what ultimately prompted me to do the fix.

    All in all, I'm very happy with the results, and would like to thank the original poster for putting this together. Great step-by-step write up! 5 Stars!
  5. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums!
  6. Mr. Ed

    Mr. Ed Well-Known Member

    Thank you and welcome! I am very glad this has helped so many people!!!!
    jacker likes this.
  7. 2kwik4u

    2kwik4u Member

    Another quick follow up. I was still only getting around 350-400kbps down. While it was a 200% gain from the factory settings, I felt it should still be higher.

    Did a bettery pull (old Blackberry habit) and rechecked my speeds with speedtest app. Sitting on the same couch cushion as before with roughly the same signal strength, I'm now getting an average of around 1,200kbps down!!!! This is how 3G is supposed to be IMO!

    I would recommend the battery pull after the procedure. Worst case it'll cost you a minute or two and won't help, it could be a huge help as in my case. Of course this is assuming that it wasn't a tower problem all along.

    Thanks again guys!!!
    Mr. Ed likes this.
  8. Mr. Ed

    Mr. Ed Well-Known Member

    I will add it!
  9. 2kwik4u

    2kwik4u Member

    Thought I would add another small update to a problem this fixed for me. Not sure how many other people are using this feature, but it might be worth mentioning.

    When on a WiFi connection, I could connect via VPN into my companies file server. Once connected I used the app "ES File Explorer" to browse for files located on the server. I have some other MS Office file editing apps that I would use to then modify the files, and either dump back onto the server for other employees use, or email out to clients (Quotes, spec sheets, etc). Spending about 38-45hrs a week in the field this was a VERY handy tool to have in order to continue work on a particular jobsite, and still get my other work taken care of.

    BEFORE the fix, when attempting this process, the VPN would connect, but the file browser wasn't able to make a connection to the server. It would cite the reason as not being on a wifi connection. I assumed this meant that the connection was simply to slow, and was timing out.

    AFTER the fix, the process works like a champ when on a cell connection. I was actually able to retrieve, revise, and email a quote while riding in the truck yesterday afternoon between job sites.

    Like I said, I'm not sure how many others are using this type of connection, and associated workflow, but the speed fix restored some lost usability for me.

    Once again, thanks for the excellent work!
    Mr. Ed likes this.
  10. alphamale

    alphamale New Member

    Read through the instructions, searched the thread, and tried to go through all the posts. I normally run CM, switched to Warm 2.2 to do the fix, but am unclear on how to get back to CM with fix intact. I did a Nandroid of my CM, if I understand the instructions in this thread correctly, I can simply go back to that Nandroid w/out a wipe(cache/davlik/data)?

    BTW...awesome fix!

    Before .05- .15

    After 1.0-1.5
  11. swany11

    swany11 Member

    I am consistently getting 3G readings as follows:
    Download 1.30 MB
    Upload .78 MB

    It sounds like this is more than adequate, and there is not a need to make these tweaks?
  12. pgarrett

    pgarrett New Member

    Thought I would register an account here so I could post my results from following the info in this thread.

    Unrooted HTC EVO.

    PRL was 60677 when I started. First post said latest is 60676 but I figured what the hell

    Did some tests with speedtest app and averaged .2 to .3 Mbps dowm, .1 to .2Mbps up.

    Followed instructions in tread. Both speeds decreased. New average was .1 to .2Mbps down and .06 to .09Mbps down.

    Went and manually updated my PRL.

    PRL is now shown as 01115 (seems odd?)

    Speeds increased. Currently receiving .7 to .8Mbps down and .25 to .3Mbps up.

    Edit:

    Tried a battery pull. PRL still shown as 01115. Speeds dropped. Average is now .5/.3
  13. EarlyMon

    EarlyMon The PearlyMon Moderator

    I'd say you're good to go.
  14. 5280ME

    5280ME Active Member

    So I finally got this "Mod" done last week. I'll say it was awesome. . .for one day! Then it went right back to crappy speeds! :(
  15. Mr. Ed

    Mr. Ed Well-Known Member

    Try a battery pull....or by all means do the steps again. All it is doingvis forcing a reset ofvthe data communication between your phone and the towers. In the end it could be the tower. Its been almost a year and I still have no sprint 3g at work.
  16. longshot

    longshot Well-Known Member

    I have pretty much determined that mine is a tower issue also. My phone sometimes hits speeds past 2mb and other times .2 -.3 and tested this on one stock phone and mine rooted and the same results.
  17. 5280ME

    5280ME Active Member

    I tried both.
    I am at work now where I get between .oo-.25m (down). I first did the "mod" here at work last Saturday and instantly started getting 1.xx (down) speeds!! I just tried again today here at work and it's back to .00 -.05 (down)

    I live less than a mile, as a bird flies, from my office, and am on a completely different tower there but, the speeds at home are only at .05 -.30 (down).
  18. Mr. Ed

    Mr. Ed Well-Known Member

    Definitely odd.
  19. Matlock

    Matlock Well-Known Member

    Just installed the new Gingerbread leak from XDA. I've had horrible speeds ever since I can remember, and just dealt with it. After trying all day long to download a Sense based ROM from ROM Manager, and XDA.. I finally got one to download, but it was the new leaked version.

    Anyway.. When I type in the ##3282#... right when I hit the last #, the numbers vanish, and I am unable to click on anything. Nothing is going on at all. The only way to remedy it is to press the Back button.

    Any ideas?
  20. psychohistry

    psychohistry New Member

    I've never posted on forums before so I apologize if I'm doing something against forum etiquette, but I just had to say something because I was ecstatic with how well this worked! I did run into a problem though. When I first followed the instructions yesterday (after first updating my PRL to 60677) word for word, when I restored my data profile, my phone restarted but it didn't prompt me to do any hands-free activation or updating PRL again and I could not connect to 3g anymore. I went into setting and made sure mobile network was on but it said that service is currently unavailable, even though I was able to make calls and connect to 4g perfectly fine. Not sure what went wrong here.

    I did a factory reset and updated my PRL again (this time it showed up as 01115) and then followed the same steps and it worked! After the restart this time it did the hands-free activation and started checking for PRL update which I immediately cancelled. I checked my speeds and they were almost 10X what I was getting before!

    Before:
    0.117/0.144
    0.117/0.144
    0.118/0.149
    0.118/0.141

    After:
    1.0/0.8
    0.75/0.89
    0.72/0.88

    One thing I noticed is that in the "before" speed tests it said my connection type was 1xRTT and in the "after" ones it said EvdoA. Not sure what the significance of this is, if any. Btw the "before" speed tests listed above were done after the factory reset but before following the steps on this forum. However, they were exactly like the speeds I had been getting for the last two weeks throughout my city since switching to a Sprint Evo 4G from an AT&T iPhone 3GS!
  21. Mr. Ed

    Mr. Ed Well-Known Member

    It may be missing the file for the menu. I am elbow deep in axle greese right now changing my axle boots but I bet I can add a sense rom to my dropbox for you. A few of kings Rome don't have the menu so I bet that is what's wrong
    Matlock likes this.
  22. Mr. Ed

    Mr. Ed Well-Known Member

    1X is plain please slow data....evdo is 3g
    That's odd that itvwould update to that prl. I am pretty sure that is a Verizon prl. In the case that the handsfree doesn't start one can manually go to menu.settings system updates profile or run through the steps again.
  23. EarlyMon

    EarlyMon The PearlyMon Moderator

    Sorry to be pendantic, but you know me - :p :)

    1x is still 3G, but it's just at the original 1x speed - EVDO is faster. 1x detail - What is 1xRTT? - Definition
  24. captain008

    captain008 Well-Known Member


    I now see that as well but only after using the leaked GB rom. I flashed back to Froyo and it reports a PRL of 60676 or 60677. With the 01115 PRL I am getting roughly the same speeds. They vary from .5-1mbps down and .2-.5 up. I have also done the battery pull and still getting same results. Does anybody know if this is a new PRL or just something from the leaked GB?
  25. captain008

    captain008 Well-Known Member


    For some reason the leaked GB rom's EPST does not work. The EPST.apk in the Root/System/apps/ folder is a non executable. I have tried uninstalling the ESPT.apk (GB version) and installed the version from Froyo. Sorry to say that it failed and I still cannot get into the settings.

    I did figure out a work around but it seems a little intense.
    -First I used the clockworkmod to make backups of Froyo and GB
    -I then used ##data# in froyo and did the steps as explained by Mr.ED
    -When the phone asks to resets, I entered into clockwork recovery and restored the GB rom

    After a few minutes of recovery the GB rom loads and the hands free activation comes up, just cancel the PRL update and your done. The only issue I found is the new PRL of 01115 is being reported instead of the 60677 in froyo.

    I hope this helps.
    Mr. Ed and Matlock like this.

Share This Page