Make Handcent SMS defaultSupport


Last Updated: 2011-10-24 21:53:07
  1. dbu

    dbu Member

    How do I do this???

    Advertisement
  2. On my Hero, here's what I did:

    Install Handcent SMS.

    Go into Handcent and make sure the settings are enabled to have notifications in the notification pane and to autoretreive messages.

    Go into your native SMS app and go into it's settings, turn off the ability to auto retrieve messages.

    That's all I had to do on my Hero.
  3. dbu

    dbu Member

    Thanks, works great.
  4. imurgoodknight

    imurgoodknight New Member

    Have Eris with 2.1 update now that have set handcent sms as default will not let me send picture text unless I switch back to native sms
  5. messenger13

    messenger13 Well-Known Member

    I would leave Auto-Retrieve on, and simply just disable notifications. Should you ever want to go into the stock app, this will work better for you. Also, disabling auto-retrieve in the stock app can cause issues with MMS messages in HandCent.
  6. imurgoodknight

    imurgoodknight New Member

    Thanks buddy,going to try right now.
  7. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Was nto aware of this. But, it explains a lot....

    I so rarely use MMS that I didn't really give a rat's arse about it....

    Thanks, bro!
  8. Droid Panda

    Droid Panda Active Member

    i was wondering if there was a way in the settings to set it so that a number of unread messages pops up on the home screen by the icon? just wondering.
  9. Sabrina

    Sabrina Member

    I just started using handcent as well and have the auto retrieve off on handcent and have it on on my native sms. Should I turn it on on handcent as well? I'm a little confused.
    Also does anyone know why the sms read report isn't working on handcent? I tried it, but all I get is "report pending" and a little clock symbol next to the sms. But I know for sure that my friends have received and read the text.
  10. GirLuvsDroid

    GirLuvsDroid Well-Known Member

    AFAIK, you have to use the Handcent widget to show an unread count in the icon.
    Kchristainsen likes this.
  11. KeyserSoze

    KeyserSoze Active Member

    Handcent FTW. Thanks for the tips guys.
  12. chiu1

    chiu1 New Member


    actually I just tried it, cause i have an issue with dual message receiving coming from the default and handcent. I fixed and have had no issues, I turned off default messenging auto retrieval and turned on auto retrieval on "settings" for handcent under "recieve message settings" and checked "auto-retrieve" and when "roaming". all is good in the hood! thx and it doesn't seem to create conflict. :D
  13. John_F_L

    John_F_L New Member

    i have a question also about this... i have made the handcent the default app, but on the home screen, when i go to unlock the phone, it shows me that i have new sms... how can i delete this from the homescreen and only handcent notifications are shown???
  14. soulmenj

    soulmenj New Member

    i have the same problem.. anyone can help us.. here.. please. :confused:

    please help us how to remove the notification in the lockscreen.. even if i don't have any messages..
  15. defkorn

    defkorn Well-Known Member

    Go to the stock messenging app, then Settings. Instead of turning off auto-retrieve as mentioned above, just un-check the "display message notifications in status bar" setting. Now you simply won't be notified from the stock messenging app, and they'll come through in Handcent.
  16. bpolite197034

    bpolite197034 New Member


    Thanks!:D
  17. Conundrum1984

    Conundrum1984 Member

    Yesterday my Samsung Mesmerize did not do this: It asked me when I first bought it if I wanted to set Handcent as default. I said "yes". All notifications went through Handcent. The widget on the homepage for Handcent showed how many unread messages I had. And the original app did not. I went to work, turned the phone off and left it in the car. Came out, turned it back on after my shift and said there was an update for Handcent. I updated and all notifications for both programs were back on. I would get notified 2 times for each text. I just did what everyone said, I turned off notifications and retrievals in the original app. It all works fine except the original app icon on the homepage now shows numbers for unread messages. How can I stop this? Or is it just a fact I have to deal with now?
  18. bissolati

    bissolati New Member

    It's happening EXACTLY the same thing in here... Already tried all of the tips in here, and the original app icon still shows number for unread messages (even if i read all of them in handcent). Never happened that before this last update.
  19. PCLM

    PCLM New Member

    my handcent is not working it always say : "the message has failed to send. please select an action for the message" what do I do??
  20. wetbiker7

    wetbiker7 Well-Known Member Contributor

    Working GREAT ! Pictures are sending and receiving too ! Thanks people . :D

Share This Page