managing files on PC when the touchscreen is not workingSupport


Last Updated:

  1. rachel_x_

    rachel_x_ Member

    Hi

    Please can you advise.

    my touch screen on my HTC One X stopped working on Friday. before I return the phone to HTC I would like to recover some photos from the mobile.

    Usually after connecting the phone to the PC there is a menu that asks whether you wish to: charge, connect to the HTC programme, or use as a disk drive.

    I can not choose an option and therefore the phone drive does not show on my PC.

    Is there a programme that I can download to my PC that will access my phone memory without me having to choose options on my phone?

    The phone is otherwise working and so there is WiFi connectivity on the phone and the USB connection is recognised by the phone and the PC.

    Many thanks
    Rach

    Advertisement
  2. coos lick

    coos lick Well-Known Member

    'Myphoneexplorer' has both an android app and a desktop client. It can connect and transfer files via WiFi - so gets over the USB selection problem.

    I don't know if it will work, but you could try sending the app to your phone via the play store on pc, then using the desktop client to see if it will pick up the phone. If it does - then you are able to explore the sd card and copy across what you want.
    scary alien and rachel_x_ like this.
  3. rachel_x_

    rachel_x_ Member

    thanks for that advice,

    i have downloaded the programme to my PC and playstore on the computer says it is sending the app to my device.
    however, i think that the PC programme will require that I turn the app on on my device.

    I'm thinking I may be able to access the phone if I can get the IP address for the phone, or maybe using avast that is already installed and should be running on the device.

    after getting the data off the phone (or when ive admitted defeat) I want to remote wipe it using avast sms commands but I can not find out what these are online, although i'm very tired and worked up right now so again I'm going to leave it til tomorrow,
    thanks

    any further pointers greatly appreciated :)
  4. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    You should be able to mount the SD Card via ADB/Fastboot. Let me do some digging and I'll see what I can find.
    rachel_x_ likes this.
  5. Hadron

    Hadron Well-Known Member Contributor

    Wiping is easy - you can do that from recovery if there's any problem with the Avast method.

    One question: do you have USB debugging enabled? If you do then you can mount the card using adb (I think "adb shell mount sdcard" should do it), then copy files over usb. Most of the work will be getting adb set up if you haven't already.

    Otherwise, we're still thinking about alternatives....
    scotty85 and El Presidente like this.
  6. Hadron

    Hadron Well-Known Member Contributor

    Hi again,

    Scotty85 tested, and I can confirm, that adb shell mount won't solve this for you. So what you need to do is:

    adb pull /sdcard/

    Find a post by Scotty and thank him - I'm just posting this now because I'm in the same time zone as you, so you'll get the information sooner that way!
    rachel_x_ and scotty85 like this.
  7. scotty85

    scotty85 Guides Guide

    thanks for posting hadron :smokingsomb: anxiously awaiting the answer!

    i know you cant check it now,but the setting were refering to is settings/developer options/usb debugging. hopefully youve had to checkmark that setting for some other program or app to work,as its not usually on by default.

    if you allready have the sdk set up,all you need to do is plug in the phone,youll see the usb debug and charge icons pop up in the status bar.

    adb devices

    will spit back your serial number if your connected. you can then:

    adb pull /sdcard/ to dump the entire contents of your sd. they will be located in your adb/fastboot file

    adb pull /sdcard/DCIM/if you just want pics.

    you can pull pretty much any single file that you know the path to,if you dont want to dump the whole thing.

    if you DONT happen to have the sdk set up,no biggie,you dont need to fool with the whole thing. we have a much smaller download,youll just need to extract,open a cmd window and change to the correct directory. just let us know if you need this :)

    Attached Files:

    Harry2, rachel_x_ and El Presidente like this.
  8. rachel_x_

    rachel_x_ Member

    Thank you for your help.

    I have adb installed, however I don't think debugging is turned on on the phone, I can not see the debugging symbol and as it is a fairly new phone I haven't played around with it too much. i have tried the commands but no luck.

    the ip address for the phone doesnt show up on a cmd prompt but a programme called 'dude' found my phone and IP address and a ping test works.

    i tried to connect to the phone using the ip address and myphoneexplorer but it's not having it. i wonder if having avast security set up is preventing me from accessing the phone remotely?

    any other ideas,
    thanks so much for your time :)
  9. scotty85

    scotty85 Guides Guide

    sorry that didnt work out for you :( i have been trying to think of other ways we could possibly accomplish something remotely,but not having much luck.

    just out of curiosity,was the phone on the most current firmware,2.20.502.7? if youre not sure,you could power on into hboot and tell us the info there.
  10. scary alien

    scary alien not really so scary Moderator

    Rachel,

    I might have something that might help you, although I'm still testing the final details at this very minute.

    Ping me back on this thread or send me a PM and I'll get back with you with the information and simple steps for you to try (two apps to install remotely from the Play Store, you'll also need a web browser (like from a PC) and a wi-fi connection).

    Let me know! :)

    Cheers!
    scotty85 and rachel_x_ like this.
  11. rachel_x_

    rachel_x_ Member

    thank you! I'll check back after work today.

    the software was updated less than a week ago so should be the latest :)
    scotty85 likes this.
  12. Hadron

    Hadron Well-Known Member Contributor

    I'll let Scary post the solution (unless you get impatient ;)), but just to let you know I've tried it on my phone without using the touchscreen and it works :)
    rachel_x_, scary alien and scotty85 like this.
  13. scary alien

    scary alien not really so scary Moderator

    Hey Rach! (my daughter's name, too! :))

    Okay, here's what we've come up with that we hope will help you out:

    • from a web-based browser go to the Google Play Market and remotely install the following app to your phone:

      WiFi File Explorer

    • next, install this application from the Market, too (this is the one I wrote for you last night):

      AF Rescue

      FYI, the behavior of this app is to simply launch the WiFi File Explorer app after a reboot.

    • you should see the little download icons on your notification bar showing you that the apps are being downloaded and installed; give them a few minutes to make sure that they finish-up

    • after the apps have been installed, go-ahead and power down and reboot your device

    • after rebooting, the WiFi File Explorer app should be running, even if can't see it or unlock the screen; hopefully you will be able to see its pop-up screens directing you on what URL to use on your PC's browswer

    • for me, the prompt was "http://192.168.1.109:8000", but this will undoubtedly be different for you depending on your local network configuration (hopefully the other more network-savvy guys can chime-in here to help guide you along with how to determine what your address might be if you can't see the app's prompt)

    • if you can see the prompts from the WiFi File Explorer app, you should be able to enter that URL in to a browser on your PC; that will give you a web-based browser view of the files on your phone and allow you to download the files that you need to recover

    That's about it...best of luck and I hope this works for you!

    Cheers and please let us know.
    Harry2, scotty85, iowabowtech and 3 others like this.
  14. Hadron

    Hadron Well-Known Member Contributor

    To get the WiFi File Explorer page for my phone without being able to see the prompt on the screen, what I did was:

    * Went to my router's control panel (web page) and looked at the list of attached devices.

    * My phone was at the IP address 192.168.0.4, so I tried 192.168.0.4:8000 in my browser and this gave me access to my sd card.

    So if you can find your phone's IP address on your WiFi network, stick ":8000" onto the end and I reckon you'll be sorted. If you can't see your phone's ip address, let us know and with any luck someone will be able to figure it out

    I did try to see whether I could keep the screen on and hence see the prompt without using the touchscreen, but while I was able to stop the screen sleeping (by touching the volume keys every now and then once the phone started booting) the screen lock still came on before WiFi File Explorer started, so I couldn't view the popup without unlocking.
  15. rachel_x_

    rachel_x_ Member

    hi,

    i have sent both programmes to my phone from play (thanks so much for writing that programme) and play store says both are installed.

    there is no indication on the phone that they are installed or running and i can not see a prompt.

    the ip address of my phone is 192.168.1.4, however i get the error ' Oops! Google Chrome could not connect to 192.168.0.4:8000 ' when i put that in the address bar. ive tried in both chrome and internet explorer
    :)
    scotty85 and scary alien like this.
  16. scary alien

    scary alien not really so scary Moderator

    You are most welcome, Rachel :).

    Did you reboot your device? (it takes that to trigger my app to auto-start the WiFi File Explorer)
    scotty85 likes this.
  17. rachel_x_

    rachel_x_ Member

    yes, twice now!
  18. scary alien

    scary alien not really so scary Moderator

    Can you try: http://192.168.1.4:8000 ?

    You reported above that your IP address was 192.168.1.4, but you tried to connect via 192.168.0.4:8000.

    When I identify my phone's IP address, it matches what WiFi File Explorer instructs me to use along with the ":8000" port number suffix.

    Crossing fingers! :)
    scotty85 likes this.
  19. rachel_x_

    rachel_x_ Member

    sorry my mistake - ip address is 192.168.0.4

    Wireless Devices
    MAC Address IP Address Device Name Time Connected
    30:46:9a:27:4f:a7 192.168.0.3 hal 0days 2hrs 42mins 8s
    1c:b0:94:77:d9:5b 192.168.0.4 android-dd33cf1082afe119 0days 3hrs 33mins 33s


    could it be a firewall thing? or something to do with avast?

    thanks so much for your help :)
  20. scary alien

    scary alien not really so scary Moderator

    Hmm, dunno--I can't imagine that it's a firewall or anti-virus issue...

    Not sure that I can debug / replicate things from here at work (we have multiple networks and my PC is not on the wireless network). I won't be home for a few hours...

    Maybe Hadron or one of the other fine folks has an idea to help zero-in on the right combination.

    By the way, when the app launches after a reboot, there's no obvious indication on my GNex that its there until I unlock the lockscreen. I'm guessing that if you have a lockscreen setup, you can't unlock to see anything...

    Do you have a lock screen on your phone?

    I could tweak the app to display a notification in the status bar up-top that indicates that it thinks the other app has been launched--just to give you positive confirmation that it's up and running. I can't do that until I get home, though...

    (p.s.: you are most welcome--this is what we do here at AF :))
    scotty85 and rachel_x_ like this.
  21. rachel_x_

    rachel_x_ Member

    that would be amazing! :) there is a lock screen turned on. im only worried about avast because it has all the anti theft and anti hacking software on it...
  22. scary alien

    scary alien not really so scary Moderator

    I'll tweak the app when I get home to display a notification in the status area.

    Now, are you talking about Avast on your phone or your PC? (I've never run any of that stuff on my Android devices, so I'm woefully uninformed about those apps for a mobile device).
  23. rachel_x_

    rachel_x_ Member

    scotty85 likes this.
  24. scary alien

    scary alien not really so scary Moderator

    Oooo....interesting....(thanks!)

    Yeah, I see where it says that the firewall is only relevant for rooted phones...so, if you've never been presented with a pop-up asking to grant permission for a network app / action, then I'm guessing (hopeful) that this is not the issue.

    :) [still crossing fingers ;)]
    scotty85 likes this.
  25. coos lick

    coos lick Well-Known Member

    Avast is interesting -

    avast! Free Mobile Security | Antivirus & Anti-Theft App for Android

    Look at the bottom of the page. Apparently you can launch any app by sending an SMS to the phone? Can't translate the code instructions - but could you use this to start the wifi file explorer or myphoneexplorer? You just need to have set an avast password.

    Other option is web access - but I haven't registered to see what the options are there.

    Fingers crossed this works somehow - made me think about what I would do if my screen broke.
    scotty85 and scary alien like this.

Share This Page