1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

managing files on PC when the touchscreen is not workingSupport


  1. Hadron

    Hadron Well-Known Member Contributor

    On mine I could see in the notification bar that WiFi File Explorer had started, as long as I didn't let the screen go off - it puts a little WiFi symbol up in the left-hand corner (I've not touched the app's settings, because you wouldn't be able to).

    Can you see the notification bar through your lockscreen? I've never used Sense 4 except playing in a shop, so don't know stuff like that.

    The address looks correct (at least that's what works for me, sticking 8000 on the end). So could avast interfere with starting one of the apps up? Guess I'll install avast, uninstall the others, then try to repeat the process and see what happens.
    scary alien likes this.
  2. Hadron

    Hadron Well-Known Member Contributor

    Hmm, still works for me:

    * installed avast, ran virus scan, left other options at default. Did not set up anti theft or firewall.

    * reinstalled WiFi File Explorer and AF Rescue from play.google.com. Watched both install, didn't touch phone except to reboot after done.

    * Let phone boot, didn't touch. Checked ip address, added :8000 to end, pointed browser at it.

    All worked. So unless there's something in the avast settings that I didn't set up it didn't get in the way.
    scotty85 and scary alien like this.
  3. Hadron

    Hadron Well-Known Member Contributor

    Rachel, something I noticed:

    Your phone had been connected for 3.5 hours when you posted this. Was it that long since you'd rebooted?

    I'm just wondering whether there's any chance it hadn't done a full shutdown, but had done the "fast boot" thing instead? I don't know really what that does, but I'd think we'd want a full restart for this fix to work.
  4. scary alien

    scary alien not really so scary Moderator

    Very, very interesting, coos lick!

    I spent the last hour, LOL, trying to get the remote commands to work on my phone using this...epic fail, LOL ;) :).

    For any that might be able to get this to successfully work, here's the package name of the WiFi File Explorer app:

    com.dooblou.WiFiFileExplorer

    although I believe the activity name that you'd want to start is actually:

    com.dooblou.WiFiFileExplorerLib.Start

    I see that, too, Hadron--Rachel, are you seeing that on your phone?

    I'll still work on the notification thing we discussed earlier, but you should hopefully be seeing the wifi symbol that Hadron described.

    :)
    scotty85 and rachel_x_ like this.
  5. scary alien

    scary alien not really so scary Moderator

    Well, new version has been posted on the Play Store/Market...it seems like it takes a while for new versions to show-up nowadays (more than an hour sometimes :(), so check the version number on the Market to see that it says its 1.1.

    I added an admittedly not very pretty notification icon (small green alien head surrounded by a yellow border so it should be obvious) when the app has launched the WiFi File Explorer app.

    Don't forget, you should also be seeing the small, additional wi-fi symbol that the WiFi File Explorer app also produces on the top left of your screen.

    Cheers and again, good luck!
    scotty85 and rachel_x_ like this.
  6. iowabowtech

    iowabowtech root@android:/ # Moderator

    Just to be sure, you are typing it out as http://192.168.4:8000 correct? Also, that may well be your phone's IP on your network but often times, device IP's end with a 3 digit number. So I was just wondering how you are determining your phone's IP? The 2 most surefire ways are to login to your router, access it's settings and check the DHCP client table where it should be listed with a huge clue like HTC device, etc. Another option is to install a freeware program like this:

    Advanced IP Scanner - CNET Download.com

    I've used it and it's clean and actually quite handy. If you do end up installing it though, choose the advanced install and opt out of all the add on junk.

    Anyway, if you're already good on all this, forget what I said. Just wanted to be sure because you're soooo close to making this work. :)
    scotty85, scary alien and rachel_x_ like this.
  7. rachel_x_

    rachel_x_ Member

    i checked on the router for the ip address and a programme called 'dude'

    on avast i did set up the anti theft side of things so do have a password - however i cant find a copy of the sms commands and the web portal doesn't seem to be up and running yet. there is an app 'a! commands' that contains the sms commands ive asked my boyfriend to download it so we can try it out.

    theres definitely no icon in the top left hand corner but playstore won't allow me to install the programme from the pc as it says its already installed.

    im never able to turn the phone off just soft reset by holding the power off button for 10 seconds, however it did run out of battery last night... but 192.*168.*0.*4:*8080 still isn't working.

    downloading the new version of your app now and if you can tell me how to turn the phone off i will do it properly (or ill let it run out of battery whilst im at work)

    thanks!
    scotty85 and scary alien like this.
  8. rachel_x_

    rachel_x_ Member

    ive managed to get the phone into the startup options, i didnt realise you jad to press vol down and power as the phone was starting up. i have no idea if any of the following is relevant but i have to go to work now so...

    ***locked***
    eneavoru pvt ship s-on rl
    hboot-1.12.000
    cpld-none
    microp-none
    radio-2.1204.135.20
    emmc-bootmode: disabled
    cpuy-bootmode: disabled
    hw secure boot: enabled
    modem path: off
    jun 28 2012 11:31:28

    then it hasthe button instructions and the 6 options fastboot
    recovery
    factory reset
    simlock
    show barcode
    image crc

    im gona leave it to run out of battery

    thanks!
    scotty85 likes this.
  9. Hadron

    Hadron Well-Known Member Contributor

    8000, not 8080 - I know that was probably just a typo, but have to be sure :)

    If you've got it into hboot then booting from there should be a full boot.

    So why isn't the app launching (because that's what it sounds like is the problem, if no sign of the icon)? Hmm....
    scotty85, rachel_x_ and scary alien like this.
  10. iowabowtech

    iowabowtech root@android:/ # Moderator

    Definitely worth taking out of the equation. To bypass a fast start, pull the battery to shut off the phone instead of using the power button. Might want to try this a few times and see if the app fires itself up.

    Also, rather than the Avast being an issue, I'd be more apt to look at your local machine and any security, firewall, proxy solutions you have on it. Because this procedure could possibly be viewed as an undesirable effort to interface your network and maybe even your local machine by an external device.

    edit: I just noticed you can indeed see your notification bar and a lack of the icon so the last part of my post may be less of a concern.
  11. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    ^^Unfortunately, the One X doesn't have a removable battery to pull out. :(

    However, holding the power button down for ten seconds until the LED lights at the bottom flash is much the same thing, so try that instead.
  12. rachel_x_

    rachel_x_ Member

    i am trying :8000 at the end, im also trying 8080 because a torrent programme once worked when i changed the port to that but i know deep down thats totally irrelevant.

    the phone has been out of battery all day, have turned it on and definitely no icon, i also found the sms commands for avast and they don't seem to be working either so perhaps more than my touch screen is damaged, although im getting calls, updates and messages through just fine.

    ive disabled all the security on my pc and tested. the play store definitely says that the two apps are installed as it will not allow me to send the two programmes to my device again.

    i cant arrange to send it back til saturday now so if i havent got my photos (at the end of the day its just photos ;) ) then i'll wipe it and get over it i reckon.

    i really appreciate all the help tho, i can't believe there are so many people that want to help a stramger, thanks
    El Presidente, Hadron and scary alien like this.
  13. scotty85

    scotty85 Guides Guide

    best bet is to activate usb debugging now ;)

    *smacks forehead*

    i dont know why i didnt think to ask this before... i see now that you have an endeavor,not an evita.

    as such,you could unlock your bootloader thru htcdev,and install a recovery,where an adb daemon will be running.

    i am fairly sure the stuff on /sdcard will survive the factory reset that the htcdev unlock does. all the pics that were on my evita(att one x) were all still on there after i did the bootloader unlock.

    i did not suggest this prior,as i thot you were on evita,wich is not supported officially by htcdev unlock,and there are no means of temp root for the newest software(needed to change CID)

    i know for a fact you could:
    1)enter hboot as you just did
    2)select fastboot
    3)htcdev unlock and reboot
    4)enter hboot again
    5)select fastboot
    6)fastboot boot a recovery image(will not permanently install)
    7)adb pull the info from the sd

    all without touching the phone screen,just vol and power buttons

    just a couple things to consider:
    1)we need to verify somehow your internal sd contents will stay safe
    2)technically bootloader unlock voids "all or parts of your warranty". however,youre only doing it to retrieve personal content that you cannot becasue of the hardware failure. id think there is no way HTC or your carrier would question this as a warranty issue.

    something else to consider,anyway :)
  14. rachel_x_

    rachel_x_ Member

    Thanks! I will call HTC to check if this would void the warranty as I'm relying on the warranty to get it fixed

    :)
  15. scotty85

    scotty85 Guides Guide

    awsome! be very clear that you are only doing so to in order to retrieve your pictures. explain every thing weve tried so far,and offer to try any solutions they have(wich prolly will be none)

    dont just accept "no that will void your warranty". raise your voice and threaten to throw rocks if you have to ;)

    the disclaimer shown is "may void all or parts of your warranty" and that "repairs that are a result of unlocking your bootloader and messing with the phones OS may not be covered". since the device is clearly broken prior to unlock,they definately should honor the warranty.

    clockwork recovery,even if an adb deamon is not running is manipulatable with the power button and vol rocker,so you will also be able to siimply toggle usb storage(a feature of custom recoveries). you wont even really need to use the adb pull command :)

    as long as we can verify that your pics will remain,(they did for me) i think this is a solution.

    the other thing to consider,is are you getting a warranty replacement,or are they repairing,then returning this same device?
  16. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    There would probably be no harm in pointing the rep to this thread either, just to show you've exhausted pretty much every possibility.
  17. scotty85

    scotty85 Guides Guide

    i think refering them to the thread is an excellent idea. it may be over the heads of most customer service reps(;)) but should demonstrate that the unlock is a last resort.

    if you decide to procede with this,here is a link to htcdev:
    http://www.htcdev.com/

    here is the recovery id use:
    from this thread: 9/6 Mandatory Update Official Clockworkmod Touch Recovery 5.8.4.0 - xda-developers use this link recovery-clockwork-touch-5.8.4.0-endeavoru.img

    make sure you check the md5

    place the recovery image into your fastboot folder(tools or platform tools for most folks that have installed the entire sdk)

    -unlock via htcdevs instructions
    -boot to hboot via power/vol down
    -select fastboot
    -launch recovery:
    fastboot boot recovery-clockwork-touch-5.8.4.0-endeavoru.img

    and then you should be able to navigate using vol rocker and power button. there should be a setting to toggle usb storage,it may be in a menu called "mounts and storage"

    after you reboot,the recovery will be gone,its not being permantly written anywhere. if you need it again,youll have to relaunch it via the command.

    once youre ready to send the phone back,you can relock the bootloader via fastboot oem lock note that this will change the locked status to relocked wich brings me to the last point: if they are going to repair the device and send it back to you,be very adiment that you want them to reset the "lock status flag" so that the bootloader will be locked again. assuming that you want to stay stock,anyway. if you think you may want to unlock and root in the future, you may skip that part. just make sure that they have made notes in your account of the reason your bootloader shows relocked instead of locked just in case you have future warranty claims.
  18. scary alien

    scary alien not really so scary Moderator

    FYI,

    My developer console hasn't been updating its stats properly in recent days, but I looked this afternoon and I see a java.lang.RuntimeException: Unable to create service sa.launcher.SimpleService: java.lang.NullPointerException being reported (that it could not start the WiFi File Explorer application from the service that my app employs).

    I'm guessing those were for Rachel's phone :(.

    Sorry that wasn't successful for you Rach, but hopefully Scotty's new info will allow you to retrieve your files.

    At the very least, this has given all of us some new insights, tools, and thoughts for possibly helping other folks in the future.

    Cheers and let us know how things go! :)
    rachel_x_ and scotty85 like this.
  19. rachel_x_

    rachel_x_ Member

    HTC said it would void the warranty. I have sent a polite email directing to this thread and quoting the terms of the warranty as some of you have stated above. fingers crossed :)
    scary alien likes this.
  20. scotty85

    scotty85 Guides Guide

    lol that does not surprise me one bit! that is prolly the pre-programmed response for your average CSR. politely ask for supervisor,then his supervisor,etc. until you get someone willing to work with you. keep making it clear that you are perfectly willing to try any solutions they have.

    also make it very clear to them you do not have to continue using htc products in the future if they are unwilling to stand behind their product. if they do not have some wort of failsafe built in for this,they should be willing to bend their bootloader rules. its certainly not your fault they designed a phone with no removeable storage,or that the touch screen stopped working.

    just my 2 cents after being in retail for long time. be polite and forceful until it is time to be angry. dont be afraid to follow the chain of command all the way to the top,if needed. eventually someone will care about keeping you as a customer(or just plain give in becasue they dont want to deal with you :p)

    good luck!
    scary alien likes this.
  21. rachel_x_

    rachel_x_ Member

    their response:

    "
    I'm sorry to hear that you are experiencing difficulties with recovering lost images.
    I apologise for any inconvenience caused by this.

    Unfortunately your warranty will be void "in all instances where the phone is rooted". This means
    that as soon as the Bootloader is unlocked and any kind of modification is made to the software,
    your warranty is void.
    I would advise in future to make use of the online back up services such as Google and drop box to avoid
    further loss of information and data.

    Should you wish to continue with the repair...
    "

    it doesn't say this on the warranty that I have in front of me. I will phone after work, it's a thing of principle now!

    this is the same as the warranty booklet I have in my hand now :)
    http://dl4.htc.com/Web_materials/Manual/Warranty/Android/1015_A_WarrantyCard_76x126.pdf
  22. scotty85

    scotty85 Guides Guide

    i would definately phone them. looking fwd to hearing how it goes for you! :cool:

    be very forceful the need to unlock is a direct result of the hardware failure,there is no reason that doing it in order to retrieve your images should affect your warranty- the failure has very clearly allready happened on a stock and locked device
    scary alien likes this.
  23. laraw

    laraw Member

    i have the exact same problem!!! I've had this phone for a few months. it was working fine. then yesterday it was stuck at the lock screen. I hear all my emails, texts, notifications coming through like normal but i cannot 'pull the ring up' to access my phone like usual. I have hooked my phone up to my computer many times and pulled off the vidoes and pictures from it but again as of yesterday that too now doesnt work. the computer wont recognize my phone anymore. so i have 2 issues. the touchscreen wont let me into the phone because its ot responding and i cant access the phone on my computer anymore. htc and att both want to do a factory reset and i dont want to do that becasue i want to get my baby's videos and pictures off first. hence the reason why i was trying to access it on my computer. how do i at least access the pics and videos? i dont care about this phone anymore i just want the videos and pictures. they are very important to me. Like i said i dont care about the phone i can get another one but i cant get the the videos and pictures of my baby back
  24. scary alien

    scary alien not really so scary Moderator

    Lara,

    First, sorry for the belated reply...was on my queue to reply before, but got lost in the shuffle over the weekend.

    Second, welcome to the AndroidForums! :)

    Third, okay, can you give us a little bit more info that might help us help you?

    1. Which HTC device do you have?

    2. Do you know if you have USB Debugging enabled?

    3. Have you ever rooted this device?

    Again, sorry for the delay in replying...let us know!

    :)
    scotty85 likes this.
  25. laraw

    laraw Member

    OOHH scary thanks :) no no dont apologize for the delay. It was a much quicker response than i had expected :)

    ok i have the HTC ONE X

    no idea about the debugging... i have plugged it into my computer before and it worked but now it wont

    and rooted it? uhm :) no idea

    i did find my ip address of the phone but when i go to it, it says the page cannot be displayed.... maybe im doing something wrong.


    THANKS AGAINA SCARY :)
    scotty85 likes this.
Loading...

Share This Page