Maps crashing my phoneSupport

Last Updated:

  1. acejavelin

    acejavelin Well-Known Member

    For some reason I had trouble linking this, so had make a short url:

    Google Maps 6.9.2

    It's safe, works fine, and is the latest working version for the Rezound.

    EDIT: This site contains TWO download links, the first just takes you to the market, the second one is a local download from APK Top. Make sure to use the second one.

  2. Mr. Boom

    Mr. Boom Well-Known Member

    That links to the market which has the new version. At least it did for me.
  3. acejavelin

    acejavelin Well-Known Member

    There are two links there, use the second one that says download from APK Top.

    (I don't know why, but every time I try to put APK and Top together, this site blocks it just fills anything containing that with ****** like it is a swear word or something)
  4. MYKEL61

    MYKEL61 Well-Known Member

    YEe, there is another post on this. Delete the update and you are fine. Just dont let it auto download again or else you will be back in the same boat.
  5. Boneysota

    Boneysota Active Member

  6. tripplesix

    tripplesix New Member

    I knew that this was a bigger problem than just me considering i JUST got the ICS update. It made me late for a semi-app i had.. and it was very aggravating. One difference for me though is that I got my Google Maps update a few days ago and it was all good. i played with it. i tested it. i used it. all good. Then last night i got the long awaited ICS update. This morning i tried to use google maps and all i got was reboot reboot reboot.
    I, like somebody mentioned above, downloaded Waze (because i knew of it and had used it before) and it got me to where i needed to go. i don't have time to figure out all that uninstall update this this that. it can sit there until they fix it, i guess.
    Unfortunately, ICS update messed up more than my Maps; also stock Calendar, i can't seem to create folders anymore, and everytime i download an app it goes onto my regular screen. :(
  7. johndawg57

    johndawg57 Member

    Some interesting info for you, the latest Rezound software, 4.03.605.2, seems to be working with this latest maps version. I too had problems with maps crashing my phone and also the traffic widget didn't work, just flashed the 4.03.605.2 RUU and all works now....if your looking for the RUU, I don't have the link in front of me but if you google rezound 4.03.605.2 the android police link will come up
  8. ckar

    ckar Well-Known Member

    Ok...let me get this. Google pushed an update to their crown jewel app that turned out to make it useless to countless HTC phones. Now here we are, five days later, and no fix?! Lame.
  9. mtbhk44

    mtbhk44 Well-Known Member

    Agreed - seriously lame. I just rolled back and it's fine.
  10. dmunz

    dmunz Well-Known Member

    If you istall this 6.9.2, how do you bolck the automatic update to 6.10.0?

    There used to be a button but I can't find it now...

  11. Ted1Jones

    Ted1Jones Well-Known Member

    In Google Play Store -> My Apps, each app has a "Allow automatic updating" check box. Uncheck this for Maps.
  12. MYKEL61

    MYKEL61 Well-Known Member

    Just know it will remind you that you have an update everytime you turn the phone on.. Just dont download it again and you should be fine. I have been ignoring the "updates available" for almost a week now..LOL
  13. Mr. Boom

    Mr. Boom Well-Known Member

    You can actually go into setting in the market and uncheck the box for "notify me of updates" Then you won't get anything.
  14. acejavelin

    acejavelin Well-Known Member

    But with Ice Cream Sandwich, you can just swipe away the notification. :)
  15. Puppa

    Puppa Well-Known Member

    Has anybody on this thread seen this crash with the Global update that rolled out after ICS on the west coast? I see #3 on that changelist is "Lock up"...
  16. MYKEL61

    MYKEL61 Well-Known Member

    Didnt know that...THANKS!!!
  17. johndawg57

    johndawg57 Member

    I am running 4.03.605.2 and have no maps problems, I did with the first OTA that came out. The global OTA is 4.03.605.1 but I skipped over that one so I'm not sure if it works
  18. NightAngel79

    NightAngel79 Bounty Hunter Administrator Moderator

    It is probably been filtered due to the site being spammed here... that or they host pirated material... not sure

    This map crashing stuff blows......
  19. Bhelios

    Bhelios Well-Known Member

    Sucks and blows at the same time!
  20. acejavelin

    acejavelin Well-Known Member

    Seriously, it is not that big of a deal, annoying as hell... but not terrible, just uninstall updates and it's fine, sideload 6.9.2, or switch to Waze. Or if you feel a little more adventurous, switch to the 4.3.605.2 RUU firmware, it is very stable and everyone who has used it thinks it is 10x better then the current version, fixing not only the Maps issue, but improving battery life, reducing the "heat" issue, reducing lockups, and is just smoother overall.
  21. johndawg57

    johndawg57 Member

  22. Colchicine

    Colchicine Well-Known Member

    I'm another person that had problems with G Maps rebooting my launcher. Unfortunately, it happened to me on the first day of travel to an unfamiliar area. I have never been more angry at my phone and I've never regretted relying on a smartphone more than I did a week ago. Of course I didn't know about this thread and I had to figure out on my own that it was G Maps doing it. I found this out AFTER doing a factory reset.
  23. hereitis

    hereitis Active Member

    Thanks for the tips. I feel adventurous. I was wondering if you might give me the starting point on switching to that RUU firmware? I am currently on CleanRom 4.1 with the unlocked bootloader and rooted. How do I get to the point that I can do what you're saying? Any information is appreciated.
  24. acejavelin

    acejavelin Well-Known Member

    There are several threads on it, I have not done it on the Rezound, but I know you need to relock the bootloader first. I would use one of the All-In-One toolkits or you can boot into hboot and issue the command 'fastboot oem lock' via adb. I am pretty sure from there you can just load the RUU, remember you will lose root and custom recovery (AmonRa, TWRP, CWM) too.

Share This Page